Jump to content

Sign in to follow this  
rsrandazzo

Some good news on CTDs (for a change!)

Recommended Posts

Captains-Remember when I told you that if we could find a method of reproducing a CTD, it would take us mere hours to solve it? Well.... I was right. :-)I've spent the past 15+ hours working with a half dozen individuals who were kind enough to run some tests, provide very detailed feedback and allow me access to their machines in order to pursue some details that have been nagging at us for the past couple of weeks.I am pleased to say that we have for-certain slayed one very specific type of CTD...I think it's normally considered bad form to admit fault (at least that's what you'd think by looking at some of our competitors, LOL!) but as you know we tend to be pretty candid here- good and bad- because we are more concerned with giving you good products/service than we are with our ego.... So I'm going to break convention a bit here. ;-)CTD Reported: Some customers reported that when loading the sim, the 747-400 would CTD immediately upon load. They further reported that sometimes they could load the airplane cold/dark- but it would CTD when they tried to power up the airplane.This immediately told us that some sound files were missing- but after running nearly 150+ installation tests we were unable to duplicate the problem.RESOLUTION: I've been exchanging email with a dozen or so folks for almost a month- asking a whole range of questions that might lead to a condition in which the problem was reproducable.Last night I received an email from a fellow named Niki that had one piece of information in it that nobody else had provided- and it started a chain of events that allowed me to reproduce his CTD at will.From there- it took less than 90 minutes to determine exactly what the problem was- and another three hours to implement and test a fix.Here's what I found: During the V1.10 update, we added the stick shaker sound to the airplane. Apparently, when I added this sound to the installer (full version and universal update) I accidentally assigned this sound file to the "Flight Plans" component. So- if you ran the installer and did not select COMPLETE INSTALL or did not select FLIGHT PLANS from the feature menu- then this single sound file would not install.....Without that sound file there- the sim will CTD as soon as the 747-400 is loaded....So, in effect we were right- we were finding NOTHING about the airplane that would lead to a CTD. Instead it was an installer failure that we had looked for and not found because none of us considered that a feature selection might cause such mahem. :-)Okay- so the problem has been fixed. And those of you afflicted with this insidious little out-of-wedlock-child-without-parents bug can obtain relief by doing one of the following:1) You can reinstall the entire V1.10- just make sure to install the FLIGHT PLANS while doing so. The problem will then go away.2) You can download the fixed copy of the Universal Updater from the downloads area right now if you like also... Once you have it downloaded, run it. It will complain that you don't need to update your installation- but select "Yes I want to anyway." The installer will then add the missing file....That will get you up and running.Now- before anyone leaps into the conversation to tell me that we haven't fixed their particular issue yet- let me offer a qualification- we have solved one instance that we were able to find attributable to the installer goofing up the installation. We have already attributed a number of other CTD reports to various freeware and commercial installations. (CTDs on landing, for example....)Keep us informed of problems you are having- and we'll keep investigating. This fix came out of a rather obscure observation made by an attentive user. It allowed us to reproduce a problem that we had not been able to reproduce- and now you have a solution for it. ;-)


Robert S. Randazzo coolcap.gif

PLEASE NOTE THAT PMDG HAS DEPARTED AVSIM

You can find us at:  http://forum.pmdg.com

Share this post


Link to post

Yayyy, I'm on my way!ETA: It works!! I can't believe it was something with the installer! Why, after a few dozen installs didn't I just let it put the flight plans in??!?! http://deephousepage.com/smilies/banghead.gifThanks for the fix! Thanks also to Ryan and Lefteris for their willingness to help, despite our schedule conflicts.


- Chris Jefferies

 

Asus Maximus VII Hero motherboard | Intel i7 4790k CPU | MSI GTX 970 4 GB video card | Corsair DDR3 2133 32GB SDRAM | Corsair H50 water cooler | Samsung 850 EVO 250GB SSD (2) | EVGA 1000 watt PSU

Share this post


Link to post

Orlaam-In my experience with hunting bugs- it's always something like that. "Why didn't I just......"I checked my Installshield log a few minutes ago. I have installed/uninstalled this product more than 220 times since 20NOV...(And no- I didn't trigger the auto-protection a single time. :-) )Good you are up and running.


Robert S. Randazzo coolcap.gif

PLEASE NOTE THAT PMDG HAS DEPARTED AVSIM

You can find us at:  http://forum.pmdg.com

Share this post


Link to post

Oh I can imagine. It takes someone with some serious patience to sit and program. I tried to learn several years ago and was not very good at it, but I could see how it would really be difficult and downright irritating. Although, this issue, is not unlike so many others in life. Fixing an engine, electronic equipment, and so on. Then you say "Hindsight's 20/20".Anyhow, I'm glad she fixed! Thanks for all the hard work. Happy New Year!


- Chris Jefferies

 

Asus Maximus VII Hero motherboard | Intel i7 4790k CPU | MSI GTX 970 4 GB video card | Corsair DDR3 2133 32GB SDRAM | Corsair H50 water cooler | Samsung 850 EVO 250GB SSD (2) | EVGA 1000 watt PSU

Share this post


Link to post

Chris,So glad to hear this solved it for you! A file count would have been one of the first things I'd have looked at if I'd been able to make it up there last week... (ended up not needing to do what I was going to do up in PHX...)


Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post
Guest neilb

Thats excellent news for those with the issues. Luckily mine were cured by a very quick uninstallation and reinstall.I used to work very heavily on Citrix Win/Metaframe systems, and applications could be extremely difficult to get working on that system. You could spend days on end just looking for the problem and when you found it then it might just be a change in file location, or ini change. Something very simple.Two tools I found very useful in this kind of debugging were FileMon and RegMon, both freeware from sysinternals.com. Both will show you file/reg activity along with the conditions of access, (success/failure etc).Might not be any use for you, but very handy in locating missing/unaccessible files/registry entries and that type of issue.I'm very impressed that PMDG would spend the time to fix such an issue when so many other software developers would wash their hands of this kind of issue.

Share this post


Link to post
Guest BravoOne

>I'm very impressed that PMDG would spend the time to fix such>an issue when so many other software developers would wash>their hands of this kind of issue.That's the difference between PMDG and others, the difference between quality and "junk" (s.l), the difference between costumer support and profiteering. That's what PMDG makes great and shows they are the best.An "objective" idea from a fellow simmer.Kind regards,Niki

Share this post


Link to post

Installed the Queen once more - this time I did a complete installation including flight plans and, well, it does indeed work! No CTD when I pushed the battery to ON from a cold & dark state. I have to admit I feel silly, LOL! I am off to fly my first flight in the Queen since upgrading my PC and if anything shows up, I'll report back here. But so far, YES, doing the Complete install cured my CTD!Thank you very, very much, PMDG & Niki! :) All the best in the new year!Regards,Jure Dolanec

Share this post


Link to post

Hi Robert.Well, it's working!!!! :D :D :D Now I can sleep without nightmares.Many thanks Robert, especially that you don't stop finding this silly bug. Some other add-on developers will just stop comunicate with few customers, who has a problem. Or will simply repeat a magic sentence "We can't reproduce this problem". I know one of these "developers". Unfortunately.So, many thanks again and I'm looking forward to 747-400F and MD-11. :-waveMichal Salek.

Share this post


Link to post
Guest morvious

How small things can lead to such irritating things :)Allthough I didn't had this problem (My last CTD was due to a bad TCAS.dll) I was always worried that it would come to me.The 2 best product designers (LVLD and PMDG) show that they can not only design incredible aircraft, but also show that they can provide exelent customer support!!Thumbs up, and there should be also awards for these kind of things! Now, lets bring that Freighter on ;)

Share this post


Link to post

>Chris,>>So glad to hear this solved it for you! A file count would>have been one of the first things I'd have looked at if I'd>been able to make it up there last week... (ended up not>needing to do what I was going to do up in PHX...)Well, I really appreciate the idea that you were willing to actually help in person. Not too many people would take the time to offer such assistance. Thanks again.Happy new year!


- Chris Jefferies

 

Asus Maximus VII Hero motherboard | Intel i7 4790k CPU | MSI GTX 970 4 GB video card | Corsair DDR3 2133 32GB SDRAM | Corsair H50 water cooler | Samsung 850 EVO 250GB SSD (2) | EVGA 1000 watt PSU

Share this post


Link to post
Guest poschrob

hi!now it's working here, too! no more CTD:)))only one more thing: if I click in the menu on "Reset flight" the PFD and the ND remain black, only the upper eicas works. any ideas why? I know it isn't such a big issue but it'd be great to know why.kind regards and a happy new year!Rob

Share this post


Link to post
Guest

just remember everyone to install FSUIPC again as the updater overwrites it. There is a beta release in Petes forums which helps with wind smoothing bugs so go grab that!Thanks for the help Robert! Looking forward to the freighter

Share this post


Link to post
Guest UPS523

Ok now that the ctd probelm is solved [i never had one] Will this speed up the release of the 400F thx

Share this post


Link to post

Rob-Sounds like you need to turn the standby power switch ON, and/or ensure you have a functioning source of AC power....Oh- and don't forget the manuals... yeah. Read those too. :-)


Robert S. Randazzo coolcap.gif

PLEASE NOTE THAT PMDG HAS DEPARTED AVSIM

You can find us at:  http://forum.pmdg.com

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    2%
    $715.00 of $25,000.00 Donate Now
×
×
  • Create New...