Sign in to follow this  
haldir

Possible fix for Accel/SP2 menu crashes...

Recommended Posts

Hey guys. This is for Nvidia 7 & 8 series owners experiencing menu CTDs (if you haven't all switched to ATI by now out of frustration, I almost did).I have a possible solution to the full screen menu crashing problem.Look in your bios for any of the following settings and disable the ones you find:-C1E function-Enhanced Halt-SpeedStep-Enhanced Intel Speedstep (EIST)Most intel dual or quad core cpus have at least one of these functions available to them. Not sure about single core.C1E in my case was the one causing full screen menu access CTDs. I have an 8800 Ultra.These functions allow the system to lower its CPU voltage, multiplier, or FSB speed in cases where cpu load is low, in order to conserve power and reduce heat. Unfortunately for me it turns out they're tripping up my nvidia driver (169.21) somehow. Accessing a menu in the sim is a case where the cpu is going from max to pretty much idle instantly.I'm not going to come back here after this post and say that it didn't actually fix it, it certainly did. I was able to get FSX to crash on menu access within 2-3 attempts on any run before this. After disabling C1E on my system I was able to sit there for about an hour and a half randomly accessing menus in rapid succession. Tried it on all different kinds of aircraft while warping myself all over the world. Restarted FSX several times for kicks, and not one hiccup. I finally got bored, re-enabled C1E, FSX crashed in 2 menu selections.Definitely give it a try guys. The risk is nil. I really hope this helps some of you, I know how frustrating this particular CTD is. Apparently this function is known to cause stability issues, particularly on overclocked systems.Some further and very enlightening reading if you're interested:http://www.overclock.net/intel-cpus/220297...ng-windows.htmlFor reference, my system:Intel QX9650 Penryn @3.8ghzNvidia 8800 ultra 768mb2 gigs 1066 mhz Corsair XMS DDR2Gigabyte x38 chipset moboFingers crossed and good luck!-Mike

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Mike, I did this fix in Bios, so far working for me, no more menu crashes with Aceleration FSX.....

Share this post


Link to post
Share on other sites

Mmm... none of those settings appear in my BIOS. I'm using a dual core AMD CPU, so this might only be a fix for you Intel boys. Glad it works for you though - the battle is gradually being won!EDIT: Tried disabling the AMD equivalent - "Cool'n'Quiet" - in the BIOS and it made no difference. SP2/Acceleration is still the same crock of crap that it was before. Oh well, worth a try I guess.Vox

Share this post


Link to post
Share on other sites

Mike, I have a Dell XPS w/ Nvidia Gforce 7300. I made my way into BIOS and found Speedstep there, unfortunately "disabled" is the default. I have found that solution for me is to flip from full screen to windows mode to make any changes from menu drop down and then to flip back after FSX makes change. I have been told that this problem is a Nvidia driver problem. I have latest driver and not sure if this is the case. Your suggestion sure makes sense and I wish it was an option for my system. Thanks for posting, Paul

Share this post


Link to post
Share on other sites

>I have been told that this problem is a Nvidia driver problem.This is the general belief, yes. However, what I fail to see is how SP1 doesn't cause the same CTD that SP2/Acceleration does, with the same NVidia driver? MS changed something in SP2, but because they refuse to provide any further patches, they're happy to blame NVidia.It's all quite sad really.Vox

Share this post


Link to post
Share on other sites

Adamsman, did you look for C1E or any of the other settings? They're typically under the power management section of the bios, and I haven't seen a computer yet that has one with out the other (speedstep and C1E). If you don't have access to the C1E function there may be a bios update for your motherboard that gives access to it, though obviously bios flashing is risky. Still might be worth looking into though.Going to windowed mode can help yeah, but it can still crash on the transition between them.Vox, I haven't owned an AMD since the intel core2duo range came out and promptly smacked AMD into the last century, so I have no idea on equivalent bios settings for those. :(However I totally agree with you on where the problem lies. Since no other game crashes from this, and neither did SP1 or RTM, then where in fact does the problem lie? Windows didn't change, driver didn't change, sooo ummm??? ;)All I can say is that C1E was definitely the root cause in my case, the rapid changes of voltage and cpu multiplier dropping as soon as I accessed a menu. There's something about that which either the nvidia driver or FSX sp2 doesn't like. Still hasn't crashed for me since.Good luck!

Share this post


Link to post
Share on other sites

Haldir I'm the guy where your suggestion about the BIOS change solved my menu crash issue,,,, it is amazing the billion dollar goliath Microsoft cant see this and regular users using a lot of trial and error can... leave it up the people...

Share this post


Link to post
Share on other sites

Since it's proven that this *can* be one of the causes of the SP2/Accel menu crashes (there are probably others), you can download Cpu-Z to determine if your motherboard is telling your cpu to change its voltage/speed/multiplier etc under changing load conditions...Cpu-Z is just a simple and very handy free utility that gives realtime processor and memory state information.http://www.cpuid.com/cpuz.phpDownload link is at the top left of the page.You'll see something like this when you run it:http://forums.avsim.net/user_files/183441.jpgTo test it, start cpu-z, then start FSX or any other demanding program in a window and see if any of the highlighted (red) values change. If they do, then your motherboard is set to allow the cpu to alter its frequency, voltage etc, via C1E, speedstep etc. If no changes to those values occur then speedstep, C1E etc are all disabled. If FSX still crashes when none of these values change under load then the problem I guess must lie elsewhere.Good luck!-Mike

Share this post


Link to post
Share on other sites

Mike, Thanks for the info. I downloaded CPU-Z and checked it out as you instructed. My PC Dell XPS 410 showed no movement in the areas you highlighted. As my bios indicated Speedstep is disabled. I have had no crashes or errors since I have used the method of flipping to windowed mode. I guess I can live with that till someone possibly does a 'fix'. I'm not holding my breath. Paul

Share this post


Link to post
Share on other sites

i went into my bios both CE1 and speedstep were already disabled so no fix here for me an suggestions? Missing my Sim!!Windows XP latest Nvidia DriverIntel Core 2 Duo E6600 Processor 2.4MHz overclocked to 2.93MHzMSI 975X Platinum PowerUp Edition MotherboardGeil 4GB RAM (4 x 1GB 800MHZ Ultra low Latency DDR2 Dual channel)2 x Seagate Barracuda 7200.10 320 MB Hard Drives 16MB cache2 x Asus DRW-1608P3S 16x16 DVD Dual Layer620W Enermax PSUCreativeSound Blaster X-Fi Xtreme Music Sound Cards with Creative EVGA GeForce 7950 GX2 Superclocked 1024MB GDDR3 PCI Express Graphics CardMatrox Triple Head2 Go3 x Samsung SM-940BF 2ms LCD 19'' Monitor

Share this post


Link to post
Share on other sites

Gents,I did download this utility, and found no movement in any of the categories; and could not find the settings in my Bios area either. My System is about a year and a half old which is:Dell XPS 400; Dual Core 2.8 ghz2 Gig RameVGA GeForce 7950 GX DDR3 PCIe Card with 512 meg160G 7200 Seagate HDNow, I did download the latest drivers from Nvid and install them (using the uninstaller, going to safe mode, running that nifty litte program to "really" uninstall the old drivers, then installing the newest ones).Next, I have NHancer running. I installed SP2 for FSX, ran FSX to the main menu, exited, defragged, rebooted, and then restarted FSX. I ran the default flight, used my mouse to bring up the menu, and as soon as I selected the option to turn off Full Screen; bamn, crash.So, I restared FSX, this time I just tried to use the key function Ctl Alt....bamm, crash.So, I thought, maybe I should shut off NHancer and try it again. I shut it off, restarted FSX, pulled up the menu while in full screen mode....un-checked Full Screen and what do you know, it went to windowed mode! I was ALLLLL excited! Flew around, changed acft, locations, time....all worked. So I exted FS; restarted and it goes to Windowed mode....cool, lets go back to full screen....cool it worked, lets go back to windowed.....bamm....crash. WTH I thought? So I started NHancer back up, started FS which now goes to windowed mode and all works good, but as soon as I go to full screen and try to use the menues....crash....with Nhancer both off and on. What happened? I have no clue. But at least I can use SP2 which seems to run a bit smoother with a new FSX.CFG file and no modifications....in windowed mode....which I guess I prefer. Just thought I'd share my story.Ken

Share this post


Link to post
Share on other sites

It's the old pass the buck solution--- - We don't know so let's blame nvidea!!!Don

Share this post


Link to post
Share on other sites

Agreed, to some extent. They can say all they like about nvidia's hardware, or drivers or whatever, and there's obviously blame to be laid at nvidia's feet as evidenced by the lack of issues with ATI cards, but the crux of the issue is that *something* was changed in sp2 to cause this utter showstopper of an incompatibility for a wide range of nvidia hardware. This problem may have always been there waiting to happen, but the fact of the matter is that it doesn't occur in RTM or SP1. Since the drivers, OS, and hardware didn't change, then what does that leave?The change may have been well within the lines of the directx specs and limits, but that doesn't help us. The way I see it, if Crysis didn't exist then Nvidia might actually work on this problem. Unfortunately it does, making us (and just about every other issue with every other game) a very very small blip on their scope for some time to come. Crysis, as evidenced by the 'fixes' in the last 10 driver revisions, is literally all they care about at this point, which is really quite sad.I've posted about it and written to them, never a response, and I don't ever expect one. If MS is going to point the finger solely at Nvidia and not help them by taking a look at what code they changed in sp2 with menus, then it's going to come down to us users to find the root cause of this.At least some fixes are working for some people, so there is some hope. The fraps issue and driver changes for others (though I think both are a bit of a red herring) and the C1E/speedstep for me. I'd love to know what they have in common though.

Share this post


Link to post
Share on other sites

My crashes have some how gone away with the latest Nvidia Beta driver.:)

Share this post


Link to post
Share on other sites

Thanks for posting that note on the beta driver. I was just about to ask if I should just go ahead and waste a day or two reninstalling Vista64, FSX, SP1, SP2, etc, etc.Since FSX just crashed again on descent, I have some time to spare.So, I may download the beta and see what happens.I did see a note here, http://www.pcstats.com/NewsView.cfm?NewsID=65134 that Vista SP1 is close to public release. Maybe that will cure some of the issues also.Richard

Share this post


Link to post
Share on other sites

I really appreciate the tip - I was excited when I found both CIE and EIST were enabled in my BIOS. Unfortunately, disabling both made no difference - I still get either a CTD or a lockup when I use menu items. I changed from a 63.75 to a 69.21, but no help there, either.Everything seemed to work if I use window mode to make menu changes, but I much prefer full screen. Dale

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this