Sign in to follow this  
betelgeuse

GPS and CTD

Recommended Posts

I've been flying FS9 and its predecessors for many years. A couple of weeks ago I installed Radar Contact 4.3 and was able to use it successfully. A couple of days ago I installed some freeware Airbus and B737 aircraft.All of a sudden yesterday FS9 has become completely unusable. This occurs even with the default Skylane. Basically, the program crashes to desktop when I change something. It might be opening the GPS, or undocking a window. It happens with Radar Contact inactive or active - it seems to make no difference. I know that CTDs are usually due to scenery conflicts. I have disabled a freeware scenery program which affects terrain 70 miles away. The terrain where I get the errors is default FS9. I am using simple clouds and the sliders are set mid-range. I aim for 30 fps. I run a second monitor for undocking popup panels and AI, but the problem occurs even when the second monitor is disabled.I am running XP Pro with a medium spec machine - AMD64 4000+, 1GB DDR, Nvidia 7800 GTX 256 MB, and lots of HDD. Any time in the past when I induced CTDs by some action of my own, I reckoned it was due to CPU overload and I took off some of the load! This time it happens even when the load is relatively low. Over the years I've messed a lot with addon sceneries, planes, gauges etc. I've never reinstalled FS9 since I installed it back in 2004! Maybe it is corrupted. Is it a big job to reinstall? Can I keep my addons etc? Or can someone think of a simple explanation for my problem?John

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>I've been flying FS9 and its predecessors for many years. A>couple of weeks ago I installed Radar Contact 4.3 and was able>to use it successfully. A couple of days ago I installed some>freeware Airbus and B737 aircraft.>>All of a sudden yesterday FS9 has become completely unusable.>This occurs even with the default Skylane. Basically, the>program crashes to desktop when I change something. It might>be opening the GPS, or undocking a window. It happens with>Radar Contact inactive or active - it seems to make no>difference. >>I know that CTDs are usually due to scenery conflicts. I have>disabled a freeware scenery program which affects terrain 70>miles away. The terrain where I get the errors is default FS9.>I am using simple clouds and the sliders are set mid-range. I>aim for 30 fps. I run a second monitor for undocking popup>panels and AI, but the problem occurs even when the second>monitor is disabled.>>I am running XP Pro with a medium spec machine - AMD64 4000+,>1GB DDR, Nvidia 7800 GTX 256 MB, and lots of HDD. > >Any time in the past when I induced CTDs by some action of my>own, I reckoned it was due to CPU overload and I took off some>of the load! This time it happens even when the load is>relatively low. >>Over the years I've messed a lot with addon sceneries, planes,>gauges etc. I've never reinstalled FS9 since I installed it>back in 2004! Maybe it is corrupted. Is it a big job to>reinstall? Can I keep my addons etc? Or can someone think of>a simple explanation for my problem?>>JohnJohn you have my sympathies.You say you recently installed some freeware aircraft,perhaps you should start with these and remove them first(they are easily put back).Although a lot of CTDs seem to be caused by addon scenery issues its not always exclusively so.I personally am vary wary off addon sceneries the only ones i have at the moment are the seven road and rail bridges+FSGlobal SE(payware)and i am quite content with that as i can takeoff,climb ,cruise, descend and land.Cheers AndyPS which 320s and 737s did you use.

Share this post


Link to post
Share on other sites

Thanks, AndyI installed these:iFDG Aer Lingus A319-114 repaint by Geoff DoddsiFDG Aeroflot A319-100iFDG Aer Lingus A320-214Moach B737-700 in Aer Lingus livery (checking the .cfg file makes me wonder - the texture displayed perfectly but it is not labelled as a 'Moach' model - unlike my other Moach repaints).'Kittyhawk' B737-800 Aer Lingus repaint.So much for the Irish adventure! CPU overheating can cause CTDs but there was very little dust inside - I air dusted it anyway. virus check showed no threats. I suppose I could use the XP System Restore and go back to before I installed RC and these new aircraft. Or would I be better to re-install FS2004? Any more thoughts, anyone?

Share this post


Link to post
Share on other sites

Hello JohnI would not want to advise you on reinstalling.But i sometimes feel unin and rein seems to advised as a solution for every problem and i wonder if its always the case .By the way when you uninstall unless you remove everything physically yourself a lot of files remain untouched.(on this you need more expert advice than i can provide)On your aircraft models i have loads of IFDGs with no problems , Moach and Kittyhawk are well known to.Are you fully up to scratch on installing aircraft?Are you sure it could be an overheating issue?according to the experts my computer should be keeling over with overheating problems ie i only have a 250 watt power unit with quite a lot of addons.... soundbalster,cordless joysticks and mouse external drives etc a good but only mid-range Gcard G-force 6600 but even Nvidea recommend a 300 watt minimum power supply for that but i can say i have never had a hint of a problem even on long four plus flights.I do always run my comp with a side panel off,but thats not because of any trouble i was having but as a precaution.If i was in your position i would defiantly try a system restore to a time when FS9 was running correctly you cant really do any harm as you can undo a restore back to your current setting anyway.Finally in your case it might be an idea to list your system specs as more experienced boffin types may have some more ideas you can try.I hope you get it sorted CTDs can be so frustrating.cheers Andy

Share this post


Link to post
Share on other sites

Thanks again, Andy. I'm usually alright with installing aircraft. I've installed many over the years, and I've hundreds of AI planes from PAI, Evolve AI etc. I've even tweaked some FDEs and uploaded, and made a few sceneries. So, I am not a novice, but not an expert either! I had overheating problems once before but I'm doubtful it can be that this time. I have a 500 watt PS so that should be okay. Until two weeks ago I rarely had problems - none like this anyway. I flew for hours with complex planes like the ATR72, Dreamfleet Fokker 50 etc, with panel popups on mon 2 etc, AI all around, real weather, etc. I fly on VATSIM too - no problems. So, it must be something to do with the recent installs.I will experiment a bit more with the present setup. If I cannot get it running by this evening I will do a system restore. All the best!John

Share this post


Link to post
Share on other sites

It could be that a gauge was overwritten or just added that uses a support dll in your modules folder.I would also get the latest FSUIPC here for FS9:http://www.schiratti.com/dowson.htmljust in case.If your system becomes unstable after opening a sub-window in FS, then it could not hurt to check your video driver, DX9 version, etc. I hope you are using an add-on video card with about 256MB ram and not using an on-motherboard video setup which steals ram from FS.

Share this post


Link to post
Share on other sites

Thanks, guys! Some good news. I just flew for about 5 hours in Alaska without problems. I even used the Moach 737. In fact I tried to get the system to CTD and could not! The bad news is that if I try to fly anywhere near the Irish Sea - Ireland, England, Isle of Man, I still get CTDs. I tried a system restore but it made no difference. I removed the latest addon aircraft files manually but this made no difference either! I got to thinking that I installed an FSG UK/Ireland scenery demo program in December. At the time I liked it and it ran well. I wonder now if it was 'time-limited'??? The demo has two .bgl files installed in ...SceneryWorldScenery. There is no uninstall facility and the program does not appear in the 'Add or Remove Programs' list. I renamed these files as .bbb files but this made no difference. I still got CTDs between Ireland and Isle of Man. Maybe I need to remove these files completely. I cannot find any other non-default sceneries for this area but I guess there might be some lurking. I tried changing to summer season as I know that winter has caused CTDs in some areas but the problem remains. So, there's been progress of a sort. At least I am sure now that I have a scenery problem. Thanks for your suggestions. As you say, Andy, CTDs are very frustrating. That's putting it mildly...Ron, Nvidia 7800GTX 256 MB. The latest FSUIPC is installed.

Share this post


Link to post
Share on other sites

More bad news! The CTDs in the area between Ireland and the Isle of Man persist. The problem appears to be related to this area only. I disabled all my addon scenery but the problem remains. I checked for dual AFCADs in the area but could not find any. As I said in my first post, the CTD occurs when I do something - often opening the GPS but it could be something else. I am getting frame rates of around 30 fps and so I cannot believe the CPU has a huge load. There is obviously some conflict going on in this geographic area only which causes the problem. The CTD doesn't always occur in the same place and sometimes I can open and use the GPS fine! :-grrIf anyone can suggest what to do next (don't tell me FSX please!) I'd be grateful. Perhaps my setup needs a clean re-install. John

Share this post


Link to post
Share on other sites

>Thanks, guys! >>Some good news. I just flew for about 5 hours in Alaska>without problems. I even used the Moach 737. In fact I tried>to get the system to CTD and could not! >>The bad news is that if I try to fly anywhere near the Irish>Sea - Ireland, England, Isle of Man, I still get CTDs. I tried>a system restore but it made no difference. I removed the>latest addon aircraft files manually but this made no>difference either! >>I got to thinking that I installed an FSG UK/Ireland scenery>demo program in December. At the time I liked it and it ran>well. I wonder now if it was 'time-limited'??? The demo has>two .bgl files installed in ...SceneryWorldScenery. There>is no uninstall facility and the program does not appear in>the 'Add or Remove Programs' list. I renamed these files as>.bbb files but this made no difference. I still got CTDs>between Ireland and Isle of Man. Maybe I need to remove these>files completely. I cannot find any other non-default>sceneries for this area but I guess there might be some>lurking. I tried changing to summer season as I know that>winter has caused CTDs in some areas but the problem remains. >>>So, there's been progress of a sort. At least I am sure now>that I have a scenery problem. Thanks for your suggestions. As>you say, Andy, CTDs are very frustrating. That's putting it>mildly...>>Ron, Nvidia 7800GTX 256 MB. The latest FSUIPC is installed. Hello againIt does seem a bit of a coincidence that the area you are having problems with is the area where you tried a demo scenery addon.I would try removing the two BGLs to somewhere safe and see what happens.The seasonal CTDs you describe should not be present if you have installed SP1.Does the Irish scenery show in the 'scenery library'Andy

Share this post


Link to post
Share on other sites

I deleted the two .bgls but this made no difference. I still have the CTDs. Perhaps the demos did something which is not reversible - there is no uninstall for these. The local scenery is now default except for some AFCAD files. The FTGenesis UK/Ireland demo scenery never showed in the Scenery Library. The two .bgls were put in the ....SceneryWorldScenery folder as per the install instructions. These two lovelies are are now ex-bgls!I'm really out of ideas with this one. I wonder if I should copy/paste the scenery area .bgls from a copy of FS2004 which I keep on an old machine.

Share this post


Link to post
Share on other sites

>I deleted the two .bgls but this made no difference. I still>have the CTDs. Perhaps the demos did something which is not>reversible - there is no uninstall for these. The local>scenery is now default except for some AFCAD files. >>The FTGenesis UK/Ireland demo scenery never showed in the>Scenery Library. The two .bgls were put in the>....SceneryWorldScenery folder as per the install>instructions. These two lovelies are are now ex-bgls!>>I'm really out of ideas with this one. I wonder if I should>copy/paste the scenery area .bgls from a copy of FS2004 which>I keep on an old machine. It might be worth a try.If you back up any files first.Yesterday i reinstalled the complete texture folder because i made changes which i hadn't backed up and couldn't change,so i took the original texture folder from the FS DISC backed up the one i wanted to change and dropped it in and have had no problems.Do you have lots of stuff in your addon scenery folder.I only ask because a couple of years ago i was having a bad bout of the CTD blues and decided to empty out my addon scenery folder as i had all sorts of stuff in it i didn't even recognise anyway sceneries are easily replaced(tedious but easy)i don't remember what it was that prompted me to clear out the ADDON SCENERY folder but i did and in my case that stopped that particular bout of CTDs.All these sorts of things are worth trying provided you BACK UP anything that might be important first.I call it Sherlock Holmes modeBy the way have you checked out the CTD forum here at AVSIM.CHEERS Andy

Share this post


Link to post
Share on other sites

AndyThanks again.Yes, I have a lot of Addons. I used ScanAFD to detect duplicate AFCAD files and I deleted about 20 of these. It made no difference! grrr! I take your point about stripping out the Addon Scenery folder completely but I already have it disabled in the Scenery Library. Is this not enough?Taking another approach I had a look at my fs9.cfg file. The first thing is that under ....ApplicationsMicrosoftFS9 I have the following files:fs9.cfg.txtfs9.cfgscenery.cfgNewScenery.cfg (wherever this came from I have no idea)scenery.xxx (?)wxstationlist.BIN (ok I think)AIRCRAFT (folder)FACILITIES (folder)SCENERYCACHE (folder - empty).Does this look right to you? It doesn't to me and it is different to my back up FS2004. It has these:The three folders abovefs9.cfgwxstationlist.BINOdd to say the least but what to do?John

Share this post


Link to post
Share on other sites

>Andy>>Thanks again.>>Yes, I have a lot of Addons. I used ScanAFD to detect>duplicate AFCAD files and I deleted about 20 of these. It made>no difference! grrr! I take your point about stripping out>the Addon Scenery folder completely but I already have it>disabled in the Scenery Library. Is this not enough?>>Taking another approach I had a look at my fs9.cfg file. The>first thing is that under ....ApplicationsMicrosoftFS9 I>have the following files:>>fs9.cfg.txt>fs9.cfg>scenery.cfg>NewScenery.cfg (wherever this came from I have no idea)>scenery.xxx (?)>wxstationlist.BIN (ok I think)>AIRCRAFT (folder)>FACILITIES (folder)>SCENERYCACHE (folder - empty).>>Does this look right to you? It doesn't to me and it is>different to my back up FS2004. It has these:>>The three folders above>fs9.cfg>wxstationlist.BIN>>Odd to say the least but what to do?>>John>>John As i said i am no expert but perhaps your present CFG is looking for the Irish scenery you said you installed but now you have removed (or a tleast altered)and perhaps thats causing a conflict and crash.I am just going to look at mine now.In my .........C:Documents and SettingsFlight simulatorApplication DataMicrosoftFS9I have these files and bits and pieces...Aircraft folder,Facilities and Scenery cache folders.Something called dxdiag XML Document,FS9 AND scenery CFGs and FS9 cfg Text Document thats it.Have you tried removing or deleting your FS9 CFG file this will force FS9 to create a new when you next start it up.You will end up back with the FS9 default settings but these are quickly reset.PS that new scenery CFG could be something to do with trial scenery you installed.cheers Andy

Share this post


Link to post
Share on other sites

Thanks, Andy, I re-set the FS.cfg but still get CTDs in the Irish Sea area west of Isle of Man. I thought I had solved it - flew Newtownards to IOM, no problem. Flew back to Belfast City, landed, turned off the runway, CTD! Grrrr!I have NOD anti-virus which I update every day. I did a full scan with this as soon as the CTDs started to appear. Nothing showed. Yesterday I ran a full scan with a specific trojan file detector. It found a trojan: Found trojan file: C:WINDOWSsystem32flt1chk3.dll (Obfuscated.334)I've no idea what this means but it's clear that it has something to do with flight! Needless to say this file has been cleaned out. What is the function of this file and could it account for CTDs? John

Share this post


Link to post
Share on other sites

>Thanks, Andy, I re-set the FS.cfg but still get CTDs in the>Irish Sea area west of Isle of Man. I thought I had solved it>- flew Newtownards to IOM, no problem. Flew back to Belfast>City, landed, turned off the runway, CTD! Grrrr!>>I have NOD anti-virus which I update every day. I did a full>scan with this as soon as the CTDs started to appear. Nothing>showed. Yesterday I ran a full scan with a specific trojan>file detector. It found a trojan: >>Found trojan file: C:WINDOWSsystem32flt1chk3.dll>(Obfuscated.334)>>I've no idea what this means but it's clear that it has>something to do with flight! Needless to say this file has>been cleaned out. >>What is the function of this file and could it account for>CTDs? >>JohnHello again JohnI cant help you with that file thats a bit beyond my current FS tech knowledge.There is a program (freeware)called filemon that some people swear by,and what you do is start it up before a sim session and when you get your CTD you then view your filemon readout and its is supposed to show or point to what particular program or file or whatever caused the problem.I have to say it didn't help me that much,but then again i am not that tech savvy.Have you tried entering your C:WINDOWSsystem32flt1chk3.dll>(Obfuscated.334)[/i][/b] into google and see what it turns up?also try just entering the flt1chk3.dll part as there are sites that explain DLL functions as well.I am surprised you have not had more help from others here as there are some clever bods on this site.cheers AndyPS have you tried a flight in your problem area since removing this problem file?

Share this post


Link to post
Share on other sites

No! Removing the 'trojan' made no difference. Again, I flew for ages and thought I'd cracked it. Asking ATC for an IFR clearance caused the CTD this time. I googled for that file but it seems that it comes up as a false positive with some anti-virus programs. I've no idea what problems I've caused since removing it! As far as I can tell things are no worse at least. I will try your filemon and see what happens. After that, I will uninstall Radio Contact 4.3 in case it is something to do with ATC conflicts. I upgraded from 4.0 relatively recently.I'm taking a break from CTDs this weekend so no testing till Monday at the earliest. I'm in London to go with my son to see Spurs V Man U. Much more fun!Will post again once I have a stable system.

Share this post


Link to post
Share on other sites

Make sure you are using FSUIPC minimum 3.75 or newer. Make sure you also obtain the latest Makerwys.exe and then run the scenery rebuilder.Both are at: http://www.schiratti.com/dowson.htmlRC should not be causing a CTD specific to any scenery area.

Share this post


Link to post
Share on other sites

Thanks, Ron. FSUIPC 3.75 is the latest for FS9 and, as I said, is installed. I've not heard of Makerwys.exe. What does it do? John

Share this post


Link to post
Share on other sites

Makerwys.exe is installed in your FS root directory. It is called by the RC Scenery Rebuild utility. It searches through all of your scenery folders as entered in your FS Scenery Library settings and extracts airport and runway data including runway navaids. The resulting files are copied to the RC data folder and then RC further processes these to create a couple of more data files.RC uses these files to establish your airport environment and calculate what it needs to establish proper ATC guided departure and arrival. It also helps RC pick the best runway for arrival based on priorities of active weather conditions and runway properties (headings, length, etc)including types of navaids. It also provides what runways are closed in that they are excluded from the database.Also excluded are properly created pseudo runways used in the "star" system created over at project AI so non-parallel runways can be simultaneously active. Unlike FS ATC which will show these in various lists such as choosing your own runway, RC will not showing only valid runways.

Share this post


Link to post
Share on other sites

Thank you again, Ron.I ran makerwys.exe and I've attached part of the .txt file. This appears to contain some errors but none I think that could be relevant to my CTD problem at EGAD, EGAC, EGAA, EIDW, EGNS. I'm not sure how to interpret the file - maybe you can help with this?Since my last posting I've uninstalled RC4.3 and I've replaced the relevant Eurw scenery files (AB946120.bgl; AP946120.bgl files etc) with files from a backup FS9 install on an old PC. Since then I've flown many hours around Eastern England and pushed the simulation very hard without causing a CTD. However, as soon as I fly in the Belfast area I find the same old problem. :-grrI've managed to come up with some factors:1. The CTDs always occur in a triangle between Belfast (N. Ireland) - Isle of Man - Dublin (Rep of Ireland). 2. They are often associated with the use of the GPS. The GPS can be used okay sometimes but other times when the map appears on the Garmin screen it quickly rotates, and another CTD!3. They are also associated very strongly with turns off the runway when ATC requests a change to Ground frequency. This frequently, but not always, prompts an immediate CTD.At the start of all this I thought I had a scenery problem because the CTDs occured in only one area. I am wondering now if this can be true. Is it possible that they are due to ATC, ATIS, or Navaid frequency conflicts arising out of the Radar Contact install?I do not know where to go from here and I'd be grateful for advice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this