Sign in to follow this  
John_Tavendale

Radeon 9700 Pro & Stuttering is driving me mad!

Recommended Posts

Hey folks,Maybe I am missing something, I really don't know, but I am rather frustrated with my Radeon 9700 Pro.When I run the sim and go into spot mode, it starts to stutter when I pan around. I have tried different display settings, the only thing that elminated the stuttering was to untick the mutiple textures tab. Obviously this is not a good solution as you lose a fair bit of detail :(I have tried different levels of AA and AF, the stuttering is the same whether its 2x AA or 6x AA.Stuttering is elminated using 1024x768, but I am used to running 1600x1200 and I really don't want to drop down the resolution. I did buy a Radeon because they can run at those resolutions problem free (Well, expcet mine.. :-lol)I am running DX9.0, I've tried using the drivers from the CD, also Cat 3.1 & Cat 3.2, all have the same effect. I've tried lowering the AGP from 8x to 4x, turning off fast writes, increasing the voltage in the BIOS, turning off AGP texturing in DX. I even deshimmed the core, replaced the heatpad with some Artic Silver 3, made no difference. The power connector isn't running off another device. It has it's own IRQ, so no conflict there. Benchmarks just fine, just won't behave in FS.Does anyone have any suggestions? I'm at witts end, I know what these cards can do, I just want mine to run properly.Thanks in advance :)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Did you install the latest control panel for the Catalyst drivers you are using? The 3.1s and 3.2s have their own control panels.Also, when you uninstall old Radeon Drivers make sure to delete the ATI Folder after the uninstall!!!Also make sure to delete ALL the old Radeon registry entries!!!!!! Whether you use Windows 98/ME/2000/XP you still HAVE TO MANUALLY DELETE a few of the entires. For some reason the uninstall in the "Add/Remove Programs" file doesn't erase all of them (it did for Nvidia drivers in XP and 2000 but not these for some reason!!)!!Hope this helps John.Shane

Share this post


Link to post
Share on other sites

Shane,I did install the matching CP with the drivers.I removed my old drivers, boot into safe mode, search for ati*.*, deleted all the files, rebooted and installed the new drivers.However I didn't erase the entries in the registry. The suttuers happened from the inital install, so I don't know if that would make a difference, worth a try though :)

Share this post


Link to post
Share on other sites

John have you made sure you have nothing in the background like motherboard monitor or any other such polling programs? I am using a 9700 pro on a new install of Win2k with no stuttering. Rarely when I'm turn on the taxiways it might give a hint of a stutter but otherwise it's silky smooth in all areas, even with hefty 3rd party stuff. Make sure you have no other programs that can be causing this.Also, what mode are you running in? I am going with stock Smartgart recommendaitons with AGP8x, DirectX 9.0, 128mg AGP aperture, fast writes on. Everything is working great with this card.Good luck that can be annoying.Noel

Share this post


Link to post
Share on other sites

Same problem here. This card is faster than my old nVidia 4600, but it sttuters a lot!. Really I

Share this post


Link to post
Share on other sites

Noel,I don't run MBM, but I often use MSN chat, browse and ICQ. I know the stutters lessen when I am not running these programs, but my old Ti4600 didn't have any trouble with this.I mean, when the time comes to fly online and I have RW & SB running, the stutters will appear again.

Share this post


Link to post
Share on other sites

I have just changed to a Radeon 9700 Pro and touch wood don't have the stuttering problems - but a lot of people do. A good forum on the Radeon is Rage3D - the following is the stutter thread -http://www.rage3d.com/board/showthread.php...readid=33664557The card is superb for FS2K2 - my settings on a 19" Monitor -1600x1200x32, Refresh rate 75, AGP4, FW on, AAX4, AFX16, VSync off, I do have the DX sound accleration down one notch in DxDiag to standard acceleration.My system - AMD2400@2136, A7V333 Bios 1015, 512mb PC2700, Rad9700 Pro with cat 3.2 WinXP Pro - no SP1 update.I did use the DH Driver cleaner from http://www.driverheaven.net/cleaner/ to uninstall drivers first - it works with Nvidia and ATI.One thing I did see - try to disable all icons in the tray - that sometimes helps.Good luck tweaking, Shep.

Share this post


Link to post
Share on other sites

Thanks Shep. I followed that very guide. Turned off all services I don't need, only load one or two things on startup. I also used DH Driver cleaner too.

Share this post


Link to post
Share on other sites

John, Disabling services can definitely speed up your machine but disabling services has it's own problems if the right ones aren't disabled. Have you tried running the latest series of Omega drivers. As a huge fan of UT2003 I as well as hundreds of others suffered from stuttering problems w the game. As soon as we installed the Omega drivers our problems went away. These drivers also cured all stuttering issues I was having w CFS3. You may want to look into them as another solution to your problem.Bobby

Share this post


Link to post
Share on other sites

John; switch to performance 16xAF. I noticed when I flew the advertised 32bit high res aircraft, I had some stutter in outside view and also after landing. After switching, it went away. No problem with any other aircraft. The high res 32 bit texture aircraft, your aircraft and the ones from Precision still have a delay in texture load when switching to outside view; but no real problem with stutters. Here's my settings:http://www.x-plane.org/users/mgdbottled/Settings1.jpg

Share this post


Link to post
Share on other sites

Hey Bobby,Thanks for that. I don't have them, might grab 'em and try that.Think I'll wait for my DSL to come back online before I do download them :-lol

Share this post


Link to post
Share on other sites

Hi John,If you have a Radeon you HAVE to download a Radeon tweaker to set the higher functions of the card. Making changes from the control panel may work but I had the EXACT smae problem you describe. I downloaded Rage3D Tweak from www.rage3d.com, adjusted my settings and am able to run FS2K2 with everything maxed except mesh and I get NO, none, nadda, zip stutters or annoying pauses. My frames do decrease in areas of HEAVY AI traffic but over all my frames stay around 28 (locked at 30).If/when you download the tweaker you can try these settings:# of Samples=4Ansio Filtering=8:1 forcedAnsio mode=QualityBump Mapping=enabledColorfill=enabledCompressed Textures=enabledDisable HierarchialZ=enable (check the box to disable)Dither Mode=OrderedFastZ Clear=enabledFSAA Mode=Quality-always onMip Mapping=QualitySupport 32bit Z-Buffer=enabledTCL Back Face Culling=enabledTCL Hardware=enabledTexture Micro Tiling=enabledTile Back Buffer=enabledTile Primary Buffer=enabledTile Textures=enabledTrueform=always offVertex Optiblend=enabledVertexBlendUseProjMat=enabledVolume Textures=enabledWFog=enabledWait for Vert Sync=always offZCompression=enabledZfog=enabledZmask=enabledGood luck!!Mike - Radeon 9700TX user!!

Share this post


Link to post
Share on other sites

John:I'm with you man, I just built my killer rig for FS2002 and am severly disappointed with this stuttering. I run 1600X1200 also with everything maxed out ( I have a 22" monitor), and have tried various settings for the AA and AF, and sure enough, I have this annoying stutter every few seconds, really ruins the whole experience....damn, it's more annoying than my previous setup with the GeForce 256DDR! I am also at my whits end, I've been researching this for about 3 weeks since I built my system (see specs below).I think someone may have mentioned it, but about the most information I have been able to find on this issue is at the forums on RAGE3D....seems like ALOT of people are having this problem with many different games, both in DirectX and OpenGL.My test for stutter is the default Meigs airfield in the Cessna, and within a few seconds I know if whatever umpteem tweak I tried actually helps the situation. All I do is press the 'S' key and pan around the aircraft while it sits on the runway, whenever the skyline of Chicago comes around, the sim usually freezes for about 2-3 seconds (only once) then thereafter, it will stutter for about .5 second in a regular 2-3 second interval. In between, the frames are smooth and the visual quality of the card is excellent....then...whammo....stutter......damn I am glad I am not the only one with this problem as I just spend many bucks on a kickass gaming box.ATI claims that the latest CAT 3.2 fixed all stuttering issues, and a post by one of the ATI guys on the RAGE3D forum seemed to indicate that any other stuttering issues were due to HD access or insufficient system RAM! I just built a box with an XP2800+ Barton with 1 GB of DDR 3500 RAM.....and I am running a game (sim) that is 1 1/2 years old, I don't think my problem is insufficient RAM. Boy, that comment really ticked me off. Bottom line is this IS an ATI problem.Dude, there are only 2 things that I have found that have helped (but not cured) the situation1. Go to the Troubleshooting tab in the drivers and turn down hardware acceleration 1 notch.....this with help out, but it's a big price to pay in FS2002 as you will loose accelerated mouse movement and accelerated bitmap display....both of these are needed for 2D cockpits, pretty much makes them unusuable..thus, this is not a solution.2. Turn down AA and AF and resolution and graphic settings in the sim. Again, why the Hell did I just build this rig and buy a $300 video card? Not acceptable in my mind, might as well go back to the damn 800 Mhz Athlon with GeForce 256DDR. At least it doen't stutter.Please, if you find a solution, send my a private message with the information (in addition to posting here)...I will do you the same also. I am also one very unhappy camper.Good Luck,Patrick-----------------------------System Specs:Asus A7N8X Deluxe w/ AMD XP2800 Barton w/ Volcano 9 HSF2X 512 MB Corsair XMS3500 C2 DDR RAM (1 GB Total)ATI 9700 Pro (it's a stutter bug)Onboard Sound, Onboard Nvidia NICDisabled Serial Port, Onboard 3COM NIC, and SATAAll PCI slots openMaxtor DM +9 80GB HD LG 48X 24X 48X CD Burner & DVD ROM Windows XP Professional SP1 w/ all updatesNothing Overclocked

Share this post


Link to post
Share on other sites

Hi Patrick,I'm really sorry to hear you're suffering too. I tried the acceleration trick, but it wasn't suitable.Mike: I tried your suggestion, and I am still seeing the stuttering :(I know that the earlier revision 1 Radeons had some problems with 8x AGP, so I tried 4x and it made no difference.I have tried just about everything except the Omega drivers which I'm about to try. I think I have exhausted just about every avenue. I am hoping like hell that Cat 3.3s fix things.. probably just a dream.

Share this post


Link to post
Share on other sites

Hi John,What's your mesh setting at? I have mine down to 0 (zero) and I read on one of the boards that this helps limit the pausing and stuttering. Also, I dug around my tweak documents and found this modified TERRAIN section for the FS2002.cfg file. May want to try the other suggestions as well.TERRAIN (Paul01 Settings)SuggestedTERRAIN_ERROR_FACTOR=10.500000TERRAIN_MAX_VERTEX_LEVEL=19TERRAIN_TEXTURE_SIZE_EXP=7TERRAIN_AUTOGEN_DENSITY=2TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=0 ;0=off 1=onTERRAIN_DEFAULT_RADIUS=5.000000TERRAIN_EXTENDED_RADIUS=8.000000TERRAIN_EXTENDED_LEVELS=3In your FSUIPC set your visibility settings to the following:MaximumVisibilityOvercast=2000MaximumVisibilityFewClouds=4000MaximumVisibility=6000Here are my FS2K2 Scenery and display settings:http://www.members.shaw.ca/madamo/display.jpghttp://www.members.shaw.ca/madamo/scenery.jpgFor Flight Sim to only pause and stutter while in spot view it would suggest that some settings within the game are to blame more than the card. I spent a significant amount of time tweaking FS2K2 when I got my new system and these settings in addition to the Radeon Tweaks mentioned in my other post have given me the best results.Hope these suggestions help to fix your problem!!!!!!Mike

Share this post


Link to post
Share on other sites

John,i just tested the link in my previous post. just type in the rest of the link (the part that's not underlined)in the address bar and it should take you directly to the KB info. don't know why the entire link did not work as i typed it. fm

Share this post


Link to post
Share on other sites

Hi John, I had a similar problem with my 9700, I was running Sygate Firewall, I removed it and the Problem went away. I don't know if you are running Sygate or not.Best of LuckBill

Share this post


Link to post
Share on other sites

Thanks so much for the suggestions.. :)The stutters don't happen in fullscreen mode, but they continue in windowed mode. I prefer to fly in windowed mode, so this is no good for me.Again, thanks so much for your help :)

Share this post


Link to post
Share on other sites

I had that problem with my 9500 Pro in full screen mode. I used the Rage3D utility to overclock the card by 10Mhz on the gpu and memory and it worked, also got a 2fps increase.

Share this post


Link to post
Share on other sites

heh, I overclocked it too, but it didn't make any differences.Ah well, she is up for sale, nVidia here I come :-hah

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this