Archived

This topic is now archived and is closed to further replies.

Chuck_B

Change Registry Entry In Fs9 To Point To C: Drive

Recommended Posts

I have my old FS9 SATA drive E: installed as a backup in my main box; this used to be my main drive (although it was never labeled C:, always E: by Windows). I've moved everyting to my C: drive, but all of the auto installers that don't give me the option to select my FS9 install and insist on finding it for themselves are installing everything on the old E: that I don't fly from any more.Does anyone know the registry keys I need to change and the appropriate values to force these autoinstallers to properly do their jobs? I'd really appreciate your help.As always, thank you!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Assuming your OS is XP,Click on Start, then RunIn the box type - regedit then click OK, this will open the Registry Editor.In the left-hand pane open this string of foldersHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.0In the right-hand pane right-click EXE Path and select Modify , not Modify Binary DataIn the box titled Value Data enter the path to your FS folder, typically - C:\Program Files\Microsoft Games\Flight Simulator 9Click OK and you should be good to go.PS. You may notice that it says you have version 9.0 even if you have installed the 9.1 patch. Don't worry about it, the patch does not change the registry.[edit]If you are not using the E: drive install you should delete any .exe files in there or at least give them a new extension like .bak[\edit]

Share this post


Link to post
Share on other sites
I have my old FS9 SATA drive E: installed as a backup in my main box; this used to be my main drive (although it was never labeled C:, always E: by Windows). I've moved everyting to my C: drive, but all of the auto installers that don't give me the option to select my FS9 install and insist on finding it for themselves are installing everything on the old E: that I don't fly from any more.Does anyone know the registry keys I need to change and the appropriate values to force these autoinstallers to properly do their jobs? I'd really appreciate your help.As always, thank you!
HKLM\\SOFTWARE\\Microsoft\\Microsoft Games\\Flight Simulator\\9.0Doug

Share this post


Link to post
Share on other sites

Thanks, Guys, very much! I knew you'd all be able to help me. Even with the new forum format! :(

Share this post


Link to post
Share on other sites
If you are not comfortable editing the Registry, you can use the free tool from the good folks at Flight1 to correct the FS2004 path:http://www.flight1software.com/files/FS_Registry_Repair.exeHope this helps.
Uh, this is emabarassing . . . I've tried doing this both ways -- manually using RegEdit AND with Flight1's free tool and would you guys believe I don't have an HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\9.0 entry in my registry? I feel so inadequate. :( Could someone please post the entries they have in their registry tree under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator so that I can add it correctly to mine and see if that does the trick?

Share this post


Link to post
Share on other sites
The repair tool should add any needed entries.
Yes it should. But it doesn't.

Share this post


Link to post
Share on other sites