Archived

This topic is now archived and is closed to further replies.

Guest Werd

Problems With Asa - Flight Time & Crashes

Recommended Posts

HiI have some issues with ASA, hope you can help.First of all I dont understand how to set ASA to flight time. I checked "flight time" instead of "system time" in FS9 and I checked "Force to sim time" in main ASA interface as well. That's what happends:It's 20:40 now in Paris so 19:40 GMT.. I configure the flight time to today 14:40. 19:40 GMT is the "Active Date and Time" in ASA.I start the flight and ASA depicts the realtime wheather (19:40). Then suddenly FS9 reloads scenery and the time in the sim is now 19:40. Please note "force to sim time" is checked in ASA, what else should I do?Ok second problem. FS9 randomly crashes since I installed ASA. The reason for crash is hard to know but I have some ideas. When in windowed mode I get an error from .net and see something like "DateTime error". When fullscreen FS9 crashes and I see FSUIPC in crash report. I doublechecked everything, I have the last version of both FSUIPC and .NET (2.0). I tryed to reproduce it and didnt succeed. Just made a 15 minutes flight in realtime w realtime weather - no crash. I think that crashes _might_ just occur when I make a fly at say 14:20 and use the realtime wheather from 19:40. So my both problems _might_ be only one problem.Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,I think everything is caused by the time issue.In ASA set Force to real time.Now, in FS you can use whatever time you want.You will get realtime weather and can fly in any time. Then your crashes should go away.Please let us know.Thanks,

Share this post


Link to post
Share on other sites

Hiok I checked "Force to Real Time" in ASA and tryied a flight (flight time in FS9 was not real time).After 3 minutes FS crashed with this report:

Signature du probl

Share this post


Link to post
Share on other sites

It's a single machine install.I've set System time in FS9 and Real time in ASA. Trying to fly at different hours/places right now and see how ASA reacts.I think I might have a FSUIPC problem. Depiction output takes forever. Generally when it's finished FS9 time is set to real time (so the scenery reloads) - never seen this happend with ASX or ASV. Sometimes it doesnt. Need a bit more flights to figure it out. Also visibility (4SM in the area) sometimes shifts to ~10-20SM (the sky goes blue) for few seconds and goes back to 4SM.-what are the "safe" settings for FS9 that will work for sure? I'll try to disable local range suppression and play arround with visibility options.-do I need the registered version of FSUIPC for ASA?edit: ok it crashed again :( system specs:c2d 1.82gb of ramintel gma x3100 integrated graphics (yep sucks for gaming but fs2004 works like a charm and doesnt crash ever)vista home premium sp1 fresh installfs2004 9.1latest fsuipc.NET 2.0 installed by default in the systemedit2:

22:50:56:0034 - FSUIPC_Wx_Main: RequestTimeStamp : IPC sendmessage failed all retries22:50:57:0188 - FSUIPC_Wx_Main: RequestTimeStamp : IPC sendmessage failed all retries
22:50:57:0188 - Error depicting FS9 Weather: Module: HIFIFSUIPC Class: FSUIPC_Wx_Main Error Message: Normal Timeout on FSUIPC Timestamp, retrying write

Share this post


Link to post
Share on other sites

Bump.Any ideas so far? I set FS to system time and ASA to sim time and it works nice so far. ASA sees the sim time correctly and loads the wheather from this day/time. That's great! I made few test flights and FS never crashed. However at one moment ASA forced FS to change flight time and to reload scenery. Once again I've never seen this happend with ASX or AS6.5. Is it a new feature? Or a bug? Also when this happend I was in Innsbruck (gmt+1), ASA changed the flight time and in FS I saw a bigger difference between local time and GMT (like +3 or +4). The location didnt change.So there might be a problem with time zones in FS/in my system (timezone set correctly)/in ASA?edit: .NET error

Consultez la fin de ce message pour plus de d

Share this post


Link to post
Share on other sites

Here is what happends.Start ASAStart FS. Flight location - somewhere in France (GMT+1). Flight time 23/11 10:00 (9:00 GMT).Asa depicts the time correctly and loads the wheather.Start flight.FS loads sceney.FS reloads scenery few seconds after the begining of the flight and sets the time to 13:00 (9:00 GMT).I set the time back to 10:00 (9:00 GMT) (somehow the timezone is right again).FS reload the scenery.Few seconds after FS crashes with FSUIPC error.All logs have the same messages I posted in other posts.Dont expect this to be fixed during the hollidays, just wanted to post the complete report while I remember everything. :(

Share this post


Link to post
Share on other sites

Hi there,any chance you can revert back to older FSUIPC and try again? Let me know if you need an older version.Cheers,Pete

Share this post


Link to post
Share on other sites
Hi there,any chance you can revert back to older FSUIPC and try again? Let me know if you need an older version.Cheers,Pete
same problem here. Can't fly with ASA at all...AppName: fs9.exe AppVer: 9.1.0.40901 ModName: fsuipc.dllModVer: 3.8.5.0 Offset: 000273e6Other times I get other programs crashing but all of them are fsuipc clients.I can confirm that this happens with both FSUIPC 3.8.5 and 3.8.1. I don't have any older version here, but if you want me to test on an older one, PM me.syn

Share this post


Link to post
Share on other sites

Ye I tryied with the old version of FSUIPC as well and it didnt change anything.Still waiting for fix

Share this post


Link to post
Share on other sites

I have exactly the same problem with windows pointing at FSUIPC.dll for the crashes. I 've rarely managed to complete a long flight without a crash. I 've actually stopped using ASA until a fix comes out since along with the wind shift and cloud popping issues it is far from a pleasant experience. I'm sure once every issue has been dealt with it will be a joy to use ASA, but until then is stays shut down...

Share this post


Link to post
Share on other sites

I have the issue of ASA causing FS to reload a few mins after I start running the program. It sometimes positions me in a different place causing my aircraft to crash....this only occurs using the new ASA....Ben

Share this post


Link to post
Share on other sites

Hi !Interim beta 355 reports these issues to be fixed, could it be confirmed by users ? Cheerios

Share this post


Link to post
Share on other sites