Archived

This topic is now archived and is closed to further replies.

ryanbatcund

Fsx Crashing With Dep Kills Key Commands

Recommended Posts

Whenever FSX crashes a little box comes up and yacks about Data Execution Prevention blah blah blah, and then I'm returned to Windows. Well, everytime this happens apparently my keyboard keys and controls are all set back to default settingsl GRRRRRRRRRR ARRRGGHHHG GRRRRR!!! Upsetting...I tried to turn off DEP for FSX but it said it needed to be on.What can I do to stop this? I'm getting the crashes from a known issue with the Citation Mustang. The crashes themsevles are annoying but not as annoying as my keyboard keys and stuff getting reset EVERYTIME this happens....What do the gurus recommend regarding DEP?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ryan,Unfortunately you cannot disable DEP for FSX. I would recommend you get on the Mustang support forum to see if they can find a solution. At present, if it keeps causing you crashes, and is a pain in ther arse to deal with....the only interim solution I can recommend is to not use the Mustang.

Share this post


Link to post
Share on other sites
Why would it delete my keyboard/controls configs though?
Out of spite perhaps? :( But as for the aftermath... next time you get the controls configured, make a copy of the standard.xml (that records those assignments) and then overwrite the (potentially damaged) default version with your copy anytime you suspect it may have changed - then fly.Loyd

Share this post


Link to post
Share on other sites

Ryan, right click on your FSX Desktop Shortcut, and click the "Compatibility" tab.Make certain to put a check mark on these two items:Disable visual themesDisable desktop compositionThat might eliminate your CTD problem.

Share this post


Link to post
Share on other sites