Archived

This topic is now archived and is closed to further replies.

Guest FrancoisH

Pro Rudder Pedals And Auto-brakes...

Recommended Posts

Hello there,I installed the FS9 version of the MD11, hoping the damn auto-brake system issue I got with my Saitek pro rudder pedals was gone but it is not...If I unset my toe brakes axis, it work, if I set it trough FSUIPC or FS9 it do not... I do not have this issue with either 747 or 737 from PMDG or any other plane... I just have to set axis and invert them and all is fine...I made multiple rejected take-off to test the system and only when I had all axis unset, it acknowledged to work as intended.Do you have any clue for me ?Regards.P.S. I got another issue, this time with the throttle, trying to set it back and with no effect (at take off) even I checked the "only in clamp mode" option which should have worked out.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ok, I suppose I am the only one to get this issue then i'll put a ticket on PMDG support adress.

Share this post


Link to post
Share on other sites
Hello there,I installed the FS9 version of the MD11, hoping the damn auto-brake system issue I got with my Saitek pro rudder pedals was gone but it is not...If I unset my toe brakes axis, it work, if I set it trough FSUIPC or FS9 it do not... I do not have this issue with either 747 or 737 from PMDG or any other plane... I just have to set axis and invert them and all is fine...I made multiple rejected take-off to test the system and only when I had all axis unset, it acknowledged to work as intended.Do you have any clue for me ?Regards.P.S. I got another issue, this time with the throttle, trying to set it back and with no effect (at take off) even I checked the "only in clamp mode" option which should have worked out.
Francois,This issue has been fixed in the FS9, and will also be fixed in the FSX update that will come out soon. I have extensively tested this with Saitek rudder pedals myself, with and without FSUIPC and it works all the time.The only limitation is that in case you use the FSUIPC joystick calibration option to process the left/right brakes you should have Filter tick box unchecked. Can you give me some information on how are your toes brakes axis set? Screenshots of FS9 control assignment, sensitivty and null zone settings and, in case you use a registered FSUIPC, axis assignment and joystick calibration screens. About the throttles: During take-off below 80 KTS ATS is not in clamp mode, so the "only in clamp mode" option will make no difference. Above 80 KTS it will do. In any case setting the throttles back and pressing F1 (to eliminate the possiblity that the throttle axis might be sending something above idle) should work.

Share this post


Link to post
Share on other sites
Francois,This issue has been fixed in the FS9, and will also be fixed in the FSX update that will come out soon. I have extensively tested this with Saitek rudder pedals myself, with and without FSUIPC and it works all the time.The only limitation is that in case you use the FSUIPC joystick calibration option to process the left/right brakes you should have Filter tick box unchecked. Can you give me some information on how are your toes brakes axis set? Screenshots of FS9 control assignment, sensitivty and null zone settings and, in case you use a registered FSUIPC, axis assignment and joystick calibration screens. About the throttles: During take-off below 80 KTS ATS is not in clamp mode, so the "only in clamp mode" option will make no difference. Above 80 KTS it will do. In any case setting the throttles back and pressing F1 (to eliminate the possiblity that the throttle axis might be sending something above idle) should work.
Hello,About the Saitek issue, I tried, tried and tried again and it is working one time upon two... I currently have my sensitivity at max, my two Toe axis set in FS with "Reverse axis" checked (because axis are inverted into FS) and with no settings for them into FSUIPC.Sometimes, Auto-brake don't work when doing rejected take-off, sometime it work... I will try to increase the null zone slightly.For the throttle I just saw my error and that work really fine, on other side, this plane is the greatest I currently have on my PC... just this little auto-brake issue ;)Regards.

Share this post


Link to post
Share on other sites

I found how to reproduce each time my problem.Arm the auto-brake, press one or the other toe then do a rejected take-off... auto-brakes will not work.Do a final approach, arm auto brake and press one or other toe brakes pedal, auto-brakes will not work at landing.Do either or the two previous things without pressing on or the other pedal and auto-brakes will work.So in fact, if you press your brakes BEFORE the action of the auto-brake, it work as if it was AFTER they acted and it do not show any "disarmed" alert anywhere. Not sure I'm really clear describing my problem.Regards.

Share this post


Link to post
Share on other sites

Interesting, I know what problem your referring to, granted I use a different brand of pedals, but I see this occur on another add-on I have, but the MD-11's ABS disarms for me like a charm and there is am amber ABS Disarm light on the glare shied when the ABS is disarmed, can't miss it.

Share this post


Link to post
Share on other sites

I have the Saitek Yoke, Throttles, and Pedals and don't have these problems. Hope you find a solution.RegardsRichie

Share this post


Link to post
Share on other sites

So it is not related to the pedals but to something in the way we configure it I suppose...

Share this post


Link to post
Share on other sites

FrancoisH, I had the exact same problem you do with my Saitek pedals. Not touching the brakes and it would work, touch them and it wouldn't. This worked for me:Open FSX controls and make sure to remove the brake axis assignments to your Saitek pedals.Then open FSUIPC in the menu and choose the Axis Assignment tab.Click the rescan and tap your left brake. Mine shows it as 1 and X for that assignment.Under Type of Action on the left, click the Send Direct to FSUIPC Callibration.Put a Check in the first pull down menu and choose Left Brake.Do the same as above for the right brake, mine shows it as 1 YNow go to the Joystick Calibration tab, page 2.Click the Set button for both left and right brakes.Put a check in the Rev box.I also have the control spike elimination checked on the Misc. tab in case that has anything to do with it.See if that fixes it. Jeff P.

Share this post


Link to post
Share on other sites
FrancoisH, I had the exact same problem you do with my Saitek pedals. Not touching the brakes and it would work, touch them and it wouldn't. This worked for me:Open FSX controls and make sure to remove the brake axis assignments to your Saitek pedals.Then open FSUIPC in the menu and choose the Axis Assignment tab.Click the rescan and tap your left brake. Mine shows it as 1 and X for that assignment.Under Type of Action on the left, click the Send Direct to FSUIPC Callibration.Put a Check in the first pull down menu and choose Left Brake.Do the same as above for the right brake, mine shows it as 1 YNow go to the Joystick Calibration tab, page 2.Click the Set button for both left and right brakes.Put a check in the Rev box.I also have the control spike elimination checked on the Misc. tab in case that has anything to do with it.See if that fixes it. Jeff P.
Ok, I conducted the suggested test but the bug still the same one time over two... I line up use my brakes to stop the plane on the runway...The "ABS disarm" is not ligthen up but my auto-brakes are not working when I do the rejected take-off...With the workaround above, it work as it should work, thanks to Jeff but seems your plane do not like standard axis of FS.Regards.

Share this post


Link to post
Share on other sites
Ok, I conducted the suggested test but the bug still the same one time over two... I line up use my brakes to stop the plane on the runway...The "ABS disarm" is not ligthen up but my auto-brakes are not working when I do the rejected take-off...With the workaround above, it work as it should work, thanks to Jeff but seems your plane do not like standard axis of FS.Regards.
Isn't it intended to disarm the autobrake by pushing the brake pedals?Maybe I don't understand your problem well, but then there isn't a problem :(

Share this post


Link to post
Share on other sites

Auto-brakes are designed to be disarmed by the use of my toe brakes pedals when they are active, either on a rejected take-off or when landing.But there, they are effectively "disarmed" but should not be because they are correctly set on the pedestal, and the amber warning is not alive on the glareshield...So this is a kind of wrong disarm and it happens when pressing the brake pedals BEFORE you started initial acceleration or when you press them before your gear touch the ground.If you follow check lists, you arm your auto-brakes at taxi when you still have to use your brakes to hold short of the runway or after you lined-up if required to wait, etc...But here, if you arm the auto-brakes, use brakes at taxi then do a rejected take-off, they will not work.This happens when you set the axis with FS, but seems to be solved if axis are set trough FSUIPC... don't ask me why.Regards.

Share this post


Link to post
Share on other sites

Conducted the whole test again and it still happens... auto-brakes not activating but ABS Disarm light is not lighten up... just because I do used my toe brake to stop the plane at taxy... I have to rearm those each time before take-off to be sure they will work correctly.Regards.

Share this post


Link to post
Share on other sites
Conducted the whole test again and it still happens... auto-brakes not activating but ABS Disarm light is not lighten up... just because I do used my toe brake to stop the plane at taxy... I have to rearm those each time before take-off to be sure they will work correctly.Regards.
Hi,I believe they stated that the update that's coming out today should fix this problem. I'd wait for further tests until after the update and see how it goes.-stefan

Share this post


Link to post
Share on other sites
Hi,I believe they stated that the update that's coming out today should fix this problem. I'd wait for further tests until after the update and see how it goes.-stefan
Stefan,No we didn't say that. The fix was included in the FS9 version. The PMDG MD-11 FSX update that will be released today will also fix these problems for the PMDG MD-11 FSX. The PMDG MD-11 FS9 update that will be released today has no changes related to the problems discussed in this post. While preparing the FS9 version and the update to the FSX version we have spent a lot of time investigation all sorts of problems caused to the ABS by the use of rudder pedals either assigned through FS or assigned/calibrated with FSUIPC. We have made changes and tested them extensively on various configurations with various brands of rudder pedals to ensure everything is working as expected. Considering that I personally have the exact same equipment with Francois (Saitec Pro Rudder Pedals) and they work fine in all kind of FS and FSUIPC control set-ups (except with the "Filter" box in FSUIPC ticked as I mentioned) there is nothing else I can do at this stage. Unless I have a situation that I can reproduce on my end there is no way to fix it.

Share this post


Link to post
Share on other sites
except with the "Filter" box in FSUIPC ticked as I mentioned
Michael,I don't know how to thank you :( I had the same problems as discribed in this topic : no more autobrakes.All my buttons and axis are via FSUIPC, INCLUDING "filter" option => really don't know why this is for, but anyway ...After your suggestion to untic this option i have autobrakes again :( I have FS9.1 and your excellent B744/B744F (No MD11 yet installed).

Share this post


Link to post
Share on other sites

hi all,I also have trouble with Saitek Pro Rudder Pedals (USB) and FS9 version of MD11.My problem is that parking brake can

Share this post


Link to post
Share on other sites
hi all,I also have trouble with Saitek Pro Rudder Pedals (USB) and FS9 version of MD11.My problem is that parking brake can

Share this post


Link to post
Share on other sites
Michael,How are the brakes axis of your rudder pedals set? From the FS controls menu? Or through a registered FSUIPC version?
good morning Michael,thanks for your fast reply.Both are set. FS controls menu and registered FSUIPC.I switched off one after another and reconfigured. No success.I did upload 2 pics.Michael

Share this post


Link to post
Share on other sites
Considering that I personally have the exact same equipment with Francois (Saitec Pro Rudder Pedals) and they work fine in all kind of FS and FSUIPC control set-ups (except with the "Filter" box in FSUIPC ticked as I mentioned) there is nothing else I can do at this stage. Unless I have a situation that I can reproduce on my end there is no way to fix it.
Surprisingly, I find that some of your do not have to "Reverse" axis with the saitek pro rudder pedals as I have and I am like sure this is related to this option...My problem is and still is that if I USE BRAKES AFTER arm of the AUTO-BRAKES it sometimes make auto-brakes disarmed BUT THE ABS DISARM is not alive on the glareshield... So auto-brakes just do not work. I am almost sure the system that make auto-brakes being disarmed is taking into account any pressure on my brakes EVEN if the auto-brakes are not yet activated, so I think it is not normal... either the light should go on or it should not be taken into account.I can reproduce it almost everytime. I tried to test that many time, using FSUIPC or FS Axis definition... It happens less when using FSUIPC than when using directly FS... but it still happens regularly.The only workaround I found is to rearm brakes after line-up or last use of my brakes at take-off and be sure to not press toe brakes before landing... but anyway this is an annoying issue.I noticed when this happens that I can no longer use my "brake" key untill I rearm the system... when I press brakes, nothing light up... but this do not happens each time either...Regards.

Share this post


Link to post
Share on other sites
good morning Michael,thanks for your fast reply.Both are set. FS controls menu and registered FSUIPC.I switched off one after another and reconfigured. No success.I did upload 2 pics.Michael
Michael,In FS Controls left/right brakes should have the "reverse" box ticked. This is how they work for me and this is what the Saitek manual says (also in the sensitivities menu, sensitivity must be set to full and null zone close to 0). Without the reverse box ticked you will have constant braking when you don't press the pedals. Make this change, then disable FSUIPC calibration, pressing the "reset" button for both brakes ("axis not processed" should display). You might need to restart FS9 for these changes to take effect.Check if this works. It should work this way. If you want to use the FSUIPC calibration option, try to do again the calibration in the FSUIPC, without changing any of the FS control settings.

Share this post


Link to post
Share on other sites
Surprisingly, I find that some of your do not have to "Reverse" axis with the saitek pro rudder pedals as I have and I am like sure this is related to this option...My problem is and still is that if I USE BRAKES AFTER arm of the AUTO-BRAKES it sometimes make auto-brakes disarmed BUT THE ABS DISARM is not alive on the glareshield... So auto-brakes just do not work. I am almost sure the system that make auto-brakes being disarmed is taking into account any pressure on my brakes EVEN if the auto-brakes are not yet activated, so I think it is not normal... either the light should go on or it should not be taken into account.I can reproduce it almost everytime. I tried to test that many time, using FSUIPC or FS Axis definition... It happens less when using FSUIPC than when using directly FS... but it still happens regularly.The only workaround I found is to rearm brakes after line-up or last use of my brakes at take-off and be sure to not press toe brakes before landing... but anyway this is an annoying issue.I noticed when this happens that I can no longer use my "brake" key untill I rearm the system... when I press brakes, nothing light up... but this do not happens each time either...Regards.
Francois, This SHOULD be working. Initially remove the left/axis assignment from FSUIPC and use the FS controls assignment. Make sure "reverse" is ticked, sensitivity is set to full, and null zone is close to 0.Restart FS. If it is still not working: Take screenshots of the FS controls assignment screen, and the FSUIPC "sensitivities screen"Go to the FSUIPC "joystic calibration" screen. "Not processed" should be displayed for left/right brakes. Do NOT press SET.Press and release the rudder brakes, then take one screenshot with brakes not pressed and one with brakes fully pressed. Post the screenshots and we will sort this out.

Share this post


Link to post
Share on other sites
Michael,In FS Controls left/right brakes should have the "reverse" box ticked. This is how they work for me and this is what the Saitek manual says (also in the sensitivities menu, sensitivity must be set to full and null zone close to 0). Without the reverse box ticked you will have constant braking when you don't press the pedals. Make this change, then disable FSUIPC calibration, pressing the "reset" button for both brakes ("axis not processed" should display). You might need to restart FS9 for these changes to take effect.Check if this works. It should work this way. If you want to use the FSUIPC calibration option, try to do again the calibration in the FSUIPC, without changing any of the FS control settings.
good morning Michael,it

Share this post


Link to post
Share on other sites