Archived

This topic is now archived and is closed to further replies.

Guest dc4

FSX on ATI 9.2 driver package

Recommended Posts

Hi,I have a 4870 x2. I downloaded and did a clean install of the 9.2 driver package. What is really strange is that when I try to fly at night, in FSX, my saitek x52 does not work. Also my g15 keyboard does not work except for the function keys. Also there are no cockpit lights. When I shut down FSX a window with acceleration pops up in the lower right corner of my lcd. Then another windows pops up and tells me FSX and stopped working with a option to close. Then a error reporting window comes up and sends off the error report. I tried to fly at night 3 times with the same result.When I fly during daylight hours my keyboard and flightstick work great. However, when I quit FSX I get the same windows and error reporting that show up when I was flying at night.I have vista 64 bit with 8 gigs of ram. I have not checked my error reporting yet. Might be acceleration or FSX messing up or both. 8.12 and the 9.1 drivers worked fine.Has anybody else seen this problem using the 9.2 drivers? If so did you find a work around? I can always roll back to 9.1. The other software on this machine work just fine.Thank you,David

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

JUST FYI for others:Last night I deleted the 9.2 package and reinstalled and still have the same problems. I started to have problems with FSX even starting as it would crash. So I deleted the config file and let FSX re-build it. Started up fine and flew great but when I went to change aircraft nothing displayed in the aircraft display area, just a black space. So I shut down and tried to restart but FSX crashed and sent a error report. I have FEX installed so I started FSX from FEX and it started and ran but when I shut down FSX It crashed. I cont, alt, delete to close it thru task manager. When I closed FSX thru task manager the FSX error came up and sent out the error report. The FSX error report pointed to the FSX.exe. I sent my system specs and a copy of the error report using the ATI driver feedback program on the ATI website. All my other games and software work perfect. Just wait and see.

Share this post


Link to post
Share on other sites

David,I'm using the 9.2 drivers on 2 X Radeon HD 4870's with 512 each in XFIRE, with Vista 64 Ultimate, using a QX9770 quad/X48 Platinum at 3.2 ghz, with 2 X 2gb OCZ 1600 mzh ram which can't clock higher then 1200 (All clean and fresh installs (format) with latest updates). I don't have stability issues as you do, but a complete set of different issues. My desktop icons are blurry. I'm not really sure I've got 100% the 1920 X 1200 res my systems says I'm in with a HANNS-G 28" wide screen.I'm pretty sure AA doesn't even work, especially in FS. MY FS settings are set right now to the exact same setting as Nick's over at GEX. I'm running ASX with XG, UTX, and GEX. Terrain is still blurried no matter what LOD I use. I'm definately not getting the same cm texture resolution with or without (before and after I should say) the addons. Frames are in the single digits.RMA'd the MOBO 3 times...lol. There's a ton more issues I could go into.Jeff

Share this post


Link to post
Share on other sites
Hi,I have a 4870 x2. I downloaded and did a clean install of the 9.2 driver package. What is really strange is that when I try to fly at night, in FSX, my saitek x52 does not work. Also my g15 keyboard does not work except for the function keys. Also there are no cockpit lights. When I shut down FSX a window with acceleration pops up in the lower right corner of my lcd. Then another windows pops up and tells me FSX and stopped working with a option to close. Then a error reporting window comes up and sends off the error report. I tried to fly at night 3 times with the same result.When I fly during daylight hours my keyboard and flightstick work great. However, when I quit FSX I get the same windows and error reporting that show up when I was flying at night.I have vista 64 bit with 8 gigs of ram. I have not checked my error reporting yet. Might be acceleration or FSX messing up or both. 8.12 and the 9.1 drivers worked fine.Has anybody else seen this problem using the 9.2 drivers? If so did you find a work around? I can always roll back to 9.1. The other software on this machine work just fine.Thank you,David
Hi David. Sorry you're having so much trouble! I just installed the 9.2 driver for my single 512 4870 and I have not noticed any of these issues. I actually just did a complete system reformat and did a fresh FSX install w/Acceleration. Then I installed REX and I have no strange symptoms so far. I would seriously not think this is driver-related, but perhaps it is since it coincides with your update. I don't know how hard it would be for you to back up your payware and just reinstall FSX, but that is what I would do. It might be worth the effort. Have you noticed any abnormalities with other titles since you installed 9.2? Probably not - FSX seems to be the dunce of the class with regard to tuning and hardware changes. Usually it's hard to deal with, it doesn't adapt well to changes, and you just end up wanting to put it in a corner for a while. :( Seems like Nvidia and ATI never work much on driver updates that help FSX, do they? Most games are buttery on my computer and ATI released a driver update that really helped Crysis....but when will the day come that they concentrate on FSX improvements? Probably never now that Microsoft said "peace out" to Aces.I'll report if I notice anything weird in the near future. In the meantime, I would just try to start from scratch with FSX and see how that ends up.Best,Scott

Share this post


Link to post
Share on other sites

Jeff and Scott,Thank you for your response.As far as other sim titles like: Falcon AF, WOE, WOI, WOV and the newer Strike fighters 2 they all work perfect with the 9.2 drivers. Least I can fly and blow things up!! All the other software works perfect too. As far as wiping FSX and starting from scratch I think that will be a good idea. I did notice that AA works in the cockpit. However in the distance, looking out the cockpit, AA seems to be not working when I bank to make a turn. I have AA turned off on the card and use the game AA. Adaptive AA works as I can tell the quality of the rendor is better. The card itself is not over clocked. I have it turned on just to adjust the fan speed. The card I have hates over clocking and left artifacts so I nixed that idea. So with that said thanks again for your information and I will reinstall.

Share this post


Link to post
Share on other sites

Don't know how far along you reinstall you are but did you try renaming your config file and letting fsx build a new one? Tony

Jeff and Scott,Thank you for your response.As far as other sim titles like: Falcon AF, WOE, WOI, WOV and the newer Strike fighters 2 they all work perfect with the 9.2 drivers. Least I can fly and blow things up!! All the other software works perfect too. As far as wiping FSX and starting from scratch I think that will be a good idea. I did notice that AA works in the cockpit. However in the distance, looking out the cockpit, AA seems to be not working when I bank to make a turn. I have AA turned off on the card and use the game AA. Adaptive AA works as I can tell the quality of the rendor is better. The card itself is not over clocked. I have it turned on just to adjust the fan speed. The card I have hates over clocking and left artifacts so I nixed that idea. So with that said thanks again for your information and I will reinstall.

Share this post


Link to post
Share on other sites

Tony,I did a repair on FSX and Acceleration. Also let the FSX config file rebuild. Same results. FSX hangs up when I exit and I have to do the ctrl, alt, del thingie. I reinstalled the 9.2 driver package with the same results. Everything works fine except FSX. David

Share this post


Link to post
Share on other sites

Ok, I went back to the 9.1 drivers for my 4870 x2 and now FSX works great. Guess the 9.2 drivers has issues with FSX on the 4870 x2. Least with me anyways.Thanks for everybody's help. Maybe this will help someone.

Share this post


Link to post
Share on other sites

Hey guys Sorry to hear that you've been having system problem I started a thread HERE about using ATI's Catalyst crew feedback program to get them to improve there FSX support and performancehttp://support.ati.com/ics/survey/survey.a...86&type=webif you could take a few mins to fill it out let to ATI know of your problems that would be greatMaybe if a high enough number of us complain they might take 5 mins out of coding driver hacks to improve crysis by another 0.5% and spend sometime atleast bringing the FSX number up to that of last gen Nv CheersGizmo

Share this post


Link to post
Share on other sites
Ok, I went back to the 9.1 drivers for my 4870 x2 and now FSX works great. Guess the 9.2 drivers has issues with FSX on the 4870 x2. Least with me anyways.Thanks for everybody's help. Maybe this will help someone.
That is too weird! The problem must be the 9.2 driver only with the x2 card. I can confirm that the single 4870 does not encounter any of these issues by upgrading to the 9.2. I'm surprised your report is the first I have read about this problem. Surely there are others out there using FSX with an x2! They might want to hold on to whatever driver they are currently using!Gizmo has suggested that we request further driver support for FSX on an ATI page. I think this is a great idea. It looks like FSX will be what we (as flight simmers) are going to be using a while. I hope Nvidia and ATI consider broadening their updates to encompass FSX for this reason!Scott

Share this post


Link to post
Share on other sites