Archived

This topic is now archived and is closed to further replies.

Guest Poppa_Bear

fsuipc_wait error

Recommended Posts

I'd found this error dialog about fsuipc_wait during a previous flight and it didn't seem to adversely effect the flight, however, last night it happened twice and appeared to cause RC to pause: no ATC calls, no AI calls, nothing until I selected OK. After that, RC chugged along. I am curious about what this is trying to tell me and if there's anything I should be doing. I have FS9 and registered FSUIPC on an XPSP3 machine.RC4_burp.jpgCheers!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'd found this error dialog about fsuipc_wait during a previous flight and it didn't seem to adversely effect the flight, however, last night it happened twice and appeared to cause RC to pause: no ATC calls, no AI calls, nothing until I selected OK. After that, RC chugged along. I am curious about what this is trying to tell me and if there's anything I should be doing. I have FS9 and registered FSUIPC on an XPSP3 machine.RC4_burp.jpgCheers!!
what version of fsuipc, what version of rc? if you use widefs, what version of widefs?

Share this post


Link to post
Share on other sites
Sorry 'bout that. FSUIPC v. 3.82Cheers!!
3.85 is current. what version of rc?

Share this post


Link to post
Share on other sites

v.4.3.3845My apologies for having to drag this outta me.Cheers!!

Share this post


Link to post
Share on other sites
v.4.3.3845My apologies for having to drag this outta me.Cheers!!
update fsuipc, and let me know if that fixes the problemwhat other add-ons are you using, that might also be using fsuipc?jd

Share this post


Link to post
Share on other sites

Latest from Dowson's page is v.3.90; will that be ok? Other stuff is ASA b.355 & PMDG 744. Thanks for the help.Cheers!!

Share this post


Link to post
Share on other sites
Latest from Dowson's page is v.3.90; will that be ok? Other stuff is ASA b.355 & PMDG 744. Thanks for the help.Cheers!!
cool. update, and make a log. instructions pinned at the top of the forum.jd

Share this post


Link to post
Share on other sites

I'm getting this same error for the last 3 months or so and its completely random when it happens. I've gone 8 or 9 flights without a problem then bam it happens again. Sometimes I can 'OK' out of it but sometimes its just too many errors. Becuase its so random I'll run the logger thinking I'll catch it but then it won't happen again for xx amount of flights. I've tried reinstlling RC4, reinstalling Fs9 several versions of FSUIPC (v.3.85, 3.90 & 3.907 registered). I've had it happen with and without ASA both betas and AS6.5. I know you need a log and believe me I'm trying! but if you have any ideas???

Share this post


Link to post
Share on other sites

One thing I want to ad when I run "rebuild scenery DB" it asks me if its wide FS and the Fs9 location but then says completed. I know in the past it would take a few minutes to rebuild. If I run Makerunways (4.29) from inside my Fs9 folder it acts as it used to. This has been going on for sometime and happens with FSX as well.

Share this post


Link to post
Share on other sites
One thing I want to ad when I run "rebuild scenery DB" it asks me if its wide FS and the Fs9 location but then says completed. I know in the past it would take a few minutes to rebuild. If I run Makerunways (4.29) from inside my Fs9 folder it acts as it used to. This has been going on for sometime and happens with FSX as well.
are you running rc on the same machine as fs? what is your answer to the widefs or not question?jd

Share this post


Link to post
Share on other sites
are you running rc on the same machine as fs? what is your answer to the widefs or not question?jd
Yes the same machine and no wide FS. Along with RC4 I run ASA and FsPax. I do have quite a few scenery's including UT and GEP as well as add-on AC.

Share this post


Link to post
Share on other sites
Yes the same machine and no wide FS. Along with RC4 I run ASA and FsPax. I do have quite a few scenery's including UT and GEP as well as add-on AC.
lets see where the conflict might be. stop running fspax and asa, and fly a dozen flights. do you still get the error? if not, add back asa. run another dozen flights. no errors, add back fspax.we'll find out who isn't playing nice :-)jd

Share this post


Link to post
Share on other sites

Let's confirm that you are not on a net and RC is on the FS PC. Based on that you should not be running anything but RC when rebuilding the scenery database. If you are a Vista user you should be running as an admin and have a shortcut to RC with the property to run it with admin rights. If you have good security add-ons it might be beneficial to turn off User Access Rights. Once applications in Vista are installed in any "Program Files" folder, additional security is in place that has caused some problems for FS users. I am om XP and I base the following on that:You have confirmed that makerwys.exe is in your FS folder as shown in the path statement you will enter into RC. (To make things easier for me I have the path in a text file with a shortcut to it so I can paste the path into RC each time needed. I bring up the text file, highlight the path with a mouse drag, hit ctrl-c, and when at the RC path request window set the cursor in it and hit ctrl-v to paste it in.)So start RC without any other FS applications including FS not running. Click the Scenery Rebuild button. Answer No to the Wide FS query. The FS path box pops up. Enter the path. Mine is "h:\program files\microsoft games\flight simulator 9" (exclude quotes). (This is the path where makerwys.exe is also located and where the updated file r5.csv or r4.csv is initially created and RC will in the second step copy and convert those files to your RC folder.) A box should pop-up RC rebuilding r4.csv, running makerwys. OK it. You should now be seeing the runways and sceneries changing while makerwys is running. There will also be a makerwys icon in your task bar. Eventually it will stop counting an an OK button will appear. Click OK. A box pops-up RC finished building r4.csv. Click the OK button. A box pops-up about RC building a new a4.csv. Click OK. The box changes to RC finished building a4.csv. Click OK. I'd wait now about ten seconds so any remaining internal RC file copying is completed. This has to do with Windows settings. Then close and restart RC when you are ready.If you wish to confirm your updates go into the data folder under RC4 with explorer or get to it via my computer. Click view and set to details. The modified date and time for a4.csv and r4.csv should be when you ran the scenery rebuild.If your path is correct to your FS folder and makerwys called from within the RC application is not running I suspect you have a user rights issue.Let us know if this process is working for you.

One thing I want to ad when I run "rebuild scenery DB" it asks me if its wide FS and the Fs9 location but then says completed. I know in the past it would take a few minutes to rebuild. If I run Makerunways (4.29) from inside my Fs9 folder it acts as it used to. This has been going on for sometime and happens with FSX as well.

Share this post


Link to post
Share on other sites

Ronzie, I've been doing it that way since purchase. I'm pretty sure it stopped working when I moved from XP32 to VistaX64 and now it happens in XP64. I've done several clean re-installs with both RC and FSX, could it be the 64 bit OS?Jd, I'm gonna knock em out one at a time first with just ASA. I did 2 quick KORD-KCVG flights without ASA and had no trouble except with the horrible wind shits from the default weather. I will try it again with ASA and without FsPAX and see what happens.John

Share this post


Link to post
Share on other sites

Just to be clear I was referring only to your problem with the scenery rebuild. ASA would not be a factor if it is not running. FYI there are release service packs for ASA put out recently as one aspect of it was causing memory leaks in its first release version.There are some security differences between the 32 bit and 64 bit versions of both XP and Vista with 64 bit being stricter as I recall. Here's something you can check:When you installed RC it created some variables that were placed in a .bat file in the RC4 folder called makerwys.bat. The last time you ran the rebuild it also placed the path you entered into it. Right click on it and choose Edit, NOT OPEN. It will open in Notepad. You can see if your RC4 path and FS path are correct in there. DO NOT SAVE this file on exiting Notepad. It must not be changed by you. If you want you can make a copy of this to place elsewhere and open that for examination. Do not use the Open command as that would run it which you must not do. If available you can use Open With and choose a program to examine it.If you can't get this to go then you could adopt the technique for networks to some degree. Go into your FS folder and run makerwys directly. This will create a new r4.csv of r5.csv file in the FS folder. Then start RC4 as you normally (running in its own folder) would and while makerwys will not run the copying from FS to the RC folder and conversion processes within should still update the database. You can check the r4.csv and a4.csv (in your RC4 folder) dates as previously described.

Ronzie, I've been doing it that way since purchase. I'm pretty sure it stopped working when I moved from XP32 to VistaX64 and now it happens in XP64. I've done several clean re-installs with both RC and FSX, could it be the 64 bit OS?Jd, I'm gonna knock em out one at a time first with just ASA. I did 2 quick KORD-KCVG flights without ASA and had no trouble except with the horrible wind shits from the default weather. I will try it again with ASA and without FsPAX and see what happens.John

Share this post


Link to post
Share on other sites

I have looked at the batch file and the FS location is correct, this is for both FSX & FS9. I think I'm one step ahead of the game here! and have been running makerunways from my Fs folders since I first noticed the problem :(

Share this post


Link to post
Share on other sites
lets see where the conflict might be. stop running fspax and asa, and fly a dozen flights. do you still get the error? if not, add back asa. run another dozen flights. no errors, add back fspax.we'll find out who isn't playing nice :-)jd
Ok jd I've done 8 flights with just FsPAX, AI smooth and no pre-recorded chatter, and all went well. I just started a flight with ASA running and about 30 minutes into the flight I get the wait error. John

Share this post


Link to post
Share on other sites
Ok jd I've done 8 flights with just FsPAX, AI smooth and no pre-recorded chatter, and all went well. I just started a flight with ASA running and about 30 minutes into the flight I get the wait error. John
i dont remember the options in ASA, but there are two, that you can turning off. one is to turn off asa doing the atis reports. the other, something like DSA or something. it sets the weather repeatedly at the arrival aiport i think.maybe take ASA back to the default settings, and turn the ones you want, on one by one.jd

Share this post


Link to post
Share on other sites