Archived

This topic is now archived and is closed to further replies.

bojote

bufferpools=0

Recommended Posts

Out of frustration will spikes coming from the scenery and not finding a way to solve this I started changing, testing and experimenting.yes, I know it sounds crazy and completely contrary to general wisdom, but bufferpools=0 seems to have eliminated this spikes completely and smooth things out in my setup(windows XP, 32 bit, 2GB Mem FX-60 CPU w/3850 ATI Card)If you have 'spikes' coming from autogen and know a sure way to replicate the problem try experimenting with bufferpools=0 take a fast jet and so some low level turns to experiment. Maybe this bufferpools=0 makes SP2 like SP1 but without the OOMs?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I bet '0' will reset the bufferpools value back to default. Spikes and stutters might be introduced when bufferpools is set too high...

Share this post


Link to post
Share on other sites
I bet '0' will reset the bufferpools value back to default. Spikes and stutters might be introduced when bufferpools is set too high...
However, *NOT* having bufferpools in the fsx.cfg still gives me the scenery spikes, so, setting it to 0 does not equal 'default' values as you suggest. I guess that some things work for some, in my case the bufferpools=0 seems to have a positive effect in my setup.. just wanted to share this with people having the scenery spikes problems, as in my case it was severe.

Share this post


Link to post
Share on other sites

Well, i am not 100% sure if it resets to default or if you can let it use a lower value (eventually the pre SP1 value) with your zero entry. But i really doubt that it IS actually zero.PT could shed some light if he drops by :( .

Share this post


Link to post
Share on other sites
Out of frustration will spikes coming from the scenery and not finding a way to solve this I started changing, testing and experimenting.yes, I know it sounds crazy and completely contrary to general wisdom, but bufferpools=0 seems to have eliminated this spikes completely and smooth things out in my setup(windows XP, 32 bit, 2GB Mem FX-60 CPU w/3850 ATI Card)If you have 'spikes' coming from autogen and know a sure way to replicate the problem try experimenting with bufferpools=0 take a fast jet and so some low level turns to experiment. Maybe this bufferpools=0 makes SP2 like SP1 but without the OOMs?
You mean this, right? [bufferPools]PoolSize=0

Share this post


Link to post
Share on other sites
You mean this, right? [bufferPools]PoolSize=0
Correct. And, yes, I assume the 'default' is around 3M (3.000.000) I tried lowering that value, 300.000, 100.000 and it took longer to get the scenery spikes, but still had them (after >30 min). setting the poolsize to 0, I guess, bypases the use of the GPU memory, what effect it can have long term? I really don't know. But, as I said, it has completely eliminated the annoying spike textures coming off the autogen.It would be nice to have someone from the FSX team explain the downside of having this set to 0, because so far I have found none.. performance wise It would be hard to say there is an 'improvement' but flying low, fast and doing hard turns does not seem to affect the smooth experience I have. (and my machine is mid-low end)So, this is not some kind of 'magic' tweak, all I'm saying is that it seems to eliminate the spikes, and it would be nice if someone can test if there is any 'negative' effect when setting it to 0.

Share this post


Link to post
Share on other sites

Just a friendly reminder of what the ACES team has already written:BUFFERPOOLSThe pedestrian sounding BUFFERPOOLS is a section of its own in the fsx.cfg file. There is a setting in there called Poolsize, as in[bUFFERPOOLS]Poolsize=nWhere n is the amount of bytes we will allocate for one pool of vertex and index buffers to store geometry.Again from Raf (Rafael Cintron, part of the FS Graphics and Terrain team):

Share this post


Link to post
Share on other sites

My French is almost non existent, but i think i can understand what he says here :

Avec ma carte video

Share this post


Link to post
Share on other sites
My French is almost non existent, but i think i can understand what he says here :However, the best will be i try it myself...
Well.. it might very well mean something 'other than' ZERO, for 'unlimited' frames the value is 0, so I don't know if a value of zero in PoolSize could mean 'unlimted' or 'dynamic' and not a fixed allocated ammount. So far it has been worked very good, but it requires further testing to see if there are any downsides to using it.

Share this post


Link to post
Share on other sites
Well.. it might very well mean something 'other than' ZERO, for 'unlimited' frames the value is 0, so I don't know if a value of zero in PoolSize could mean 'unlimted' or 'dynamic' and not a fixed allocated ammount. So far it has been worked very good, but it requires further testing to see if there are any downsides to using it.
zero means zeroit means you are not allocating any video memory to buffering geometry around the aircraftsetting it to zero and seeing a better result would indicate you are pushing the sim too hard for you hardware and that small amount of VM is helping you over the humpI never seen a correctly set up system remove the bufferpool entry and get better results and as a matter of fact I run 70-100MB to smooth out flight over large amounts of AG trees. If I ran with no BP in the config or set to zero my systems would stutter badly.What ever the reason for the change, if it works for how you have things set then use it.. thats all that matters. But be aware, if at some time your typical scenery changes and you start seeing stutters it could be caused by the lack of the default BP amount in the configSomething else that BP effects is latency on the PCIe buss. It was discovered some time ago that the higher the BP setting the lower the latency in requests to PCIe calls. Those on 768 - 1GB video cards which run the higher bufferpools settings see better results and solutions to sound crackle problems related to high autogen settings because of that as well as geometry buffering

Share this post


Link to post
Share on other sites

Do you think zero is possible ? There might be a... protection for vital settings. Like i said, i am not sure about this. Maybe i can find out.Btw, i was at it yesterday and can confirm that my 280 GTX is a happy camper with BP 200,000,000. I was never lucky with this tweak and the 8800 GTX (for whatever reason). The TBM i have to keep at 40 though for a very smooth ride.

Share this post


Link to post
Share on other sites

My only experience with 'BufferPools' was when it was first mentioned as a tweak and I was looking for better performance after SP1. I put it in and tried a few different values but it just seemed to make things worse so I removed it.When SP2 came along (Acceleration), my system could not handle that and I got auotgen spikes and BSODs all over the place and so I went back to SP1 which is what I currently run without problems.My video card is a 256Meg AGP card and Ive begun to wonder if the RTM->SP1->SP2 changes did not make things progresively worse for AGP users while shifting towards PCIe users.The one thing that surprises me very much are reports from people who have systems that appear to be much (MUCH) stronger than my Athlon64 2.4Gig with a 6800GT but yet they report lower frame rates than I get. It makes me leary of upgrading.BTW - my only addon is FEX and I run without a lot of traffic. (actually I have zero autos and only some GA traffic at the moment). Im hoping that the only reason those with much better systems report low frame rates is that they are using many complicated addons with very high settings. I use settings which give me as good of an appearance as I can get while maintaining at least 16FPS. Im often at my limit of 20. It works for me. :) I get dropped to single digits at places like FTX Perth or Sydney or Brisbane. My new system will surely do better (I hope)

Share this post


Link to post
Share on other sites
zero means zero
Nick,Consider the following:[bufferPools]PoolSize=0has effectively, caused an increidible consistent, performance gain over the past two months. Now, We know it doesn't sound 'logic' or there is noscientific way to prove it.. however, think about this:In the early FS9 days... there was a tweak to DISABLE AGP aceleration, remember it? I think it was TextureAGP=0 or something like that.. that tweak didn't make any difference in my OLD PC's but it definitely did in my newer ones, so, my conclusion, at the time was.. well, maybe NOT using the Video Card memory, but using system memory is better... oh well Now, lets fast forward 3 years... BufferPools, Video memory speed and i7 processors..I have an nVidia GTX 285 card (default clocks), an Overclocked i920 @ 4.2 Ghz, with low latency (CAS 7) memory running its memory bus at 1595 Mhz (x2)now.. in my specific situation, my computer's memory, is FASTER than the Video Card memory.. so, I have, LOWER latency and FASTER bus speed on my system memory subsystem. What happens, if I tell FSX DONT USE THE VIDEO CARD MEMORY, use the system memory because its faster, lower latency memory (and here is where the PoolSize=0 makes sense to me) Again, its been more than two months, and PoolSize=0 was the miracle tweak for me. (along with a TBM of 15) yes.. 15

Share this post


Link to post
Share on other sites
zero means zeroit means you are not allocating any video memory to buffering geometry around the aircraft"EMFBI... But are you the same NickN who posted the fsx tweaking guide at simforums? If so..please allow me to offer a public thank you to what I believe is the absolute best FSX tweaking guide....I have used it and, as I have said in other forums...found my sweet spot. To those of yo who do not know Nick's work, take a look at this....http://www.simforums.com/forums/forum_posts.asp?TID=29041again, thank you for your contributions to the betterment of our magnificent obsession.Sherm

Share this post


Link to post
Share on other sites
hi bojote, does your frame rate go up too?
No, it does not. For me, setting the PoolSize to 0 only offers a 'smoother' experience. Somehow, and for a reason I don't know. setting *ANY* bufferpools value, will cause what appears to be a framerate overlapping. I do mini warp jumps, which kills the inmersion.Another point to mention is this:The PoolSize=0 value, seems to be effective ONLY under Windows XP 32-bit. With Windows 7 64-bit ANYTHING below 300,000,000 will cause heavy stutters and artifacts, but 300,000,000 seems to be perfect... weird.As for poolsize having any impact in performance, it does. But you can't notice it. The only way to test is run task manager and watch CPU utilization. With poolsize=0 you reduce CPU utilization by 1-2% and setting UNLIMITED frames 5% more, you can test and see for yourself.

Share this post


Link to post
Share on other sites