Jump to content

Archived

This topic is now archived and is closed to further replies.

chavins

dot net frameworks

Recommended Posts

i have win xp professional with sp3 installed, plus (among other things) all of the dot net frameworks out to dot net framework 3.5 sp1. apparently everything was working well, but today i was running fsx/sp2 along with rex and the sim suddenly froze. a typical microsoft error message appeared and i had trouble following it. it said asomething about a fatal exception, also mentioned rex, and dot net framework 3.5 sp1. i am not sure whether it actualy told me what was wrong and exactly where the error is. i chose the option to ignore the mesage and then the sim crashed todesktop.my questions are:are each of the numbered dot net frameworks separate and independent from each other, or do they function as a single piece of software? if i need to repair or replace 3.5 sp1, can i just do so with the current version of this softwaare or do i need to somehow fix any or all of the other dot net frameworks?can one use control panel/add-remove software to repair dot net versions, or does the faulty version need to be uninstalled first?any guidance will be greatly appreciated.

Share this post


Link to post
Share on other sites
i have win xp professional with sp3 installed, plus (among other things) all of the dot net frameworks out to dot net framework 3.5 sp1. apparently everything was working well, but today i was running fsx/sp2 along with rex and the sim suddenly froze. a typical microsoft error message appeared and i had trouble following it. it said asomething about a fatal exception, also mentioned rex, and dot net framework 3.5 sp1. i am not sure whether it actualy told me what was wrong and exactly where the error is. i chose the option to ignore the mesage and then the sim crashed todesktop.my questions are:are each of the numbered dot net frameworks separate and independent from each other, or do they function as a single piece of software? if i need to repair or replace 3.5 sp1, can i just do so with the current version of this softwaare or do i need to somehow fix any or all of the other dot net frameworks?can one use control panel/add-remove software to repair dot net versions, or does the faulty version need to be uninstalled first?any guidance will be greatly appreciated.
Hi, I'm far from an expert but it's my understanding that if software requires a specific version of .Net then you'll need that specific flavor. Normally, it's safe to assume that version 2 of some software replaces version 1, and that version 3 replaces both 1 and 2. Each later version includes everything in the prior versions, so that the prior versions are no longer necessary. Apparently the .NET framework isn't "normal". For example, software that requires .NET framework version 1 might not work if only version 2 is installed. While most software upgrades replace the previous versions, .NET framework installations do not. If you install version N+1, version N remains.If you're having an issue with REX, make sure you have the version of .Net installed that they require. They also have an excellent forum if the issue persists. Hope it helps

Regards, Kendall

Share this post


Link to post
Share on other sites
i have win xp professional with sp3 installed, plus (among other things) all of the dot net frameworks out to dot net framework 3.5 sp1. apparently everything was working well, but today i was running fsx/sp2 along with rex and the sim suddenly froze. a typical microsoft error message appeared and i had trouble following it. it said asomething about a fatal exception, also mentioned rex, and dot net framework 3.5 sp1. i am not sure whether it actualy told me what was wrong and exactly where the error is. i chose the option to ignore the mesage and then the sim crashed todesktop.my questions are:are each of the numbered dot net frameworks separate and independent from each other, or do they function as a single piece of software? if i need to repair or replace 3.5 sp1, can i just do so with the current version of this softwaare or do i need to somehow fix any or all of the other dot net frameworks?can one use control panel/add-remove software to repair dot net versions, or does the faulty version need to be uninstalled first?any guidance will be greatly appreciated.
It is extremely unlikely that there is anything wrong with the frameworks... They are separate and live side by side. They may be removed via the control panel individually and simply reinstalled like any other program.DJ

Share this post


Link to post
Share on other sites

×
×
  • Create New...