Sign in to follow this  
Luc Brusselmans

Atc.dll causing error

Recommended Posts

hello everybody,Flying from KMSP (BluePrint simulations) to KDEN (Imagine Simulation) I got fs 9.1 shutting down on me.Error message stating that atc.dll caused the error but when opening the technical info I see quite a number of probable causes.Now I have read somewhere about act.dll but I can't find the thread anymore.I am using Windows XP 64bit.In the past I have flown quite a lot on Denver (from Imagine Simulation) and I have never experienced this kind of error.Can anyboy point me in the right direction?ThanksLuc BrusselmansBelgium

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Luc,Are you using AI traffic?If so.Turn it off and do a test.Same problem?

Share this post


Link to post
Share on other sites
Luc,Are you using AI traffic?If so.Turn it off and do a test.Same problem?
Vaughan,no, I don't use any AI traffic, except for the default AI included in Fs-9 (maybe I should....).I have read somewhere this crash can be caused by a problem with ATIS frequencies but I don't know where I read it or how to solve it.And I have never experienced this kind of crash with KDEN.Thanks anyway.Luc BrusselmansBelgium

Share this post


Link to post
Share on other sites

Luc,I should have said:In MSFS, set (verify) your AI traffic to 0 (zero), then test again.

Share this post


Link to post
Share on other sites
Vaughan,no, I don't use any AI traffic, except for the default AI included in Fs-9 (maybe I should....).I have read somewhere this crash can be caused by a problem with ATIS frequencies but I don't know where I read it or how to solve it.And I have never experienced this kind of crash with KDEN.Thanks anyway.Luc BrusselmansBelgium
Hi Luc,It's not related to Ai traffic but to a long-standing bug in FS9. It occurs on a change of frequency (TWR to GND for example) and is associated with other frequencies used in your plan. I've experienced it when a frequency at EGLL is the same as one at LIRF.Try entering removeatc=yes in the General section of FSUIPC.INI. That will stop some instances of the bug but not all. I've beaten it by using AFCAD to change one of the frequencies at either of the airports in your plan but that may introduce the problem at previously unaffected airports.It's a pain but fortunately is quite rare. If it occurs when you switch to a frequency at KDEN try editing the AFCAD for KDEN and change the frequency to another. GND usually has more than one anyway.

Share this post


Link to post
Share on other sites
Hi Luc,It's not related to Ai traffic but to a long-standing bug in FS9. It occurs on a change of frequency (TWR to GND for example) and is associated with other frequencies used in your plan. I've experienced it when a frequency at EGLL is the same as one at LIRF.Try entering removeatc=yes in the General section of FSUIPC.INI. That will stop some instances of the bug but not all. I've beaten it by using AFCAD to change one of the frequencies at either of the airports in your plan but that may introduce the problem at previously unaffected airports.It's a pain but fortunately is quite rare. If it occurs when you switch to a frequency at KDEN try editing the AFCAD for KDEN and change the frequency to another. GND usually has more than one anyway.
Ray,That's the explanation I was looking for. I knew that I read it some where but couldn't remember where...I'll start with changing the fsuipc ini file. If the problem still pops up at Denver I'll try to change some of those frequencies.Thanks for the tipLuc BrusselmansBelgium

Share this post


Link to post
Share on other sites

Ray,Could AI traffic at a nearby airport changing frequency / flight plan cause this problem?Or is it only the users aircraft/flight plan?

Share this post


Link to post
Share on other sites
Ray,Could AI traffic at a nearby airport changing frequency / flight plan cause this problem?Or is it only the users aircraft/flight plan?
Ai traffic cannot cause this. If you notice this only happens immediately after a frequency change in your own flight and virtually always at the arrival end.

Share this post


Link to post
Share on other sites

Ray,Thanks for confirming.I do not use AI or FS9's ATC.I have never had the problem with FS9.Yet!

Share this post


Link to post
Share on other sites
Ray,Thanks for confirming.I do not use AI or FS9's ATC.I have never had the problem with FS9.Yet!
Many haven't and it's still pretty uncommon. I should also say the problem can occur with Radar Contact but it's not RC's fault but the underlying problem in FS9.

Share this post


Link to post
Share on other sites
Many haven't and it's still pretty uncommon. I should also say the problem can occur with Radar Contact but it's not RC's fault but the underlying problem in FS9.
Ray,This confirms my suspicion because at the time of the crash I was using RadarContact. (As I always do)thanks for sharing this infoLuc BrusselmansBelgium

Share this post


Link to post
Share on other sites

Luc,When I saw you don't use FS9's ATC and no Ai I thought you must be a VATSIM pilot but I'm pleased to hear you use RC. :(

Share this post


Link to post
Share on other sites

That atc.dll error could occur when using any other atc application alternative. I had the same error flying KMSP - KDEN with RC and it was cured by the FSUIPC.ini entry as described by Ray."removeatc=yes" should be used when using RC, PFE, VATSIM, or other application of that type. It does not shut down FS AI movements, just basically FS ATC comms.

Share this post


Link to post
Share on other sites
That atc.dll error could occur when using any other atc application alternative. I had the same error flying KMSP - KDEN with RC and it was cured by the FSUIPC.ini entry as described by Ray."removeatc=yes" should be used when using RC, PFE, VATSIM, or other application of that type. It does not shut down FS AI movements, just basically FS ATC comms.
Too All,Today I flew the same route with RC but now with the "removeatc=yes" in place.No crash....So, I am happy again.thanks for aal the help here.Luc BrusselmansBelgium

Share this post


Link to post
Share on other sites
Too All,Today I flew the same route with RC but now with the "removeatc=yes" in place.No crash....So, I am happy again.thanks for aal the help here.Luc BrusselmansBelgium
That's good news Luc, you're welcome. :(

Share this post


Link to post
Share on other sites

Im sorry to rip open a topic this old 
But im having trouble with the ATC.dll crash here in 2014 
Every time i land at an airport and contact ground. The program stops responding and restarts
Is there any fixes for this problem
I dont have FSUIPC Full 
Since i dont have money to buy it 
I havent had any problems before with this
And i have so many Addon's to the game so a reinstall would be the most critical for me with this problem 
I have tried to change the frequencies of all of my airports (the ones i use for flying) 
It works but then some of the aiports dont have ground and tower separated or at some airports not even able to contact the airport in ATC 

I use FS9.1 
I dont have Radar Contact 
So i need the FS ATC
And have updated all i can 
Ive been reading posts with this problem for quite a while now 
And still cant figure out the fix of it 


Computer: Acer Aspire M3800 
 
Processor: Pentium ® Dual-Core CPU E5400  @ 2.70GHz  2.70GHz
 
Ram: 4GB
 
System windows 7 Home Premium 64 bit 

Im from Denmark so showing the log will just confuse you since the language is Danish on this computer 

HELP PLEASE

Share this post


Link to post
Share on other sites

Have you edited the FSUIPC.ini file ?    removeatc=yes   

 

That shuts down FS9 ATC when it is not needed as it would bomb occasionally if not used but left running when another ATC app was being used. It also in this manner disabled the repeated frequency issue. The user

MrRevoSmiley

 

states he needs to use FS9 ATC.

Share this post


Link to post
Share on other sites

I have fixed the problem (sorta) or just got around it atleast
I did erase all my addon airports UNICOM frequencies and reseted their ATIS frequencies (I dont fly to other airports than what i have addons for) 
to something not usable for flightsim like "137.750" or "139.250" 

I cant use the ATIS but its okay for me since i rather will be able to fly than using those frequencies 
But thanks for any help i was givin 
Next up is jut to learn to be able to use the ATIS again 


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this