Sign in to follow this  
jfri

Problems with using CH Pro USB Pedals

Recommended Posts

I have just purchased the CH Pro Rudders USB and FS 2004.I have two problems with itFirst there is a problem releasing the brakes. It seems thepedals somehow controls them. They can be applied if I just touch the rudder pedals.But I havn't been able to release them with the pedals.I can have the BRAKE text in the lower left corner go out if I first press space and then'.' sometimes the text says differential brake. I can't release the brakes with the joystick any more in spite of having release/apply brake attached to a buttonSecond it is very difficult to steer the aircraft with the rudders, especially on the ground. It seems the controls overreact.Let me also state that I have calibrated the pedals and I have experimented with the sensitivity settings. What is the best settings?Should it really be like this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I got my pedals on Thursday and I've been fighting with them. I think I'm finally close to making them useful...Here's what I did:- downloaded and installed the CH control center from the CHProducts web site- Set the sliders for the pedals in FS2004 full right for sensitivity and full left for null zone. This should take care of that brake message.- Used the axis settings in the calibration tool (select test/calibrate from the Control manager, and then choose the axis settings tab).- I set the X axis and Y to "center" and then used the up arrow on the gain controls for X and Y as far as they would go. I left the sensitivity and null zone for these alone, since the gain control seems to make the brakes very responsive when pressed in but not so easy to accidentally activate when using the rudder- I left the gain control for the Z axis (the rudder) alone. I've set the sensitibity for that to 80, though I am still fiddling with it.Here's a screenshot of what I ended up with. I'd be interested in hearing from anyone with more experience than I if these settings are fundamentally wrong ... I'm not sure if using the center checkbox in the X and Y axis is correct, but the gain control was the only way I could dampen the touchiness of the brakes without reducing the ability to actually stop the plane.http://forums.avsim.net/user_files/29482.gifWith these settings, I was able to taxi pretty effectively. I'm still trying to get used to the rudder in the air, which was initially frustrating because the default C172 seems to always fly coordinated. I'm trying the Realair C172 now.

Share this post


Link to post
Share on other sites

I'm using Win XP Pro. I didn't mention that. Does it change anything?You say set the sensivity full right. But is that not the most sensitive setting? The problem seems to be that the rudder are too sensitive.The brake problem did handle by disabling the joystick assignments for the brake on y and x axis.I have also discovered that there are some button function by presseing the pedals backwards (but not along Z axis)What is the purpose of this and how is it supposed to be used?

Share this post


Link to post
Share on other sites

What is CH Control center? The same as CH Control Manager 2.1?But if that so the rudders are not listed among the items it can be used with.

Share this post


Link to post
Share on other sites

>What is CH Control center? The same as CH Control Manager>2.1?>But if that so the rudders are not listed among the items it>can be used with.I had the same problem and cured it by calibrating the pedals as described above using the CH control manager. It fixed mine perfectly. I cured it previously in FS2002 using FSUIPC, so either one should be able to fix it for you.KP

Share this post


Link to post
Share on other sites

I have now tried using this Control Manager program from CH an recalibrated. The problems with the brakes are gone, but now I can't control the rudder at all. The ball is moving slightly but is not affected by rudder pedals. Also when I look at airplane from outside I can see that the rudder is not moving when moving the rudder pedals. But it did before. What is wrong now?

Share this post


Link to post
Share on other sites

I have installed the Control Manager and got it to function.I also tried the settings you suggested and I still find it verydifficult to control the plane. It still seems to overreact both on ground and in the air. But I have to use the rudders because the ball is moving slightly around the center both on ground and in the air.So what to do? The rudders were supposed to make the flying easier.At least I think I have read here that it would be easier controlling the plane while taxing. for me the opposite is true.

Share this post


Link to post
Share on other sites

I second that, FSUIPC made my pedals work beautifully.Boyd Barker, Senior Command CaptainDirector of Special Projects & KBOS Hub ManagerWestWind Airlines

Share this post


Link to post
Share on other sites

How did you do that with FSUIPC? Is the registered version neccessary?

Share this post


Link to post
Share on other sites

Look in the FS200? settings as well under Joystick assignments, and sensitivities.You can set dead zones and sensitivities here. I set my brakes to have a large null zone so that they don't trip immediately, but the rudder has no null zone and full sensitivity.One problem I had as well is that my X36 stick has an in builr rudder rocker, which FS2004 picked up and set as a rudder - thus I had two rudders fighting for control.So it's worth a look at least.Especially if the CH rudders are fine in other sims.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this