Sign in to follow this  
Followers 0
yankeegolf3

SPAD drivers

14 posts in this topic

HI,SPAD drivers are free drivers for the Saitek panels (switch, radio, MCP). They are available here: http://fstools.weebly.com/They work great and are a very useful replacement for the Saitek drivers which are useless. One of the major issues being the inability to fine tune the knobs. I've always been surprised by Saitek shortcomings regarding their software which make their nice panels nearly useless. Now they even recommend the SPAD drivers. A good move which made me buy their otherwise great stuff.I have one issue though. When I have the radio panel only, it works fine. the same with the MCP only. But when I have both, the panels seem to freeze. Actually they don't because when I make a change from the cockpit, it shows on the panels, while the opposite is not true. I am not sure it is caused by the drivers because it seems that I am the only one to have this problem on the Saitek and the Spad forums. It can also be FSUIPC related , I don't know. It looks like a communication problem ,sort of saturation issue. Any idea?Thanks.

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I never have any problems, might want to make sure you either don't have UAC or you enable to run as admin. ALso make sure you delete the standard Saitek drivers.

0

Share this post


Link to post
Share on other sites
I never have any problems, might want to make sure you either don't have UAC or you enable to run as admin. ALso make sure you delete the standard Saitek drivers.
Hi,I have windows XP so no problems with administrator rights.I've made a strange discovery. I can make my two panels work when I put FSX in the task bar. I am totally baffled!!! :Shocked: Has anybody experienced that? There must be a display conflict of some kind. Any idea?
0

Share this post


Link to post
Share on other sites

I've found what caused my problem. I had installed an add on to the task manager which allows to set a priority to a running application. I had selected high priority for FSX. When I installed the SPAD driver I did not set any priority because I did not remember my priority software. SPAD was set to the normal priority by default. As a consequence there was a conflict between FSX and SPAD due to the different priority levels. I restored FSX to a normal priority and that was it; Everyting works fine now.I am surprised that I am so clever... :rolleyes:

0

Share this post


Link to post
Share on other sites

Hi,
could anyone tell me, if I can use the Saitek Panels with the SPAD in the Airbus X Extended ?

Thanks in advance...

0

Share this post


Link to post
Share on other sites

Hi,

could anyone tell me, if I can use the Saitek Panels with the SPAD in the Airbus X Extended ?

 

Thanks in advance...

Hello,

I don't know but I've never had any problems with any aircraft even the A2A B 377 and the aerosoft Da 20 so I guess it should work. You can try anyway, it will not break anything and the drivers are free.

0

Share this post


Link to post
Share on other sites

Hello,

I don't know but I've never had any problems with any aircraft even the A2A B 377 and the aerosoft Da 20 so I guess it should work. You can try anyway, it will not break anything and the drivers are free.

Ok, thank you...

I will try it

0

Share this post


Link to post
Share on other sites

Can't you just use LINDA?  I dropped SPAD 3-4 months ago.  You can do a lot more with LINDA.

0

Share this post


Link to post
Share on other sites

Can't you just use LINDA?  I dropped SPAD 3-4 months ago.  You can do a lot more with LINDA.

Jehhr ? Nice

0

Share this post


Link to post
Share on other sites

I have the Saitek switch Panel along with SPAD and FSUIPC. I deleted the saitek drivers for the switch panel. When I click any switch on my switch panel in the A2a cessna 172, I get a runtime 6 overflow error. Does anyone have any idea how to fix this? I have fsx and win7. I'm not very happy with SPAD. :(

0

Share this post


Link to post
Share on other sites

 

 


I have the Saitek switch Panel along with SPAD and FSUIPC. I deleted the saitek drivers for the switch panel. When I click any switch on my switch panel in the A2a cessna 172, I get a runtime 6 overflow error. Does anyone have any idea how to fix this? I have fsx and win7. I'm not very happy with SPAD. :(

 

You can get Saitek drivers from here...

 

http://www.saitek.com/uk/down/drivers.php

 

Again, if you don't like SPAD, LINDA works well and you can do more with the switches.

0

Share this post


Link to post
Share on other sites

Thanks Gregg for the suggestion. I'm not very techy. The saitek drivers conflict with my EZCA. Is there a LINDA FOR DUMMIES? What do I need to do to make my switch panel work? Any videos? It seems like I would have to reprogram my flight yoke, throttles, and switch panel, using LINDA. A lot of work. Doesn't anyone just make plug and play anymore? :huh:

0

Share this post


Link to post
Share on other sites

 

 


Thanks Gregg for the suggestion. I'm not very techy. The saitek drivers conflict with my EZCA. Is there a LINDA FOR DUMMIES? What do I need to do to make my switch panel work? Any videos? It seems like I would have to reprogram my flight yoke, throttles, and switch panel, using LINDA. A lot of work. Doesn't anyone just make plug and play anymore? :huh:

 

LINDA shouldn't conflict with anything...it connects directly to FSUIPC via LUA.  The conflict could be that EZCA is trying to control the same button/switch?  There are some brief manuals that come with LINDA that explain it pretty well.  You click the Settings button at the top and configure your hardware on the right under Summary.  It's not complicated.  Then you click on Joysticks.  Your controllers are the pictures at the bottom.  Click a button and you'll see it highlighted.  Then left click on it and assign that click to a command and test it. 

 

Some aircraft do come preprogrammed (sort of) but you always need to test and adjust.  I have all my Carenado aircraft, Q400, Flight1 Mustang, PMDG 737, A2A C172, RealAir Dukes and Legacy set up this way.  It takes a bit of getting used to but, once you get it figured out, it's easy.  Worth the bit of time investment.

0

Share this post


Link to post
Share on other sites

LINDA shouldn't conflict with anything...it connects directly to FSUIPC via LUA.  The conflict could be that EZCA is trying to control the same button/switch?  There are some brief manuals that come with LINDA that explain it pretty well.  You click the Settings button at the top and configure your hardware on the right under Summary.  It's not complicated.  Then you click on Joysticks.  Your controllers are the pictures at the bottom.  Click a button and you'll see it highlighted.  Then left click on it and assign that click to a command and test it. 

 

Some aircraft do come preprogrammed (sort of) but you always need to test and adjust.  I have all my Carenado aircraft, Q400, Flight1 Mustang, PMDG 737, A2A C172, RealAir Dukes and Legacy set up this way.  It takes a bit of getting used to but, once you get it figured out, it's easy.  Worth the bit of time investment.

Gregg-

My switch panel is working well with LINDA. EZCA works great, also. One question-

My MCP com port cannot be found. Any idea what this is for, and how do I find the com port number? Thanks for your help.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0