Sign in to follow this  
Guest DrJimi

Announcement: new "groundhandling" gauges

Recommended Posts

I have just uploaded a new version of my "groundhandling" gauges to the library, so it should be available soon. And yes, it's still free :-).File: rcbgh-31.zipIt contains a.o. pushback control, taxispeed control, brakepressure and brakesounds.It includes an all-new sound playing mechanism, made by R.L. Clark (THANKS !), and everything works for both FS2002 AND FS2004.New features a.o.:- Several new pushback and control/attention sounds, like "roll" sound.- Extensive consistancy control, like "you cannot start pushback while aircraft is moving" and "you cannot activate taxispeed control with the engines off".- Brakes sound gauge- Much improved Taxispeed control algoritm, using Throttle AND Brakes- Can now be used in any panel for any aircraft: no more problems with "magneto" aircraft, and the gauges can now be at any position in the panel (including main panel)- All '.xml gauges and required bitmaps now bundled into one .cab file.- Complete package, not depending on addon's like FSsound or FSUIPC.Includes a comprehensive manual, with installation and upgrade instructions.Enjoy .....Rob Barendregt

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

great stuff Rob,thanks for making it available mate ;-)if you happen to be thirsty,and find yourself in Friesland,come get a beer or something.

Share this post


Link to post
Share on other sites

Hoi Tom,If (and when) I come in Friesland, I'd rather drink a Beerenburg :-)(Don't know how to write that, only how to drink it :-) )Cheers, Rob

Share this post


Link to post
Share on other sites

No problemo Rob,lot's of Beerenburg factories here...only one is good enough tho:Sonnema.See ya(do NOT design after finishing a bottle of Beerenburg...but i think you know that one ;-) )

Share this post


Link to post
Share on other sites

For those of you that have problems with the "brakes-not-releasing" issue I described in the README (for which I added the NoBrake version of the gauge):You are probably using FS2004 AND the registered version of FSUIPC.I have found what the problem actually is, and have a new version of the taxispeed gauge. But before I upload it I want one or two testers first, preferably persons who have this problem now.. So if you are interested: please send me an EMail (see README for address) Rob

Share this post


Link to post
Share on other sites

HI RobJust installed it, works great many thanks for your work ,its much appreciated.It worked on all aircraft I tried it with perfectly, except when using it with Fanda's Dash8 I get Pushback but I hear no sounds.I will recheck My panel.cfg for this aircraft.Thanks againJohn

Share this post


Link to post
Share on other sites

HelpI have been working on this for hours. no gauge in the 747 panel, I did everything to the letter. I did the one for 747 aircraft. did I missomthing. thanks JerBear

Share this post


Link to post
Share on other sites

Successfully installed in the PMDG 737NG, except I installed the button icon in Window 1 (PMDG Main panel), not Window 0 as you documented. Works excellent, except for one minor issue that may be related to your brakes post -- I am using the registered FSUIPC. Sometimes after auto taxi the "foot" brakes will not work, confirmed by no brake pressure on your gauge. Parking brake does work, but it's a sudden stop :-)I'd be glad to test a revised version if you feel it may be of value. I'll email you.Thanks, Jimi

Share this post


Link to post
Share on other sites

""...except I installed the button icon in Window 1 (PMDG Main panel), not Window 0 as you documented ...""Hi Jimi,Yes of course you can. Come to think of it, that "the position of the icon is also flexible" must be the only thing I didn't document :-)Drop me an email, and I'll send you the update.Rob

Share this post


Link to post
Share on other sites

Hi Jimi,What was the screen location for gauge in the PMDG 737 that you used?RegardsDrayton

Share this post


Link to post
Share on other sites

>Successfully installed in the PMDG 737NG, except I installed>the button icon in Window 1 (PMDG Main panel), not Window 0 as>you documented. Works excellent, except for one minor issue>that may be related to your brakes post -- I am using the>registered FSUIPC. Sometimes after auto taxi the "foot" brakes>will not work, confirmed by no brake pressure on your gauge.>Parking brake does work, but it's a sudden stop Thanks Rob for great add-on. Just like in above I install with no problem but yes there is some issues with braking and I also use register FSUIPC. Another question I have, if is possible to make Icon_Pushback invisible, I had it set that way for your older work.Thanks again and looking forward for an upgrade to the brakes.

Share this post


Link to post
Share on other sites

I used:gauge24=rcb_groundhandling!Icon_Pushback, 129,566,12,12It's above the other icons.

Share this post


Link to post
Share on other sites

Really Great, Rob!Hope u don't mind but I've done some resizing and repositioning for the gauge and icon as per piccie for two great aircraft for FS9. Here's the details....AlanFS9PMDG 737NGICON:gauge52=rcb_groundhandling!Icon_Pushback, 651,597,21,21Gauge Location and resizing:[Windowxx] //DON'T FORGET THE NUMBER!size_mm=98,50ident=10005visible=0window_size= 0.15,0.1window_pos= 0.356, 0.570background_color=16,16,16gauge00=rcb_groundhandling!XMLSoundSwitch, 0, 0, 25, 18gauge01=rcb_groundhandling!AutoTaxiAfterLanding, 25, 0, 24, 18gauge02=rcb_groundhandling!AutoTaxiAfterParkingbrake, 49, 0, 24, 18gauge03=rcb_groundhandling!ParkingBrakeSwitch, 73, 0, 25, 18gauge04=rcb_groundhandling!PushbackDisplay, 0, 18, 43, 32gauge05=rcb_groundhandling!TaxispeedFS2004, 43, 18, 30, 32 gauge06=rcb_groundhandling!BrakePressure, 73, 18, 25, 32gauge07=rcb_groundhandling!PushbackStates, 0,0gauge08=rcb_groundhandling!XMLSoundServer,0,0gauge09=rcb_groundhandling!BrakeSound, 0,0gauge10=rcb_sound!sound,0,0,,,9998 9999 95Eaglesoft BeechJet400AICONgauge52=rcb_groundhandling!Icon_Pushback, 39,746,21,21Gauge Location and resizing[Windowxx] //DON'T FORGET THE NUMBER!size_mm=147,75ident=10005visible=0window_size= 0.20,0.15window_pos= 0.474, 0.465background_color=16,16,16gauge00=rcb_groundhandling!XMLSoundSwitch, 0, 0, 37, 27gauge01=rcb_groundhandling!AutoTaxiAfterLanding, 37, 0, 36, 27gauge02=rcb_groundhandling!AutoTaxiAfterParkingbrake, 73, 0, 36, 27gauge03=rcb_groundhandling!ParkingBrakeSwitch, 109, 0, 37, 27gauge04=rcb_groundhandling!PushbackDisplay, 0, 27, 64, 48gauge05=rcb_groundhandling!TaxispeedFS2004, 64, 27, 45, 48gauge06=rcb_groundhandling!BrakePressure, 109, 27, 37, 48gauge07=rcb_groundhandling!PushbackStates, 0,0gauge08=rcb_groundhandling!XMLSoundServer,0,0gauge09=rcb_groundhandling!BrakeSound, 0,0gauge10=rcb_sound!sound,0,0,,,9998 9999 95

Share this post


Link to post
Share on other sites

Hi Edward,The new version appear to work fine now.I'll release them tomorrow.About: ""if is possible to make Icon_Pushback invisible""What do you mean by that ? Just send me an EMail what you want (and how you did that in the previous version)Rob

Share this post


Link to post
Share on other sites

Rob,Installed the gauge.. Great... Notice a little hit on frame rates...Anybody else notice a frame rate hit??Barry

Share this post


Link to post
Share on other sites

Hi Barry,I tested that on my 2.53 Ghz machine.At the airport (and the FS settings) I use: the average FPS went from 36 (without all the gauges) to 34.5 (with the gauges installed and the window opened). That why I said "hardly noticeable" in the README :-)Cheers, Rob

Share this post


Link to post
Share on other sites

Hey Rob,I have the exact same processor as you... What video and how much memory are you using? I can only get 18-20.Barry

Share this post


Link to post
Share on other sites

Hi Barry,ATI9700, 512Kb.But I personally find comparing FPS values rather pointless without knowing the setting of ALL FS variables.An example only: my FPS 34.5 was measured at EHAM. But only changing the heading of the aircraft full circle and varying the zoom factor between 0.5 and 2, the av.FPS values (when stabilised) varied from 24 to 41. If I change other settings as well (weather, time, AI %, screen resolution, displaymode, AA/AF settings, other sliders, etc etc) I can get as low as 16 and as high as 62 with the same aircraft at the same location. See my point ?Rob

Share this post


Link to post
Share on other sites

I too have lost toe brakes after this fantastic addition. Will the update fix this? Its damned hard trying to stop now without doing a "handbrakey"!!Jon

Share this post


Link to post
Share on other sites

Hi Jon,Yes, it will.I have got it working in all configurations I can imaging, but I will not release it untill I'm absolutely sure when to advise which braking system to use. I expect in a few days, it's now being beta-tested.FYI: There are many variables, like:- FS2002 or FS2004- Toebrakes pedals installed or not- Toebrakes calibrated via a FSUIPC or not.And in every configuration, the braking system in FS2004 appears to behave differently :-(.Rob

Share this post


Link to post
Share on other sites

Great. I will wait with great anticipation for the patch/update.Till then , I'll just keep praticing handbrake stops, and I apologise to all ATC for the cry off - "$#@* !! , NO BRAKES !!!!":)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this