Archived

This topic is now archived and is closed to further replies.

Simba

CTD problem

Recommended Posts

Hi,I dont know if this is related to fs2crew or not but it seems to occur only when I use fs2crew, I get a CTD. The culprit points to a xactengine.dll error, which is related to directx. Just trying to figure out what is causing this error, so I thought I would ask. Any ideas?Win xp proFS9

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,I dont know if this is related to fs2crew or not but it seems to occur only when I use fs2crew, I get a CTD. The culprit points to a xactengine.dll error, which is related to directx. Just trying to figure out what is causing this error, so I thought I would ask. Any ideas?Win xp proFS9
1. Re-install FS2Crew and SP1. Do not click "cancel" during the install procedure.2. Ensure no audio programs are running on your system that attempt to strip DRM rights from 3rd party music.3. Try lowing your audio hardware acceleration.One of those 3 should work.Cheers,

Share this post


Link to post
Share on other sites

Dear All,I bought some days ago your button version. When i try to switch on the HS button on the main panel, i get an error message: "XACT Audio Init Failed Please contact FS2Crew. Error code 0x8889000a" and FS goes to crash with wanting send message to Microsoft and so on.It was installed without any cancelling or error, and my FS went well till now. Please help me, what's wrong.Thanks in advance,TomWin7, 64bit, FS9.

Share this post


Link to post
Share on other sites

Did you try these two:2. Ensure no audio programs are running on your system that attempt to strip DRM rights from 3rd party music.3. Try lowing your audio hardware acceleration.

Share this post


Link to post
Share on other sites

Dear Bryan,2. There isn't any audio program running in the background.3. Please tell me how can i do that.ThxTom

Share this post


Link to post
Share on other sites
Dear Bryan,2. There isn't any audio program running in the background.3. Please tell me how can i do that.ThxTom
Hi Tom,See this:http://support.riverdeep.net/techtips_detail.asp?id=80Also, if that doesn't help, try using a program like "End it All" to terminate all non essentially processes running before you load FS.I still wouldn't be surprised if you had an audio program running the background that you may not even be aware of.

Share this post


Link to post
Share on other sites

Hi Bryan,OK, i was not successful, but thanks for help.The link given by You is usable only for 95,98, or XP but for Win7 isn't. I can't make lower the HW acceleration, at Win7 it is not possible, i think.In another case i tried switch off all process allowed by the op. system, but it was not any result.The error everytime is the same, in the win eventlog the error is causing by FSAudio.dll. So unfortunately my FS2Crew is unusable with sound at the moment.Best regards,

Share this post


Link to post
Share on other sites

It is 100% your sound card I had the same problem as you running a digital sound card, I changed the settings to the other sound card and FS2crew worked perfect. with either laud speakers or head phones.

Share this post


Link to post
Share on other sites
It is 100% your sound card I had the same problem as you running a digital sound card, I changed the settings to the other sound card and FS2crew worked perfect. with either laud speakers or head phones.
BCA,Can you give more details on exactly how you did that?Do you simply mean you selected a different audio device in the FS2Crew Audio Device Selector?Thanks,

Share this post


Link to post
Share on other sites

Dear Sirs, thanks for the help! I think i'm on the right track, i will be back if will be some result. :rolleyes:At the moment what i know something problem is in my audio chipset (Realtek, integrated on my motherboard), if i configure to use another audio device (i have several virtual, but they cannot be use to generate actual sound) it's not going to freeze. So i thing so, my problem is in my hardware with some device conflict, i don't know yet.Thx again, best regards,

Share this post


Link to post
Share on other sites

Hello byork I have two sound cards running and in settings was the digital sound card and for the other sound card was two choises SB audio and windows standard I chose windows standard and things worked I am not on my FS computer ATM if you need more details let me know I have now done two flight without problem.

Share this post


Link to post
Share on other sites
Hello byork I have two sound cards running and in settings was the digital sound card and for the other sound card was two choises SB audio and windows standard I chose windows standard and things worked I am not on my FS computer ATM if you need more details let me know I have now done two flight without problem.
Hi,That's interesting sound card setup you have there.Why would you want two sound cards?Important thing is got it all working.Cheers,

Share this post


Link to post
Share on other sites

I used to have SB running over a second computer with head phones, and aircraft sounds from laudspeakers, first computer . I just run now the one computer Aircraft sounds, cabin sounds over 1st card laud speakers SB (VATSIM) Controller and FS2crew over 2nd card and headphones. makes more realistic hearing all voice over head set and cabin sound is around you.

Share this post


Link to post
Share on other sites

Hi All,OK, the situation is te same here like at BCA59 more or less. And when i set the SB for hear cheklist everything is working. It's an interesting thing. Batting%20Eyelashes.gifBest regards,

Share this post


Link to post
Share on other sites
Hi All,OK, the situation is te same here like at BCA59 more or less. And when i set the SB for hear cheklist everything is working. It's an interesting thing. Batting%20Eyelashes.gifBest regards,
Tom (or should I say, Bruce :( ),Glad you got it sorted.Cheers,

Share this post


Link to post
Share on other sites