Jump to content

Archived

This topic is now archived and is closed to further replies.

askemou

Airspeed indicator not functioning!

Recommended Posts

Hello there, just got FSX installed. Now.. When I'm 5 mins into flight my Airspeed Indicator drops to zero and doesn't move.. Simpy inactive..It does it everytime I fly at around 5 minutes into the flight.Any help?

Share this post


Link to post
Share on other sites
Hello there, just got FSX installed. Now.. When I'm 5 mins into flight my Airspeed Indicator drops to zero and doesn't move.. Simpy inactive..It does it everytime I fly at around 5 minutes into the flight.Any help?
check your OAT you may be iced up, bob

Share this post


Link to post
Share on other sites

Sounds like you need to put the pitot probe heat on to prevent your pitot probe from icing up, if that ices up, the ice can block it and prevent it from registering air pressure, so your ASI will not work.You can test that by flying lower and see if it clears, if it does, it was the cold temperature and moisture higher up that caused it to ice up, although it may take a while to clear without probe heat on.Al

Share this post


Link to post
Share on other sites
check your OAT you may be iced up, bob
In other words for the OP since he might not understand, what Bob is saying is that if your outside air temp is too low your pitot tube might be iced up and therefore you're not getting your airspeed. Turn on the pitot heat and it should fix the problem.Edit: Al is too quick and beat me to it, haha

Share this post


Link to post
Share on other sites

And we turn the heat on with the Shift/H keys.

Share this post


Link to post
Share on other sites

×
×
  • Create New...