Jump to content

Archived

This topic is now archived and is closed to further replies.

Paul Deemer

Think I have tracked down the BRAKE BUG! :)

Recommended Posts

Won't be %100 sure until others can reproduce this. I been having the brake issue on a lot of my flights the past few days. It always starts at the gate. If I can get past the gate part I do not have any issues rest of the flight. Solution: Throw computer out the window and retire from FSX! LOL.gif Ok just kidding, ain't gonna happen! Big%20Grin.gif There have been a lot of different solutions suggested on how to clear the Brake Fail after it already happend. What I could not figure out is why it works for some and not others. Here is what I found out through 4 hours of nonstop testing today. If you have Random Failures set to Active and you get a brake fail. It is easy to use the Clear All option to make it go away. Because that was the way it was designed to work. However WHAT IF YOU DO NOT HAVE FAILURES ON? AHA! Something caused a Hard Brake Fail and there is no way to clear it other than rebooting your computer and starting a fresh flight. (Loading a saved flight will not work, cause then you will be right back where you started). So now all we gotta do is figure out what is causing some people to have a Hard Brake Fail ? I was able to reproduce this 4 times so I feel good that is the probable cause. Here is how you can reproduce it. Sitting at the gate, go through your normal flight procedures in powering up the aircraft. Then remove the Chocks and set the Parking Brake. Now with the Chocks off and the Parking Brake engaged if you have it enabled the Red FSX Parking Brake text will display steady on bottom left of your screen. If this text dissapears or will not stay steady when the Parking Brake is on your brakes are gone. As most of you know your joysticks can sometimes become uncalibrated during a flight. When you turn off the auto-pilot your plane goes nuts, mostly it is oversensitive and the slightest pressure on the controls can cause a Barrel Roll on Final. Believe me it has happend to me twice. Waiting.gif Because of this I make it a habit to calibrate my controllers at the Gate and at the Top of Descent. I know what your thinking and you would be correct. Calibration is causing the Hard Brake Fail. At least it is for me. I know most of you do your calibration in FSUIPC Registered. I have never done this before and was always doing it one of two ways. 1) Originally I was going to FSX Options, Settings, Controls and Calibrating from there, while it did not cause a crash at the Gate when calibrating it did cause FSX to Crash a few times at Top of Descent. So then I started doing option 2) Going back to Desktop, My Computer, Control Panel, Game Controllers and Calibrating it that way. This is what causing it. Why? I am guessing that with the aircraft powered up and going into calibration mode and moving your sticks and pedals back and forth it causes damage to the aircraft some how. (ie the Brakes which fail) If you go into the FMC you will see a Brake Failure is ACTIVE. Since this is a Hard Brake Fail and not a Genrated one you can't clear it. So what is the Solution? Yep, Calibrate your controllers with the Registered version of FSUIPC. Have not had any problems since I started doing it this way. Yeah I can hear a lot of moans and groans out there right now. Another thing to buy right? Well there are a host of features in the Registered FSUIPC and if you never considered getting it before well here is another good reason to buy it. If any of you can reproduce this let me know. Be sure to remove the Chocks First and then put the parking brake on because the Chocks keep the FSX Red Parking Brake Text on all the time when the Chocks are in place. Also The Aircraft should be powered up and ready for push n start.


Paul Deemer

Share this post


Link to post
Share on other sites

Interesting. The only brake "bug" I have ever has is when I fly from point A to point B and land the autobrakes work fine and disconnect fine after double tapping the brakes. BUT, when I fly from point B to the next airport, call it point C, and land the autobrakes usually disconnect by themselves as soon as the wheels hit the ground requiring me to reach over turn the knob to OFF, then back to whatever number I want to use, they will then begin to autobrake and will disconnect after a quick double tap on the brake. My issue is a mystery to me why they work on my first landing but 9 times out of 10 they disconnect by themselves on my second landing, and this is wil cool brakes and no warnings. Sean Campbell


Avsim Board of Directors | Avsim Forums Moderator

Share this post


Link to post
Share on other sites
BUT, when I fly from point B to the next airport, call it point C, and land the autobrakes usually disconnect by themselves as soon as the wheels hit the ground requiring me to reach over turn the knob to OFF
Is this a saved flight your loading when you Depart B to go to C? Or are you landing and going to the gate then setting up for a 2nd leg without ending the previous flight? If either of the above are true the best way is to do a new flight each time. Ie after end of the 1st leg, end flight and then start a new one using one of the default panel states and not a saved flight or saved panel state. Bet if you do it this way most issues will go away, including the autobrakes issue.I know its not ideal for some who want to have custom saved panel states. But if it solves your issues it is just a temporary fix. Until the PMDG Team can track down the bugs that are causing the problems.

Paul Deemer

Share this post


Link to post
Share on other sites
Is this a saved flight your loading when you Depart B to go to C? Or are you landing and going to the gate then setting up for a 2nd leg without ending the previous flight?
Nope, in fact in the 3 years i've been using FSX I have never saved any flight or for that matter saved any panel states. Nor do I have FSUIPC saving the flight in the back ground. I am landing, taxing, shutting down and getting ready for the next leg.
If either of the above are true the best way is to do a new flight each time. Ie after end of the 1st leg, end flight and then start a new one using one of the default panel states and not a saved flight or saved panel state. Bet if you do it this way most issues will go away, including the autobrakes issue.
I might try something like that. Maybe taxi in and shut down, but not exit FSX and just select "Short Turn" from the FMC option and see if that works. The funny thing is, is that I have flown multiple legs before and had the autobrakes operate correctly on the landings of all those flights without exiting or doing anything special, but it's just that 90% of the time I get the problem I described.I can live with it for now and I will try resetting to a new "short turn" set up between legs and see if that makes a difference, if not I will just reset the knob after is discos and resume autobraking if all else fails. I loath restarting the sim and ASE between legs though :-)Sean Campbell

Avsim Board of Directors | Avsim Forums Moderator

Share this post


Link to post
Share on other sites

Paul, this sounds like a hardware issue. Possibly a USB hub issue (loading?) causing intermittent connect/disconnect cycling. Have you tried duplicating this problem with another piece of hardware in another USB port to confirm that it is NOT an equipment failure? I would seriously doubt that this is an NGX issue otherwise this problem would be seen by many other. I do not recall exactly what the NGX intro said regarding what not to do with brake cal but if you do not use the third party cal software, do you have the same problems?


Cheers, Scott Ball

Share this post


Link to post
Share on other sites
Paul, this sounds like a hardware issue. Possibly a USB hub issue (loading?) causing intermittent connect/disconnect cycling. Have you tried duplicating this problem with another piece of hardware in another USB port to confirm that it is NOT an equipment failure?
I do not think there is a hardware issue and my controllers are plugged into the USB 2.0 ports directly connected to my motherboard. The whole point here is that I am not the only one having this problem, many others are. The point of all this was to track down what is causing it. I believe if you go outside of FSX and calibrate from Windows that it causes an issue with the NGX and causes a brake failure to occur. If I calibrate in FSUIPC no isses at all anymore. Was posting this to warn other folks that if they have a hard brake fail it could be that they were doing the same as me and calibrating outside FSX. What I believe is happening is. When you Calibrate with Windows the NGX is still running and moving the sticks and pedals around radically while calibrating causes damage to the plane. When calibrating from FSUIPC FSX probably pauses while your in there messing around and thats why it doesnt cause the brake problem. Should be easy for the PMDG Team to verify this now that they know what to look for.

Paul Deemer

Share this post


Link to post
Share on other sites
I do not think there is a hardware issue and my controllers are plugged into the USB 2.0 ports directly connected to my motherboard. The whole point here is that I am not the only one having this problem, many others are. The point of all this was to track down what is causing it. I believe if you go outside of FSX and calibrate from Windows that it causes an issue with the NGX and causes a brake failure to occur. If I calibrate in FSUIPC no isses at all anymore. Was posting this to warn other folks that if they have a hard brake fail it could be that they were doing the same as me and calibrating outside FSX.
OK, I understand. What type of pedals are you using?

Cheers, Scott Ball

Share this post


Link to post
Share on other sites
What type of pedals are you using?
I use the Saitek X52 Pro and Saitek Pedals.

Paul Deemer

Share this post


Link to post
Share on other sites
OK, I understand. What type of pedals are you using?
I too having brake trouble but using only a Thrustmaster Hotas Joystick for flight controller. No 'pedals' at all and no brakes either.

 R. Scott McDonald  B738/L   Information is anecdotal only-without guarantee & user assumes all risks of use thereof.                                               

RQbrZCm.jpg

KqRTzMZ.jpg

Click Here for my YouTube channel 

 

Share this post


Link to post
Share on other sites

Hi guys i'm Emil Nilsson.I have a problem with my brakes that seems to not have accured for you guys. It works fine from gate to Approach. I uselly set my autobrake at top of descent or on approach. My most normal setting for the autobrake is 1, sometimes 2. Let's say I just touched down at Gatwick and i'm applying the reversers, spoilers and then checking the brakes. This is what a normal landing procedure for me looks like:"spoilers checked, reverse and brakes checked, 8 0 knots, reverse disengaged, 60 knots manual breaking. This is when the problem accures. Im pushing my pedals down towards the ground but nothing is happening. I now only have the spoilers to brake with (and the flaps of course). The treshhold is getting closer and closer. I engage the reversers again but its not powerful enough. I go into the "Meny bar, aircraft and than failures". Then to the system category and scroll down. What I see is that the left and right brake is failed. I "unbox" them and press "reset failures" to be sure. This should not be happening sense i have no failures pre-selected or any random failures! Now if I push on the pedals again the brakes work. This problem is only accuring in the NGX, just sense the last time i re-installed FSX. The problem has accured in the last 7-8 flights in the NGX. :sad:My flight control system i use is the "Logitech G940" (Awesome :( ). It has never had a single problem and is perfectly calibrated.


pmdgngxpilot.jpg

Share this post


Link to post
Share on other sites
Hi guys i'm Emil Nilsson.I have a problem with my brakes that seems to not have accured for you guys. It works fine from gate to Approach. I uselly set my autobrake at top of descent or on approach. My most normal setting for the autobrake is 1, sometimes 2. Let's say I just touched down at Gatwick and i'm applying the reversers, spoilers and then checking the brakes. This is what a normal landing procedure for me looks like:"spoilers checked, reverse and brakes checked, 8 0 knots, reverse disengaged, 60 knots manual breaking. This is when the problem accures. Im pushing my pedals down towards the ground but nothing is happening. I now only have the spoilers to brake with (and the flaps of course). The treshhold is getting closer and closer. I engage the reversers again but its not powerful enough. I go into the "Meny bar, aircraft and than failures". Then to the system category and scroll down. What I see is that the left and right brake is failed. I "unbox" them and press "reset failures" to be sure. This should not be happening sense i have no failures pre-selected or any random failures! Now if I push on the pedals again the brakes work. This problem is only accuring in the NGX, just sense the last time i re-installed FSX. The problem has accured in the last 7-8 flights in the NGX. :sad:My flight control system i use is the "Logitech G940" (Awesome :( ). It has never had a single problem and is perfectly calibrated.
I too had this problem, which was caused by improperly calibrated brake controls. If you are using footbrakes on a rudder pedal unit, this can occur, especially with SAITEK rudder pedals. They must be configured either in FSX or FSUIPC to work "backwards". What is happening to you is whilst taxing on the ground, your brakes are locked on and only release when you push down on them. Thus you are 'burning them up' whilst taxiing. By the time you get airborne they are gone. When you land, they don't work.So to relieve the problem go to wherever you calibrate the brakes within FSX and put a checkmark in the reverse operation box in FSX (probably the most likely spot for you to solve this) or if you calibrate within FSUIPC, there is a checkbox on the brake calbration tab you can tick.Finally, be sure you have a small deadzone at both the top and bottom of the brake calibration zones. This will prevent them locking up at either end when operating the brakes. If you are not using foot brakes but are using a button on your logitech controller, I am afraid this suggestion won't help you.HTH.

 R. Scott McDonald  B738/L   Information is anecdotal only-without guarantee & user assumes all risks of use thereof.                                               

RQbrZCm.jpg

KqRTzMZ.jpg

Click Here for my YouTube channel 

 

Share this post


Link to post
Share on other sites

×
×
  • Create New...