Jump to content

Archived

This topic is now archived and is closed to further replies.

colfmedion

Very unstable FSX

Recommended Posts

Hi,Here's the thing:For many months now, whenever I fly and at the end of the flight I then want to change the aircraft or location the aircraft splash screen goes black and clicking on fly now results in a full black screen. It is as if it is struggling to load but no matter how long I wait nothing happens. I try using Escape and Task Manager to get me to a point where I can continue using FSX but I always end up having to totally restart FSX. Over the months I have done complete new installs of FSX and tried it on a different HD but all with the same result. I have totally rebuilt the PC during this time with no change.System specs are:Windows 7 64 BIT installed on its own SSDIE912287mb RAMCPU i7 950 at 3.07 ghzATI Radeon HD 5800Kingston SSD exclusively for FSXMobo is Gigabyte X58A-UD3RAlso installed with FSX is the Acceleration pack and Traffix X. During many of my reinstallations I have run FSX without any Add Ons but the result is still the same.As far as I can tell from various testing utilities and benchmarking, there is no indication of anyting untoward with any of the Hardware.Would appreciate any advice to try and resolve this.Many ThanksColf

Share this post


Link to post
Share on other sites
Guest firehawk44

I could find no 'magic bullet' solution to your problem. I have seen others who have had a similar problem but no solutions. Based on what I have read about others having your problem, it could be-- your sliders are too high (you cannot fly w/o issues with sliders too high no matter what massive high level computer system you are using). Turn down your scenery sliders to the default and turn off AI or return them to the default settings and see if that fixes your problem. If not, return your sliders to where they were at. -- make sure you have highmemfix=1 in the Graphics section of your FSX.cfg. If it's there, remove it as it doesn't work for everyone and this could be causing the problem.-- is your system overclocked? If so, return it to the default or lower the overclocking and see if this fixes the problem. Make sure voltages and frequency settings in your BIOS are correct. you can get the correct frequency/voltages running CPU-Z and looking under the memory tabs. Testing utilities and benchmarking utilities will not find all stability issues with your memory modules. Incorrect frequencies/voltages will likely indicate your system is stable and your system will run great for a while, then anomalies will start happening. The fact that you have rebuilt your PC and done complete new reinstalls of FSX on various HD's indicates to me your FSX or BIOS settings are incorrect. -- make sure you have the latest version and all security updates to Microsoft .net programs as one of the things dotnet does is manage memory for your programs. Also make sure you have all of the Microsoft Visuals (MSV's) C++ Redistributables from 2005 to 2010 installed (they are not backward compatible or all-inclusive so you need all of them installed).-- what are the settings for your virtual memory (page file). It's possible you have incorrect settings if you set the minimum and maximum settings. I have found that 'system managed size' works the best.-- lower the settings in your display drivers if they are set too high. Perhaps you video card cannot handle the high settings. Make sure the drivers are up-to-date.-- lastly, are there any errors relating to FSX or your system in the Event Viewer around the times you have the blackout problems? The Event Viewer can possibly give you some clues as to what's wrong if an event was generated.Hope one of these suggestions helps!Best regards,Jim

Share this post


Link to post
Share on other sites

I too have had a strange black screen problem. If i go to save a flight or into another menu the screen goes black, i can still hear the sim working just cant get the graphics to show up again ? I have a new G card which is a nice upgrade on what i had. So at the moment I am just having to make sure i dont hit save flight insted of arm spoilers, which i always do lol.Andy

Share this post


Link to post
Share on other sites
Guest firehawk44

PJ,The uiautomationcore.dll is part of the Microsoft dotnet program so I think making sure dotnet is up-to-date is all that is necessary. Changing the uiautomationcore.dll works for some but not for all. For instance, I have a very similar system as others and have never had to change the uiautomationcore.dll. I do, however, keep my system up-to-date with the latest drivers.Best regards,Jim

Share this post


Link to post
Share on other sites

If it works for some - and if they haven't tried it, don't you think they should?I have exactly the same board as you, Jim - except for the newer 2103 BIOS, and it for sure cured my (mostly Maddog/long flights/multiple keypresses) freezes and black screens. I tested this numerous times and has always worked.

Share this post


Link to post
Share on other sites
Guest firehawk44
If it works for some - and if they haven't tried it, don't you think they should?
Totally agree! I haven't installed the 2103 BIOS yet but have downloaded it and will as soon as I make a copy of all the screens so I can bring back my settings. It's a shame every update wipes out any saved settings.Best regards,Jim

Share this post


Link to post
Share on other sites

Darned right, Jim: the 2600K o/c was so easy - I didn't writte them down in the way that I did with the 950, and besides - no BSoD's, so it was back to square one! Surprise!!

Share this post


Link to post
Share on other sites

Hi,Thanks for responses.Went through Jim's list and not find anything untoward. Tried default settings for Display and this appeared to cure problem but I couldn't live with the terrible quality. I have tried various settings and sometimes everything is fine and sometimes it is not. Sometimes if I change an aircraft and/or location and I am viewing FSX on a smaller screen, the display just flashes away but the desktop is perfectly stable. I will keep trying various settings.Cannot find Preload=0 in my fsx.cfg.And what is UIAuomationCore.dll and how do I change it?I have all the MS Visuals from 2005 to 2010 and all are up to date.Colf

Share this post


Link to post
Share on other sites

It's "DisablePreload=1", Colf, and it should be under the [Main] section.UIAutomationCore.dll is an API (Application Programming Interface) and "talks" between the operating system and an application: in this case between Windows 7 - 64 and FSX. Unfortunately, at the time Windows 7 came out - FSX was "End of Life" and so this API was not tested with FSX - and it does cause a number of issues - certainly freezing and black screens. Most times it will happen after too many keypresses. The answer to this is to use the Vista version, which does work - and place it into the root folder of FSXYou can get that version here:- http://dl.dropbox.co...in_fsx_root.dllDownload it, and rename it as "UIAtomationCore.dll" You can Rt-Click on it, and check the "Properties"The version number should be 6.0.5840.16386. This is the Vista 32-bit version, and works well with FSX.Place it into the root folder of FSX. DON'T put it anywhere else. OK? :(

Share this post


Link to post
Share on other sites

Hi,Loaded UIAutomationCore.dll as per your instructions but it does not appear to have made any difference.Also, I definitely do not have "DisablePreload=1" in my fsx.cfg [Main] section or anywhere else in the cfg. Will this affect anything?However, I thought I would try something else; the Direct X 10 Preview. I have tried this before, ages ago and it seemed to cause a lot of problems. Anyhow, I ticked the box and lo and behold, it seems to have cured most of the problems. I am now able to switch aircraft and locations with no problems whatsoever, touched wood. However, it does appear to have generated one particular problem. I have a B757 Continental Airlines which I use more than any other aircraft. I loaded it and flew it for a while before I switched to another aircraft. That went fine and then I switched back to the 757 and what I got was an aircraft with no textures whatsoever. I have rebooted FSX and reinstalled the aircraft and so far it has made no difference. Very strange. Perhaps after a nights rest it will appear as normal tomorrow!!Colf

Share this post


Link to post
Share on other sites
Guest firehawk44

Aircraft made for FS9 and earlier versions will not appear unless they have been upgraded to FSX when using DX10 Preview.Best regards,Jim

Share this post


Link to post
Share on other sites

whenever i get the black screen problem a quick ctrl-alt-delete and then cancel fixes it! a tip i picked up on this forum some time ago.i only see it happen occaisionally, i think it's a bug related to FSX not playing nice with the display device under windows7, as it often happens when i'm alt-tabbing and such. using windowed mode rather than fullscreen helps reduce the issue a lot as well.cheers-andy crosby

Share this post


Link to post
Share on other sites
Guest firehawk44
i think it's a bug related to FSX not playing nice with the display device under windows7
If it's bug related, then everyone who owns Windows 7 would have this problem. Most don't, including me. Again, update dotnet4 and install the MSV's from 2005 to 2010. Then, lower some of your fsx sliders until the problem goes away. Oh! Just a thought.... defrag your HD everytime you install an addon, fsx, and Acceleration. Windows throws files all over the HD in total disarray and in an incomprehensible manner.Best regards,Jim

Share this post


Link to post
Share on other sites

Hi,Activating DX10 Preview has cured the problem for me. Have lost several aircraft which were FS9 aircraft but no big deal. Have been flying for the last couple of days and doing lots of changing aircraft and locations and not problems.FSX is installed on a SSD.Thanks for all assistance.Colf

Share this post


Link to post
Share on other sites
If it's bug related, then everyone who owns Windows 7 would have this problem. Most don't, including me.
maybe, maybe not. never saw the issue with winXP. and p3d last version was basically full of basic fixes to make the app win7 compliant. but hey, whatever workscheers-andy crosby

Share this post


Link to post
Share on other sites

×
×
  • Create New...