Jump to content

Archived

This topic is now archived and is closed to further replies.

Alan_A

Stutters in DX10 - workarounds?

Recommended Posts

Have spent the past couple of days experimenting with the DX10 shader fix. I'm really impressed - textures seem much improved, framerates are better in at least some settings, there's an increase in smoothness, and the VC shadows alone are worth the price of admission.

 

The only thing holding me back from a full commitment to DX10 are the stutters, both micro and macro (sometimes a half-second to a second, and one instance two seconds, often but not always on airport grounds). I never had microstutter problems running DX9 except when using EZDok in some ORBX sceneries (the cure was to retire EZDok). So I'm not familiar with the workarounds. A question for those of you who are dealing with stutters in DX10 - what settings are you changing, and what values are you using? I'm happy to continue tweaking but could use some guidance about what to tweak.

 

My specs are listed in my profile. I'm running DX10 with settings pretty much as recommended in Steve's guide, except light bloom on, autogen at Very Dense, scenery density at Extremely Dense, and Aircraft Casts Shadows on Itself. I've tried adjusting autogen and scenery density settings, and turning off light bloom, with no effect.

 

Thanks in advance for whatever suggestions you have.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

Hi Alan. Y'know - you are the only other person besides myself that had those AZCA-caused stutters in FSX! Every 2 or three seconds It had a "lurch", and, like you did - removing EZCA cured it! I have used it since, and am not able to recreate the problem, but with A2A's AccuFeel - I don't load EZCA any more. Now waiting for V2 to come out.

 

Your problem - would you post the important parts of your cfg here, please (taking out the rubbish stuff - like Trusted, Sound, Panels, Controls, TextInfo, DynamicHeadMovement, ATC, Acontain) I have a suspicion of the cause, but I'd like to see just what else there is that might be a contributor - OK?

 

Thanks,

Share this post


Link to post

Paul - thanks for the offer of help - and apologies for my mis-crediting your guidebook to Steve. Steve's solution, your instructions - I think I've got it now, though it's a lot for a newcomer to absorb. I'm grateful to both of you.

 

Here are the relevant (I hope) excerpts from my FSX.cfg. A note about Bufferpools - as you'll see, I've tried several different settings, but the changes (including commenting out the whole section) didn't seem to make a difference. In my last test they were commented out and they stay that way here.

 

I've read some old commentary to the effect that high TEXTURE_BANDWIDTH_MULT settings can cause stutters (I used 70 in DX9 and recently dropped them to 40 with no ill effects; running them higher here, obviously). I don't know if they're at issue or not.

 

Let me know if anything jumps out at you.

 

 

[GRAPHICS]

HIGHMEMFIX=1

SHADER_CACHE_PRIMED_10=1693500672

SHADER_CACHE_PRIMED=1693500672

TEXTURE_MAX_LOAD=1024

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=1

AIRCRAFT_REFLECTIONS=1

//ALLOW_SHADER_30=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=1

AC_SELF_SHADOW=1

EFFECTS_QUALITY=2

GROUND_SHADOWS=0

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

MultiSamplesPerPixel=8

D3D10=1

Stale_Buffer_Threshold=30

[JOBSCHEDULER]

AffinityMask=14

//[bufferPools]

//Usepools=0

//PoolSize=8388608

//RejectThreshold=131072

//RejectThreshold=524288

 

[snip]

 

[display]

 

[snip]

 

 

BLOOM_EFFECTS=1

SKINNED_ANIMATIONS=1

TEXTURE_BANDWIDTH_MULT=120

TextureMaxLoad=6

UPPER_FRAMERATE_LIMIT=30

WideViewAspect=True

RUNWAY_LIGHTS_SURFACE_SCALAR=1 //1.2

RUNWAY_LIGHTS_VASI_SCALAR=1

RUNWAY_LIGHTS_APPROACH_SCALAR=1 //1.2

RUNWAY_LIGHTS_STROBE_SCALAR=1

 

[Main]

User Objects=Airplane, Helicopter

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

SimObjectPaths.6=MyTraffic\Aircraft

SimObjectPaths.7=Orbx\FTX_AU\FTXAI_Aircraft

ProcSpeed=15570

PerfBucket=7

HideMenuNormal=0

HideMenuFullscreen=1

DisablePreload=1

Maximized=1

Location=440,211,1480,989,\\.\DISPLAY1

Fiber_Frame_Time_Fraction=0.22

 

[snip]

 

 

[Weather]

 

[snip]

 

CLOUD_COVERAGE_DENSITY=8

CLOUD_DRAW_DISTANCE=3

DETAILED_CLOUDS=1

DisableTurbulence=0

DownloadWindsAloft=1

DynamicWeather=2

MaxGustRampSpeed=200

MaxGustTime=500

MaxVarRampSpeed=75

MaxVarTime=50

MinGustRampSpeed=1

MinGustTime=10

MinVarRampSpeed=10

MinVarTime=5

THERMAL_VISUALS=0

TurbulenceScale=1.000000

 

 

[snip]

 

 

WindshieldPrecipitationEffects=1

THERMAL_VISUALS=0

 

[DISPLAY.Device.NVIDIA GeForce GTX 580.0]

Mode=1920x1200x32

Anisotropic=1

AntiAlias=1

 

[snip]

 

 

[sCENERY]

LENSFLARE=1

DAWN_DUSK_SMOOTHING=1

IMAGE_COMPLEXITY=5

[TrafficManager]

AirlineDensity=30

GADensity=30

FreewayDensity=12

ShipsAndFerriesDensity=30

LeisureBoatsDensity=30

IFROnly=0

AIRPORT_SCENERY_DENSITY=4

[TERRAIN]

LOD_RADIUS=4.500000

MESH_COMPLEXITY=75

MESH_RESOLUTION=24

TEXTURE_RESOLUTION=25

AUTOGEN_DENSITY=4

DETAIL_TEXTURE=1

WATER_EFFECTS=4

 

 

I notice I have two entries for display device - not sure if there's an issue there or not.

 

Final note for this round - I'm running Forceware 301.42 with Inspector settings recommended by Mike (some1) Krawcyzk - 8x SGSS plus FXAA. Had bad gauge shimmering on other settings.

 

Thanks again, and let me know what you think.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

I think I've got it now, though it's a lot for a newcomer to absorb.

 

...Hey Alan! We're all newcomers here!

 

I've bolded what I think can be changed, and they will lighten the load some, but remember - these are "preferences", and we can do with some and we can do without some, and some we'll have to do without - just like DX9. These ought to give you smoothness, but smoothness doesn't only depend upon these settings - they also will depend upon what else the proc is doing. Is the search engine running? Is the Acronis Scheduler running? Is the Bonjour service running? Shut down as many external - unnecessary services as you possibly can. FSX also keeps track of every scenery file that's in the scenery config. You don't have to have the whole world ticked (in the World-->Scenery Library), so untick Africa, USA, New Zealand - if you don't fly there - don't select it.

Easy to do with SceneryConfigEditor and the map:

 

https://dl.dropbox.c...aller-1.1.0.exe

https://dl.dropbox.c...ring Schema.xps

 

Lastly - less complicated is better with Inspector. It's worth playing with, but keep it simple to begin with.

 

[GRAPHICS]

HIGHMEMFIX=1

SHADER_CACHE_PRIMED_10=1693500672

SHADER_CACHE_PRIMED=1693500672

TEXTURE_MAX_LOAD=1024

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=0

AIRCRAFT_REFLECTIONS=0

//ALLOW_SHADER_30=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=1

AC_SELF_SHADOW=0

EFFECTS_QUALITY=2

GROUND_SHADOWS=0

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

MultiSamplesPerPixel=8

D3D10=1

Stale_Buffer_Threshold=30

 

[JOBSCHEDULER]

AffinityMask=14

 

//[bufferPools]

//Usepools=0

//PoolSize=8388608

//RejectThreshold=131072

//RejectThreshold=524288

 

 

[bufferPools] <--- keep trying. When correct it makes a huge difference

UsePools=1

PoolSize=12582912

RejectThreshold=1048576

 

[Display]

 

UPPER_FRAMERATE_LIMIT=30

BLOOM_EFFECTS=0 <----- Just for now

SKINNED_ANIMATIONS=1

TEXTURE_BANDWIDTH_MULT=120

TextureMaxLoad=6

UPPER_FRAMERATE_LIMIT=30

WideViewAspect=True

RUNWAY_LIGHTS_SURFACE_SCALAR=1 //1.2

RUNWAY_LIGHTS_VASI_SCALAR=1

RUNWAY_LIGHTS_APPROACH_SCALAR=1 //1.2

RUNWAY_LIGHTS_STROBE_SCALAR=1

 

[Main]

User Objects=Airplane, Helicopter

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

SimObjectPaths.6=MyTraffic\Aircraft

SimObjectPaths.7=Orbx\FTX_AU\FTXAI_Aircraft

ProcSpeed=15570

PerfBucket=7

HideMenuNormal=0

HideMenuFullscreen=1

DisablePreload=1

Maximized=1

Location=440,211,1480,989,\\.\DISPLAY1

Fiber_Frame_Time_Fraction=0.12 <---- Low and Slow, bump to 18 if low and fast 0.22 is kinda high

 

FIBER_FRAME_TIME_FRACTION=0.1 <----- Mine, it makes FSX smooooother - I've been as low as 0.8.

I don't know why mine is all upper case... maybe it has to be, as is often the case with a defined parameter name.

 

[Weather]

CLOUD_COVERAGE_DENSITY=8

CLOUD_DRAW_DISTANCE=3

DETAILED_CLOUDS=1

DisableTurbulence=0

DownloadWindsAloft=1

DynamicWeather=2

MaxGustRampSpeed=200

MaxGustTime=500

MaxVarRampSpeed=75

MaxVarTime=50

MinGustRampSpeed=1

MinGustTime=10

MinVarRampSpeed=10

MinVarTime=5

THERMAL_VISUALS=0

TurbulenceScale=1.000000

[snip]

WindshieldPrecipitationEffects=1

THERMAL_VISUALS=0

 

[DISPLAY.Device.NVIDIA GeForce GTX 580.0] The GPU has two ports, and sometimes both will appear here if ...........................................................................you've used both. 2nd = GTX 580.0.0

Mode=1920x1200x32

Anisotropic=1

AntiAlias=1

 

[snip]

 

[sCENERY]

LENSFLARE=0

DAWN_DUSK_SMOOTHING=1

IMAGE_COMPLEXITY=4

 

[TrafficManager]

AirlineDensity=25 <---- vary these two AI & GA, dependent upon where you're flying.

GADensity=25

FreewayDensity=12 <---- I like to see cars, too.

ShipsAndFerriesDensity=0 <-----For now, but 8 tops

LeisureBoatsDensity=0 <-----For now but 8 tops

IFROnly=0

AIRPORT_SCENERY_DENSITY=0 <-----For now

 

[TERRAIN]

LOD_RADIUS=4.500000

MESH_COMPLEXITY=100 <--- S/B ok

MESH_RESOLUTION=23 <--- S/B ok

TEXTURE_RESOLUTION=28 <--- S/B ok

AUTOGEN_DENSITY=4 < maybe 3 while testing, but 4 is best

DETAIL_TEXTURE=1

WATER_EFFECTS=4

 

I'm running Forceware 301.42 [Latest is 304.48] with Inspector settings recommended by Mike (some1) Krawcyzk - 8x SGSS plus FXAA. Had bad gauge shimmering on other settings. <--- what about with just the original AA & AF set within the Sim, with Inspector set to App controlled?

 

Well that's about all I can add, Alan. I would not use more than those figures while looking for the sweet spot. Airport traffic is a heavy burden over 1/4, FFTF at .1 or .12 will make a big difference.

 

I hope this all helps - try it and let us know how you make out.

 

All the best,

Share this post


Link to post

Thanks much, Paul - I'm going to go now and test-drive these settings, and I'll report back.

 

About additional processes - I run pretty lean. My Window 7 and FSX are set up according to Nick Needham's guidelines, and he doesn't leave a lot of fat in the system. But I'll double-check and see if anything has crept back in.

 

About Inspector settings - for some reason, across several different NVidia cards, I've always had to push anti-aliasing higher than recommended settings to get rid of shimmers. I don't know why. But I'm not surprised to have to go to 8xSGSS and FXAA. Again, on lower settings I had severe shimmers, including unreadable gauges, and had stutters as well. So I'll probably look elsewhere for the performance issues. But you never know...

 

Again, I'll load these up and then let you know how it goes.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

No joy, I'm afraid. Still getting microstutters with these settings.

 

I'm not sure if this is a clue or not, but switching aircraft seems to make a slight difference. I'm flying mainly helos these days, and in tonight's tests (with everything else held constant), I had the worst stutters with the Nemeth AS350, did somewhat better with the Dodosim 206, and best of all with the default 206. So I'm wondering if there's some sort of interaction between aircraft (gauges?) and scenery. Or maybe it's just a texture-handling problem (aircraft textures plus scenery textures). Or maybe that's a red herring - sample size is admittedly small.

 

I'm open to suggestion.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

And just a couple more updates - tried varying the AA settings in Inspector, no effect. Tried updating to 306.02, no effect. Still microstuttering. Still open to what others think.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

Hello,

 

I have the same problem as Alan.

 

I tried to tweak anything without a success.

 

What I relise is that the problem is something connected with the photo scenery (in my case). When there is a "simple" orbx pnw area, everything is fluent. But when I sit in an airport where there are lot of photo scenery, it began to stutter awfully. (eg. Skagit, or W16 Monroe).

 

And this happen not only in the orbx areas. I tried with other scenery, that is only photo scenery, and the same issue is happen.

 

Thanks any hint,

 

Zoli

Share this post


Link to post

Hello,

 

No, I overclocked to 4.0 Ghz. First I tried 4.4 Ghz, but I lower it, because It give me about 40 fps still.

 

Zoli

Share this post


Link to post

And just a couple more updates - tried varying the AA settings in Inspector, no effect. Tried updating to 306.02, no effect. Still microstuttering. Still open to what others think.

 

As I have reported in other posts, the Texture_Bandwidth_Mult setting can cause stuttering. A lot of people put it up as high as 400 (which was the optimum setting in FS9). But, NickN in his guide on Setting up FSX and tuning it, recommends a setting somewhere in between 40 and 80 and anything over 120 will create issues. If you have yours set too high, this could be the problem.

 

Best regards,

Jim


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

Thanks, Jim. I was suspicious about the high Texture_Bandwidth_Mult setting and tried reducing it to 40, but still had the stutters. Then I reverted to DX9 and interestingly, the stutters were still there. That makes me suspect there may be an issue in the NVidia Inspector settings. I'll look at those next.



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

I don't know why I missed it, Alan - (not necessarily a fix) but a 4 - 4.5 gig proc should be able to feed a 580 so well that you can use BufferPools = 0. You should not need shared pool or an RT.

You might also try a TBM of 102.

 

Keep us in formed.. Thanks,

 

pj

Share this post


Link to post

Good thought, Paul, but I've already tried both with and without UsePools=0. Had no effect on the stutters. The fact that I'm getting them in DX9 as well as DX10 makes me think it's either an Inspector issue or a driver issue. My next moves will be to alter the Inspector settings, then if necessary revert to older drivers, and see what happens. Will advise...



Alan Ampolsk

"Ah, Paula, they are firing at me!"
-- Saint-Exupery

Share this post


Link to post

OK - try the next "fix"... We're "stretching it" a bit, but others have reported this as a fix, and I personally run it too, as it's logical, and I had stutters on numerous occasions throughout the last fifteen years.. This one is to do with Core parking. I don't know how much you've read, but when a processor core has nothing to do, it idles itself down , and then has to ramp up again when needed. This does cause micro-stutters, and there's a possibility it may be an issue with your pc. SO.... here's the "how-to" on that. Taken from a post - which I regret - I didn't note: I've tested this on three or four Windows 64-bit with different multi-core procs, and it works just fine.

 

Open regedit, and do a search for this line; -

 

0cc5b647-c1df-4637-891a-dec35c318583

 

Within this key, there is a value called: " ValueMax " This value represents the % number of cores the system will park - the default 100% ie: all Cores are potentially park-able.

 

- Change the value from 64 to 0 so the " ValueMin " and " ValueMax " are both zero.

 

- You will have to find the key a few times and repeat the process for each time it is found - the number of instances will depend on the number of power profiles in your system.

Do a full shutdown and power-off, and then cold-re-start.

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,660.00 of $25,000.00 Donate Now
×
×
  • Create New...