Archived

This topic is now archived and is closed to further replies.

iainsmith

RC4 not working

Recommended Posts

Today in FSX, as well has having a problem not being able to zoom views in or out, for which I have posted for assistance in the FSX forum, RC4 is also not working.

 

I create a flight plan using FSBuild, which saves a pln version in FSX. After firing up RC I load the plan in the usual way and then start RC. It appears to start except that I don't get the menu window and even pressing the two possible keys I usually press to get clearance results in nothing happening. If I look at Task Manager that tells me that Radar Contact is running.

 

I have deleted and re-created an FSX cfg file but that has done nothing.

 

Whether these two problems are somehow connected I do not know - in fact I'm stumped. Can anyone suggest anything I can try please?

 

Thanks

 

Iain Smith

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can't explain your RC issue even though it happens to me, now and then. Easy 'fix' is to shut down and restart FSX - that's all that's required on my system.

 

Maybe some sort of initialization/connection issue ...

Share this post


Link to post
Share on other sites

Make sure your fsuipc4 is current from:

http://forum.simflight.com/topic/66139-updated-modules/

Make sure you have set up a shortcut to rcv4.exe and set its properties to run as admin. Be sure RC is allowed through all of your security applications.

 

Have you updated makerwys.exe from:

http://forum.simflight.com/topic/66136-useful-additional-programs/

and rerun the RC scenery database utility followed by restarting RC/

 

I also would check that you set your shortcut to FSX properties to run as admin.

 

Note that this shortcut property is a program level access, not a user level access. It allows a high level of inter application communication with Windows (called Windows messaging).

 

If you alt-tab when these problems occur, do any error messages show that might have been covered by existing windows? Are you running RCv4 4.3845?

 

When you installed RC did you right click on the installer .exe and select run as admin?

 

Win 7 and now 8 are mostly vulnerable to these extended security protection requiring the setting of these shortcuts to run as admin.

 

I should have asked first, though is this a new problem? Did you have a Win or video driver update?

 

Run your tests with first just FSX running and check and then FSX and RC to see if ram resources are a problem.

 

It would help to add your hardware and software applications to your profile here as in my avatar/tag so we can click and look at your apps and hardware configuration.

Share this post


Link to post
Share on other sites

 

 


Easy 'fix' is to shut down and restart FSX - that's all that's required on my system.

 

Thanks for your response Oliver. Unfortunately your fix doesn't work for me. Shutting down and re-starting FSX makes no difference neither does shutting down and re-starting the computer.

 

Iain

Share this post


Link to post
Share on other sites

Ian,

 

Lets see if a plan created in FSX will work. Position your aircraft at EGBB (Birmingham) and create a plan for a flight to Manchester (EGCC). Include a single waypoint of TNT. Cruise level will be FL140. Use the default B737.

 

That should work. If it doesn't come back and give us as much info as you can. You don't say if you're running any 3rd party addons so just for now please just run FSX and RC4.

 

If it does work then switch to your usual aircraft and try it. Only change one thing at a time until it doesn't work and we should be able to get to the bottom of the problem.

Share this post


Link to post
Share on other sites

Thanks Ron and Ray for your responses. I updated FSUIPC from 4.9 to 4.905 but that did nothing. I then clicked on the RC4 icon to run as admin and all was well!

 

Regarding setting the properties for this to happen every time, I cannot make the change stick. This is Win 7 64 bit and I can right click on the icon, select properties and then highlight Administrator in the list that comes up and ok it but it doesn't stay that way. I pressed the Edit button but that was asking me to name the object, which I didn't understand. Presumably there is a way to make this change permanent?

 

Iain

Share this post


Link to post
Share on other sites

Iain,

 

I don't have W7 but I understand there are restrictions on programs installed under C:\Program Files.

 

If that's where you have RC4 installed it may be best to uninstall it and load into C:\RC43 instead. Others with W7 may be able to comment on this.

Share this post


Link to post
Share on other sites

Both RC and FS would have to be out of any program files hierarchy to communicate without requiring the program level admin privileges. This applies to other apps interacting with FS as well.

 

I have a laptop with Win 7-64 HP on it for other uses and I'll test setting the shortcut properties making it stick. It could be you might have to have user admin privileges to set this.

Share this post


Link to post
Share on other sites

Speaking without W7 knowledge but is it possible to create a shortcut to RC4 and FSX with admin privileges set in that?

 

Seems such an obvious requirement or do Microsoft really suppress anything so fundamental?

Share this post


Link to post
Share on other sites

<p>You can create shortcuts on your W7 desktop, for example ...</p>

<p>.. right click on the icon, choose 'properties' ...</p>

<p>... select the 'compatibility' tab, click 'all users' ...</p>

<p>... enable 'run as admin', ENTER, ENTER - done!</p>

<p> </p>

<p> </p>

<p> </p>

<p>EDIT: That's what Ron meant when he said 'sticky'.</p>

<p> </p>

<p>I have all my FSX (addons) outside the protected folder PLUS set ALL exe's to 'run as admin'.</p>

<p> </p>

<p>Again, I don't quite understand why the OP's issue hasn't happened before ...</p>

Share this post


Link to post
Share on other sites

It was a little bit different to set the run as admin property permanently on my laptop W7-64. Now, I do have a user account in the Admin group with full control. Here is the procedure I used and tested.

 

Right click on the shortcut and click properties. (Ignore the run as admin here - that's the temporary version.) Click the Advanced button. In the dialog that pops up click the box to check Run As Admin and then click the OK button. The dialog closes and then click Apply in the remaining property window, then OK to close the property window.

Share this post


Link to post
Share on other sites

Ron and Ray, so sorry - I thought that this problem had been solved but now I can't think what I did differently that made it work briefly. Thereafter it has been misbehaving again.

 

Anyway, this is the result of my latest round of tests doing what Ray suggested - FSX and RC4 v 4.3.3845 only with an FSX generated flight plan - Coventry EGBE to Edinburgh EGPH @ FL260.

 

With FSX already running I fired up RC the "admin" way loaded the plan and pressed the Start RC button. Immediately my aircraft is now across the airfield away from the gate and across the runway. (I forgot to mention that it was doing this before - probably key to the problem!). To get back to where I was I re-select the airport and gate and we're back but no RC window and no key response.

 

My PC specs are:-

 

Asus P8Z77 mobo with Intel i7/3770k @ 4,4GHz with an Arctic 13 air cooler, 4GB of DDR3 RAM and a Geforce GTX 550Ti 1GB video card. This has been running and stable for 8 weeks with CPU temps well within acceptable limits.

 

While writing this I've seen what you have been saying about where RC4 is installed and I see that it is indeed in C:|Programme files (x86) folder. FSX is on a separate drive. Are you saying I should move RC even if I do what Oliver has suggested above?

 

Grateful for your time and help guys!

 

Iain

Share this post


Link to post
Share on other sites

With FSX already running I fired up RC the "admin" way loaded the plan and pressed the Start RC button. Immediately my aircraft is now across the airfield away from the gate and across the runway. (I forgot to mention that it was doing this before - probably key to the problem!). To get back to where I was I re-select the airport and gate and we're back but no RC window and no key response.

Iain,

 

When that happens it suggests RC doesn't think your aircraft is at the correct place and attempts to move it to the right place. You didn't answer Ronzie's question on whether you have run MakeRunways (4.65 is current). You can get it here. http://fsuipc.simflight.com/beta/MakeRwys.zip

 

Run it and try again. Make sure your aircraft is at a gate at Coventry before you start RC4.

 

Don't worry about moving RC4 out of Program Files. We can worry about that later.

Share this post


Link to post
Share on other sites