Archived

This topic is now archived and is closed to further replies.

MDF86

Trouble with Cloud Flicker - VIDEO

Recommended Posts

Hi

 

I'm having trouble with cloud flicker as can be seen in the (very) short video below.

 

 

Is this a common FSX thing or is there something off with my setup that causes this?

 

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Unfortunately it's a fact of life with FSX when you have a cloud layer that intersects with terrain. :/

Share this post


Link to post
Share on other sites

Unfortunately it's a fact of life with FSX when you have a cloud layer that intersects with terrain. :/

 

Ah OK, in a way I'm pleased, at least it's not my setup! That will explain why it's not all the time!

Share this post


Link to post
Share on other sites

 

Just so MDF86 doesn't get confused, the fix you link here is for an unrelated issue. This link cures the problem where clouds "redraw" when you rotate the camera and FSX has to load scenery into memory again. So it's a useful fix, but the issue MDF86 is talking about is a z-buffer clipping issue that has no fix. It's a result of FSX trying to draw the cloud polys into the terrain polys and at long distances, you get "z-fighting" which is where the z-buffer doesn't have enough precision to determine which surface should be being displayed.

 

I hope that clears this up :)

Share this post


Link to post
Share on other sites

Thanks to you both, the other problem annoys me too and it's nice to know there's a fix!

Share this post


Link to post
Share on other sites

It's the "haze" layer that causes it. Some weather engines allow one to turn it off. However, if turned off you don't get a proper representation of the weather.

There was somewhere in the avsim library a set of haze layers, one being quite transparent which in effect fixes the problem. Also fixing the problem of a "following a/c" cloud.

Share this post


Link to post
Share on other sites

I watch a few OpusFSX Weather Engine videos of clouds hanging out around mountains and low valley areas and this flicker was not occurring.   Did they find a way to get around the Z-Buffer collision?

Share this post


Link to post
Share on other sites

No.

 

It also depends on what your ClipMode = xxx is set to in Cameras.cfg.  If it's ClipMode = Minimum (the fix to cure things like strobe lights and beacons appearing through the VC,) the z-fighting (flickering) of distant objects is much worse.

 

I actually finally found something that really helps minimize the flickering, which is to set ClipMode = Normal to the VC entry in Cameras.cfg. It's still there but a lot less noticeable this way, but you have to live with the occasional strobe light clipping through the VC model geometry.

Share this post


Link to post
Share on other sites