Archived

This topic is now archived and is closed to further replies.

ilovetoflysmile

Help please.

Recommended Posts

Hi, I'm new here and I really don't know where to post this thread.  :P 

I just replaced the file " UIAutomationCore.dll " 

and when I started flying again, I can't see my "menu" where the options , addons , flights , aircraft and failures are found...
If I press right click, nothing happens it usually show a drop-down... but now it doesn't show anything because I replaced "UiAutomationCore.Dll"

because I replaced the .dll is this the cause? If it is, CAN SOMEONE upload the original " UiAutomatiocCore.Dll " ? even if it's not the cause could someone kindly upload it? Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

UiAutomationCore.Dll is not an FSX file so it isn't replaceable per se. You can just rename it to UiAutomationCore.Dll.OLD. If that doesn't solve the problem, it is not the UiAutomationCore.Dll that is causing the problem.

Share this post


Link to post
Share on other sites

UiAutomationCore.Dll is not an FSX file so it isn't replaceable per se. You can just rename it to UiAutomationCore.Dll.OLD. If that doesn't solve the problem, it is not the UiAutomationCore.Dll that is causing the problem.

I'll try this solution and I haven't touched any files on my FSX I just added some Planes and replace that File after replacing menus won't show up...gonna try that solution now.

 

EDIT: Nope, still not working. Everytime I launch it crashes now...found a way to fix it though, now, the Menu Problem thx. :)

Share this post


Link to post
Share on other sites

UiAutomationCore.Dll is not an FSX file so it isn't replaceable per se. You can just rename it to UiAutomationCore.Dll.OLD. If that doesn't solve the problem, it is not the UiAutomationCore.Dll that is causing the problem.

 

Since he said he replaced it, I suppose the replaced the one in the System folder... while he simply should have added the version he downloaded into the FSX folder. So I think he really needs the original one to be placed into the System folder. But since we don't know yet what system he is running, there is nothing much we can do right now.

Share this post


Link to post
Share on other sites

Since he said he replaced it, I suppose the replaced the one in the System folder... while he simply should have added the version he downloaded into the FSX folder. So I think he really needs the original one to be placed into the System folder. But since we don't know yet what system he is running, there is nothing much we can do right now.

Hmm, found my CD under my table... I'll try to reinstall. :P

Share this post


Link to post
Share on other sites

Hmm, found my CD under my table... I'll try to reinstall. :P

 

Where did you put UIAutomationCore.dll?

Share this post


Link to post
Share on other sites

ok, that's good. Don't try to put it anywhere else, adding to registry or something like that, just place it in FSX main folder. Here is the link: https://www.dropbox.com/s/adxsx0mxb6wztil/UIAutomationCore.rar

 

Even if you press "alt", there is no menu? 

 

Try to install / re-install latest FSUIPC http://forum.simflight.com/topic/66139-updated-modules/

 

and to check your DLL.XML integrity http://support.precisionmanuals.com/KB/a92/dllxml-information-and-troubleshooting.aspx

 

That should fix it

Share this post


Link to post
Share on other sites

ok, that's good. Don't try to put it anywhere else, adding to registry or something like that, just place it in FSX main folder. Here is the link: https://www.dropbox.com/s/adxsx0mxb6wztil/UIAutomationCore.rar

 

Even if you press "alt", there is no menu? 

 

Try to install / re-install latest FSUIPC http://forum.simflight.com/topic/66139-updated-modules/

 

and to check your DLL.XML integrity http://support.precisionmanuals.com/KB/a92/dllxml-information-and-troubleshooting.aspx

 

That should fix it

 

 

 

 

I'll try this solutions. Thanks

Share this post


Link to post
Share on other sites

ok, that's good. Don't try to put it anywhere else, adding to registry or something like that, just place it in FSX main folder. Here is the link: https://www.dropbox.com/s/adxsx0mxb6wztil/UIAutomationCore.rar

 

Even if you press "alt", there is no menu? 

 

Try to install / re-install latest FSUIPC http://forum.simflight.com/topic/66139-updated-modules/

 

and to check your DLL.XML integrity http://support.precisionmanuals.com/KB/a92/dllxml-information-and-troubleshooting.aspx

 

That should fix it

Certainly no expert but FSUIPC and the DLL.XML shouldnt effect the entire menu board just the addons section. I have heard and seen this loss of the entire menu but can't recall the fix. Whether it was delete and rebuild the FSX.cfg or a Windows operation. Sounds almost like a display deal. Good luck.

Share this post


Link to post
Share on other sites

 

 


If it is, CAN SOMEONE upload the original " UiAutomatiocCore.Dll " ? even if it's not the cause could someone kindly upload it? Thanks.

 

In case you replaced the system uiautomationcore.dll, you can run the following program that scans your system for corrupt or missing files and replaces them - http://pcsupport.about.com/od/toolsofthetrade/ht/sfc-scannow.htm.

 

Best regards,

Share this post


Link to post
Share on other sites

replaced UiAutomationCore with the Original one. Thanks B247NG and to all who replied to this Topic! 

 

Thanks, and let's start flying!  ^_^

Share this post


Link to post
Share on other sites

 

 


Certainly no expert but FSUIPC and the DLL.XML shouldnt effect the entire menu board just the addons section

 

dll.xml yes, only addons, but i did some research and for some people installing/reinstalling FSUIPC4 solved missing menu, i realy don't know how :) 

Rebuilding fsx.cfg can help also

Share this post


Link to post
Share on other sites