Archived

This topic is now archived and is closed to further replies.

carlhermans

False Heading and Compass display

Recommended Posts

Dear friends,

Since a few weeks I get a complete erronous heading indication on my RMI and magnetic compass.

This happens in every aircraft from Cessna to iFly B737 or PMDG 747-400F

At the runway 34 at Seattle the real heading (of the runway) is 340°, the compass and RMI indicates 290° 

At runway 26 at EBOS the actual heading is 260° and I read on my compass and RMI 124°

 

Flying a iFly 737 from Brussels to Birmingham the aircraft is following the programmed course in the FMC - tot the wast but the indication on the display is completely out of course... the heading is about 175° to the southeast...

 

Is it possible that my FS2004 lost his geographical north?

 

I checked the deviation at several points on the globe and find that the error was very different: at some airports it was only 2° (ENGM Oslo); or 13° at TNMC (Sint Maarten) or 46° difference at EGBB (Birmingham).

 

Is it possible to repair this error by replacing a "gauge" file? The FS2004 on my laptop does not have these error!

 

Kindest regards and thanks for your estimated help.

 

Carl

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It could be a faulty scenery file.  I had a similar problem after installing a freeware St.Vincent scenery.  If you added anything just before this started, disable or uninstall it and try again. Mine immediately reverted to normal with LVSV removed.

 

There is a replacement MagDec file available but your differences look too big to corrected by that.

 

Deviation is the difference between Magnetic and Compass headings and nowadays can be largely disregarded as it is usually very small. (It's shown on your compass deviation card near your standby compass. Main compasses detectors are usually in the wing, well away from equipment which might affect them and don't usually need any correction or have info supplied by the inertial system.)

 

You're talking about Variation, the difference between True and Magnetic North (or bearings).  This does vary a lot throughout the world, as you have seen, although your figure for EGBB is wrong, should only be about 1°. Variation can also be East or West and is applied to True to give Magnetic bearings.

 

Colin B

Share this post


Link to post
Share on other sites

It is almost certainly your magdec file. It may be corrupted or there is another scenery that is conflicting with it. If you keep it at the highest priority it will always over-ride any other scenery file that is causing a conflict and you won't have this problem again.

 

What I have done is create a folder in addon scenery called Special. Inside the folder create a scenery folder. NO TEXTURE folder... Move the magdec file in there and then make sure that it is always the highest number on your scenery.cfg list. (Unless you use AES which has to be the last entry or it won't work)  If I remember correctly, you will find the magdec file in Scenery/Generic/Scenery

[Area.501]
Title=Special
Layer=501
Active=TRUE
Required=FALSE
Local=Addon Scenery\Special
Remote=

[Area.502]
Title=AES Basepack
Layer=502
Active=TRUE
Required=FALSE
Local=Aerosoft\AES
Remote=

 

Good luck

Ian

Share this post


Link to post
Share on other sites

Since the OP has the iFly 737, I strongly suggest not to follow the Magdec moving tweak.

 

I apologize, Ian, but when I did this tweak, my ND went nuts. I could only figure what happened after a full reinstall (sim+ addons). You know how it hurts ;-)

 

If it's a corrupted Magdec.bgl, you may extract it from your FS9 CDs and overwrite the file you've already got.

 

Hope this helps.

 

Sent from my Nokia 1100

 

 

Share this post


Link to post
Share on other sites

Dear Colin, Ian and Luis,

 

First of all sorry for my late reply. I was a few days out!

And sorry for my ambiguous formulation of my problem, using "deviation"  a complete wrong way. As a sailor i had to know better!

 

Many thanks for Colin's solution. 

I disabled my latest scenery add-ons ( EGBB; LOWW Vienna; abudhabi; and The Alex Fraser) and the problem was solved. Everthing works correctly.

 

I will find out tomorrow which one of the 4 scenery add-ons is the guilty one!

 

Kindest regards and thanks again for your highly estimated help!!! 

 

Carl

Share this post


Link to post
Share on other sites

Hi Carl

You are very welcome. My guess is that it's the last one as I have the others, presuming they are from the same publishers. Once you've located the addon that is causing it, you can still use that addon as long as your magdec file is at a higher number in your scenery.cfg

Cheers

Ian

Share this post


Link to post
Share on other sites

Good Day All,

I have been having this problem for a while now and was very interested in the above possible solutions.

Ian, your comments re the magdec bgl file. I have checked both my backed up fs9 and my using fs9 and cannot find a magdec bgl file in either of the scenery\generic\scenery folders. I have located the magdec bgl file in Disc 3 under MSGAME8.cab magdec.bgl at 130468 kb. Could you possibly give me your advice as to how to copy this file off the disc into my fs9 as you suggest and also do you have a suggestion as to why it didn't get copied when I did the install ( I did not get any messages re corrupted files when I did the install ) 

 

Colinb, you note that a replacement magdec file is available. Could you please advise where I can obtain it.

 

Many thanks

 

Mike

Share this post


Link to post
Share on other sites

Good day All,

 

Edit to the previous post.

Colinb, Thanks, I have found the update.

Ian, The instructions on the magdec update states that the magdec is in the scenery\base\scenery folder so I am now going to check this and apply the update and see if the problems are solved.

 

Thanks again for the pointers

Mike

Share this post


Link to post
Share on other sites

You are welcome Mike. If you move the magdec file out of scenery/base/scenery and keep it in a folder as shown above you probably won't ever have the problem again. And using the updated file will give you a more up to date display of headings. The only problem you will have is that as most of the info in AFCADS, addons etc. will be based on the standard magdec so in some cases headings will be different. But it's usually just a matter of a few degrees....

Cheers mate - glad you could get it all sorted out

Ian

Share this post


Link to post
Share on other sites