Jump to content

Archived

This topic is now archived and is closed to further replies.

Jedi928

Do you use the tweak SWAP_WAIT_TIMEOUT=xxx with DX10 Scenery fixer?

Recommended Posts

It's nothing to do with the DX10 Fixer, Jedi. 

 

SWAP_WAIT_TIMEOUT=2, taken from several different sources:

 

This setting affects the loading of textures. It is the number of frames that the above process will have to wait before assuming a particular tile has been already loaded into video memory.

 

If SWAP_WAIT_TIMEOUT is set too high, then FIBER_FRAME_FRACTION (no matter if it is set to 0.99) will have to wait X number of frames before attempting to read a tile/texture from video memory. This will cause stuttering.

 

If SWAP_WAIT_TIMEOUT is too low and the requested texture has not yet been loaded into video memory you will see a white flash.

 

It's size will depend upon GPU speed & memory, against the graphics pipeline speed. 2 is where mine sits at this moment.

 
Regards,
 
pj

Share this post


Link to post

That is good to know. Thanks for the thorough explanation.

Share this post


Link to post

What is the default if not in the configuration file?

 

--Don

Share this post


Link to post

I think it's 3.

Share this post


Link to post

Bojote had published 30, but I don't think that's applicable any more, given the increased speed of hardware. One can try any number of course! Too big should cause stuttering - try it! Experiment - that's how these things become recognised as a good tweak - or a waste of time......   :lol:

 

All the best,

 

pj

Share this post


Link to post

I'm currently using SWAP_WAIT_TIMEOUT=30 in DX10 with the Fixer, and it is smoother now, and I think (but not sure) that fps is  a little bit higher on approaches and finals.

Share this post


Link to post

Lower the SWT-out until white flashing begins - then up it by one. Mine is set to 3, as it was when using the 580. Remember - it's tied to the FFTF setting - which will cause stuttering when too high, and ground texture blurring when too low.

Share this post


Link to post

I have FFTF at 0.15, and SWT at 30, and everything is perfect. No stutters, no flashes. But I have a problem with lens flare and contrails (flashing and dissapearing), and I'm not sure is that problem connected with fsx.cfg at all.

Share this post


Link to post
×
×
  • Create New...