Sign in to follow this  
fakeflyer737

ASN over a Network

Recommended Posts

Hi guys,
 For years I've run almost all the Hi-Fi series WX addons on my laptop and it's been years since I had to set it up with Simconnect and all that nonsense. Anyways, tonight I purchased ASN and I'm trying to set it up on my client laptop but I'm having one hell of a time actually getting to inject WX in my FSX. I'm certain that it's my fault and not ASN's, I'm not very good at networking. My question is. Does it really make a performance difference if ASN is run on another computer that's not my FSX computer. I kinda wanna just install it on FSX computer and leave it as that. 

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ron,

 

There wasn't any performance hit on my PC when I ran ASN on it.  Will you be running the UI on a separate screen while FSX is in windowed mode or are you simply just going to run with ASN in the background?

 

I can help you with your networking if you'd like to give it a try.

Share this post


Link to post
Share on other sites

Ok thanks Robert. I was planning on running ASN on my laptop (client) and running FSX on my main PC (server). Im having a lot of trouble running it on my Client (setting it up), I was just wondering if there was a performance benefit of running ASN on a client, because if there is not than it would be simplier for me to just run it on my main FSX computer and just full screen in and out to check the WX.

Share this post


Link to post
Share on other sites

 

 


just full screen in and out to check the WX.

 

Thats where having it on a networked computer is nice. This going in and out fullscreen can be just something more to go wrong. Ive seen the issue with ASN. I just installed it on my client computer, didn't changed a thing from AS2012 and it worked fine. Strange.

Share this post


Link to post
Share on other sites

Ya I know, I'd rather it be over on the Laptop. I wiped my FSX install in PPv2 came out ( HUGE mistake) now I've gotta redo everything. Does the ASN X Gauge give you enough information to just use that?

Share this post


Link to post
Share on other sites

<!-- isHtml:1 --><!-- isHtml:1 --><strong class='bbc'>This is an automatic message.</strong><br /><br />This topic has been moved from "MS FSX Forum" to "The Unofficial Active Sky Support Forum". This move has been done for a number of possible reasons.<ul class='bbc'><li>The most likely reason is that the post was off topic.</li><li>The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.</li><li>The images might not have been "illustrative" or "explanatory" in nature.</li><li>The topic could have been moved because we deemed it to be more appropriately placed elsewhere.</li></ul>Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. <a href="http://forum.avsim.net/page/AVSIM%20Pages/screen_shot_rules.html"><B>See our image posting rules here</b></a>.<br /><br />Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

Ya I know, I'd rather it be over on the Laptop. I wiped my FSX install in PPv2 came out ( HUGE mistake) now I've gotta redo everything. Does the ASN X Gauge give you enough information to just use that?

I dont know Ron, ive never used it. ASN has a lot of information in the skin itself though. Sounds like you need to put your simconnect .xml in back in your Appdata FSX folder?

Share this post


Link to post
Share on other sites

It is in there, here's a copy. I have everything shared correctly and I am able to read, write and save in those shared folders on my client laptop.

 

<?xml version="1.0" encoding="Windows-1252"?>
 
<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect Server Configuration</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
 
  <!-- Example Global (remote) Pipe Server Configuration-->
  <SimConnect.Comm>
    <Disabled>True</Disabled>
    <Protocol>Pipe</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Port>REPLACE_WITH_PORT_NAME</Port>
  </SimConnect.Comm>
 
  <!-- Example Global (remote) IPv6 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>True</Disabled>
    <Protocol>IPv6</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Address>::</Address>
    <Port>REPLACE_WITH_PORT_NUMBER</Port>
  </SimConnect.Comm>
 
  <!-- Example Global (remote) IPv4 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>True</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Address>192.168.0.100</Address>
    <Port>500</Port>
  </SimConnect.Comm>
 
  <!-- Example Local Pipe Server Configuration-->
  <SimConnect.Comm>
    <Disabled>True</Disabled>
    <Protocol>Pipe</Protocol>
    <Scope>local</Scope>
    <MaxClients>64</MaxClients>
    <Port>REPLACE_WITH_PORT_NAME</Port>
  </SimConnect.Comm>
 
  <!-- Example Local IPv6 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>True</Disabled>
    <Protocol>IPv6</Protocol>
    <Scope>local</Scope>
    <MaxClients>64</MaxClients>
    <Address>::1</Address>
    <Port>REPLACE_WITH_PORT_NUMBER</Port>
  </SimConnect.Comm>
 
  <!-- Example Local IPv4 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>True</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>local</Scope>
    <MaxClients>64</MaxClients>
    <Address>127.0.0.1</Address>
    <Port>REPLACE_WITH_PORT_NUMBER</Port>
  </SimConnect.Comm>
 
</SimBase.Document>

anything odd looking in there?

Share this post


Link to post
Share on other sites

This is mine Ron. Only 2 grouping compared to yours.

 

<?xml version="1.0" encoding="Windows-1252" ?>
<SimBase.Document Type="SimConnect" version="1,0">
<Descr>SimConnect</Descr>
<Filename>SimConnect.xml</Filename>
<Disabled>False</Disabled>
<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>global</Scope>
<Address>192.168.2.10</Address>
<Port>6600</Port>
<MaxClients>10</MaxClients>
<MaxRecvSize>8192</MaxRecvSize>
<DisableNagle>True</DisableNagle>
</SimConnect.Comm>

<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>Auto</Protocol>
<Scope>local</Scope>
</SimConnect.Comm>
</SimBase.Document>

Share this post


Link to post
Share on other sites

Should be using port 500. Or whatever you port is in your client document simconnect .cfg file.

 

My Server simconnect.xml:

 

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>XXX.XXX.X.X</Address>.....Enter you server IP address
    <MaxClients>64</MaxClients>
    <Port>500</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>

 

client simconnect.cfg in client document folder.

 

[simConnect]
Protocol=IPv4
Address=XXX.XXX.X.X......Server IP address
Port=500
MaxReceiveSize=4096
DisableNagle=0

 

Enable network sharing of the server FSX and Appdata folder.
 

Share this post


Link to post
Share on other sites

Check your simconnect.cfg in client documents folder too Ron. Making sure IP address is correct

 

Try this port.

 

[simConnect]
Protocol=IPv4
Address=192.168.2.10
Port=6600
MaxReceiveSize=8192
DisableNagle=1

 

 

Share this post


Link to post
Share on other sites
I believe the port must be 4 digits between 4000 and 9999. Something like that. Just use 6000. And make sure the IPv4 address matches.

Share this post


Link to post
Share on other sites

Ok so the manual said use port 500 and enable it through the Firewall and I've always used 500 and its worked in the past. I checked the IP's and they all match.

Share this post


Link to post
Share on other sites

Use 500. Do you have your server IP address enter correctly? Can you see/acces your FSX folder from the client computer ?

Share this post


Link to post
Share on other sites

Use 500. Do you have your server IP address enter correctly? Can you see/acces your FSX folder from the client computer ?

Yes Sir, I can access my FSX APP FSX Files and the main FSX folder.

Share this post


Link to post
Share on other sites

The manual specifically says, "Properly installing and configuring SimConnect is not documented here." It says to open port 445 in the firewall settings on both machines. That is not related to simconnect settings. If you haven't heard of it, do a search for SimConnect Config Tool. It's an awesome little app that makes configuring simconnect a breeze. 

Share this post


Link to post
Share on other sites

The manual specifically says, "Properly installing and configuring SimConnect is not documented here." It says to open port 445 in the firewall settings on both machines. That is not related to simconnect settings. If you haven't heard of it, do a search for SimConnect Config Tool. It's an awesome little app that makes configuring simconnect a breeze. 

OMG!!!!!!!!!!!!!!!!!!!!! CLICK CLICK BOOM!! It works! Thanks everyone! I really love all of you for helping me. Jesse if we ever meet in person I owe you a few beers 

Why is it when I disconnect my ethernet cable and go on Wifi with my laptop all of my files that choose to share dissappear>

Share this post


Link to post
Share on other sites

OMG!!!!!!!!!!!!!!!!!!!!! CLICK CLICK BOOM!! It works! Thanks everyone! I really love all of you for helping me. Jesse if we ever meet in person I owe you a few beers 

Glad I could help Ron! That's what it's all about. No beers necessary (but sounds good:)

 

After switching to wifi, close the Explorer window and reopen it, see if that helps.

Share this post


Link to post
Share on other sites

OMG!!!!!!!!!!!!!!!!!!!!! CLICK CLICK BOOM!! It works! Thanks everyone! I really love all of you for helping me. Jesse if we ever meet in person I owe you a few beers

 

Why is it when I disconnect my ethernet cable and go on Wifi with my laptop all of my files that choose to share dissappear>

Can you share what you did to get it working? What steps did you take? Did you use the sim connect tool? Where on your laptop is the simconnect.xml located? Your help would be appreciated.

 

 

 

 

Sent from my iPad using Tapatalk

Reece

Share this post


Link to post
Share on other sites

 

 


Where on your laptop is the simconnect.xml located?

 

The simconnect.xml should be located on your server pc in the app data folder (along with your fsx.cfg.) The simconnect.cfg file on your client pc, or laptop, could be in a number of locations. It depends on the app you are trying to connect with the server. For example, the ASN simconnect.cfg is located at Hifi/ASNext_FSX/SimConnectFiles in your install location. Who knows where PlanG simconnect.cfg is but you control it from the app itself. 

 

Hope that is helpful and makes sense.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this