Sign in to follow this  
piperarrow41

FSX Freezes When Avionics Master Switch Turned Off

Recommended Posts

Just recently FSX started freezing after I complete a flight and turn the avionics master switch off.  It doesn't matter what airplane I am flying, or what airport I am located at.  After landing I taxi in and start the shut down process, when the avionics master switch is turned off the sim freezes and I have to use the task manager to shut it down....this is while using the Reality XP 530W.  The only thing I have changed recently was the latest update to Active Sky Next.  Any ideas what might be causing this? 

 

Thanks,

 

John

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Since you are going into Task Manager to quit FSX, take a look at "Processes" and look through the list to see which one is taking the CPU into intersteller overdrive.  I would say the CPU can't find what it's looking for.

Share this post


Link to post
Share on other sites

Hi John

Do you have FSUIPC installed? if so read on - Just had a similar problem using the Reality XP 530W as a popup in the Aerosoft Twin Otter.  Similar problem FSX crashed when I changed legs in the GNS530 or also if I left FSX paused longer than a minute or so which started randomly  sometime after the Active Sky Next Upgrade. Finally found an error in windows event manager that mentioned FSUIPC and Active Sky Next as being active at the crash.

 

Long story short  I checked out Peter Dowsons page and downloaded the latest version 4.929 (unzipped and installed shows as 4.929C ) Fixed my problem and no crashes since. The readme file says FSUIPC4 now cooperates with "Active Sky Next" (ASN). Two specific changes apply: first the hooks normally applied into the FSX/P3D weather system for FSUIPC's smoothing actions are not performed when ASN isactive, as it uses those hooks itself." 

 

Hope this is of some help - best of luck.

 

Cheers Pete

Share this post


Link to post
Share on other sites

Thank you for the information!  I am not sure what version of FSUIPC I am currently running, but will certainly check when I get home tonight.  The problem only occurs while using Active Sky Next as I tried OPUS last night without any problems. 

 

Thanks again,

 

John

Share this post


Link to post
Share on other sites

I just checked and have the latest version of FSUIPC installed.  Any other ideas?

 

Thanks again,

 

John

Share this post


Link to post
Share on other sites

Hi John

Mate the latest version numbers appear to vary depending on which site you are looking at. Is your FSUIPC Window showing 4.929c  if not you can download it at the following link - Cheers Pete

 

Pete Dowson, on 12 Mar 2014 - 7:29 PM, said:

That is a big bug! I am fixing it now -- in 4.929c. I will advise when it is ready ...

 

Okay. Download FSUIPC 4.929c. It is also shown in the Download Links subforum.

 

Pete

Share this post


Link to post
Share on other sites

John,

 

What is your FSUIPC version number?

Is it the FSUIPC Registered (payware) version?

 

Which aircraft has the problem with RealityXP WAAS installed?

Share this post


Link to post
Share on other sites

I just double checked and the version I had been using was 4.929.  I just downloaded and installed the version from the above link and will give it a try. 

 

I do have the registered version of FSUIPC and it appears to happening on all aircraft with the Reality XP 530 installed.  I will try version "c" and report back.

 

Thanks again for the great info.

 

John 

Share this post


Link to post
Share on other sites

I have RXP530W also.

 

The reason I asked which aircraft is ... maybe I can test with the same aircraft.

 

List all the aircraft ... especially default MSFS aircraft that have the problem.

 

Maybe someone could help you.

Share this post


Link to post
Share on other sites

No problem.  So far it has happened on the following aircraft...

 

Milviz 310R

Carenado C340

Carenado Cirrus SR22

 

It seems to only happen after a flight that is at least 1 hour long.  I am testing the new FSUPIC right now, I will let you know how that goes.

 

Thank you for your help.

 

John

Share this post


Link to post
Share on other sites

Carenado has a special RXP setup .. as I understand.

 

Put the RXP530W in a Default FSX aircraft and test again.

Share this post


Link to post
Share on other sites

The newest version of FSUIPC did not help.  My event log just says application hang, it doesn't give any specific details.  There was an error with the ntdll.dll file, but I am not sure if that has anything to do with FSX.  This is frustrating.

Share this post


Link to post
Share on other sites

The newest version of FSUIPC did not help.  My event log just says application hang, it doesn't give any specific details.  There was an error with the ntdll.dll file, but I am not sure if that has anything to do with FSX.  This is frustrating.

The error with ntdll.dll may indicate that you system is being over-taxed a bit.  I had it happen a couple of times if I had my AI slider a bit too high.

Share this post


Link to post
Share on other sites

But I haven't changed anything with regard to graphics in the sim and it had been running perfectly.  I see that windows did an automatic update on the 10th and that is when I started having problems, could that have messed up some system files?  Is it possible my antivirus is somehow interrupting the ntdll.dll file causing the issue?  I tried doing a system restore, but for whatever reason that didn't work.


What about the bloom affect?  I just started using that recently, but I wouldn't see how that is tied to the avionics master switch.

Share this post


Link to post
Share on other sites

Lens Flare, Light Bloom have an effect on you CPU usage.  They are easy to un-check in the settings to see if that is the cause.  Sometimes the Windows Updates do some screwy things to your Graphics, like installing unwanted upgrades.  This also happened to me about 6 months ago and I spent about 3 hrs. trying to get my NVidia settings back to where they were.

 

What happens in your shut-down process if you leave the Avionics Master switch on?  That's one of the things in my default flight that is left in the ON position always.

Share this post


Link to post
Share on other sites

I haven't tried leaving the avionics master on, but will give that a try.  Something else I just thought of, I use Foreflight on my Ipad connected to FSX through FSX flight.  Foreflight just went through an upgrade when this started happening.  If I look at task manager when the hang occurs it says both FSX flight (which connects Foreflight to FSX) and FSX are not responding.  I am going to try not using Foreflight to see if that helps.

Share this post


Link to post
Share on other sites

Put the RXP530W in a Default FSX aircraft and test again.

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "Crash To Desktop (CTD) Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

So why the move?  Its not a crash to desk top, it just freezes.  My post probably would have seen more traffic in the FSX forum...increasing the chances for a fix.  I will be lucky to get any responses here in the CTD forum.

 

Thanks!

 

John

Share this post


Link to post
Share on other sites

 

 


I will be lucky to get any responses here in the CTD forum

 

Oh contraire!  This is the place for freezes, apphangs, CTD's belong.  AVSIM has a CTD Guide which covers these issues and the guide can be found under hotspots to the right of this forum.   You will be surprised as to how many people visit this forum. 

 

There are suggestions for the ntdll.dll error in the guide.  Recently we have discovered that MyTrafficX 5.4c causes this freeze, apphang, or CTD.  I went back to version 5.4b and my problems went away.  There is some discussion on the developers website.  Not sure you have MyTrafficX but wanted to mention it as a possibility.

 

Best regards,

Share this post


Link to post
Share on other sites

Thank you, for the clarification Jim.  I think I have the problem narrowed in on my Reality XP GNS530 installation.  I will try uninstalling then reinstalling this evening to see if that takes care of the problem.  Is there any special procedure for uninstalling the GNS530 to be sure all files are removed, or can I simply uninstall it from windows control panel? 

 

Best Regards,

 

John

Share this post


Link to post
Share on other sites

 

 


Is there any special procedure for uninstalling the GNS530 to be sure all files are removed, or can I simply uninstall it from windows control panel?

 

Should work from the Add/Remove Program Panel.  I would be surprised if that's the solution though.  It will give you more computing power though once disabled or removed as these gauges are sometimes resource hungry.

 

Best regards,

Share this post


Link to post
Share on other sites

Jim, that's not very encouraging. ;-P My thought is that something may be corrupt with my GNS530 installation and that by uninstalling and then reinstalling the software it would correct any corrupt files. At this point I do not have any other ideas. I guess it can't hurt to try?

 

Best Regards,

 

John

Share this post


Link to post
Share on other sites


At this point I do not have any other ideas. I guess it can't hurt to try?

 

This link might be helpful in your reinstallation - http://www.simforums.com/forums/cannot-install-gns-530-into-fsx_topic32318.html.  The GNS 530 was developed for a previous version of FS but made to work in FSX too.  That sometimes causes problems.  Good luck!

 

Best regards,

Share this post


Link to post
Share on other sites

The reinstall didn't help.  It is definitely the Reality XP GNS530 that is causing the problems which has been working great for the last 18 months.  I am not sure what has changed, I have tried everything and am out of ideas.

 

Thanks for your help.

 

John

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this