Jump to content

Archived

This topic is now archived and is closed to further replies.

ohsirus

Why won't Xplane Change Screen Resolution?

Recommended Posts

No, it definitely does work here, I have both X-Plane on OS X and Windows 7, and I sometimes run it at lower resolution when running it on  a second screen, or for performance reasons:

 

res.jpg

 

I'm presuming you've tried all the latest tricks like making sure you have the latest drivers installed etc..?


Hardware: i7-6700HQ, 32GB DDR4,NVIDIA GTX 1070, 1TB 7200 HDD, 1TB SSD, Oculus Rift.

My sims in order of use: X-Plane 11, P3D v4.4, Aerofly FS 2, DCS World).

 

Share this post


Link to post
Share on other sites

No, it definitely does work here, I have both X-Plane on OS X and Windows 7, and I sometimes run it at lower resolution when running it on  a second screen, or for performance reasons:

 

res.jpg

 

I'm presuming you've tried all the latest tricks like making sure you have the latest drivers installed etc..?

Yeah, it has never worked for me..Are you certain you can choose the lowest possible resolution and it changes?

Share this post


Link to post
Share on other sites

Yep, just tried it again on my Windows laptop, it goes to whatever I set it to, i.e. Down to 1024x768. It isn't pretty, but seems to work.

 

Does it not work on any resolution mode at all? Also, just something to try, what happens if you run X-Plane as administrator?

 

Just another note, I've disabled all the desktop effects on Windows 7 and using the classic mode.

 

Edit: Found in this in the X-Plane docs

 

 

When using X-Plane in windowed (i.e., not full-screen) mode, simply dragging the window size down will lower your resolution. When using X-Plane in full-screen mode, open the Rendering Options by moving the mouse to the top of the screen, clicking Settings, then clicking Rendering Options. Since the run full-screen at this resolution box must be checked for full-screen mode, you can use the drop-down menu to the right of that box to choose a lower resolution. Try 1024×768 first to see if lowering the resolution does indeed improve your frame rate. Note, however, that choosing a resolution different from the resolution set in your operating system may cause X-Plane to display a black border around the simulator.


Hardware: i7-6700HQ, 32GB DDR4,NVIDIA GTX 1070, 1TB 7200 HDD, 1TB SSD, Oculus Rift.

My sims in order of use: X-Plane 11, P3D v4.4, Aerofly FS 2, DCS World).

 

Share this post


Link to post
Share on other sites

Yep, just tried it again on my Windows laptop, it goes to whatever I set it to, i.e. Down to 1024x768. It isn't pretty, but seems to work.

 

Does it not work on any resolution mode at all? Also, just something to try, what happens if you run X-Plane as administrator?

 

Just another note, I've disabled all the desktop effects on Windows 7 and using the classic mode.

 

Edit: Found in this in the X-Plane docs

 

 

Exactly. You can't really lower the resolution in a traditional sense. 

Share this post


Link to post
Share on other sites

 

 


Exactly. You can't really lower the resolution in a traditional sense.

 

I've done a little more experimentation. On Mac OS X it always works, no black border, and you can set it to whatever you want. On Windows (running on a Mac), it also works. However, on my girlfriend's Windows 7 laptop, it does exactly as you reported, it just changes the window size and not the screen resolution. So, it certainly seems operating system and graphics card dependent.


Hardware: i7-6700HQ, 32GB DDR4,NVIDIA GTX 1070, 1TB 7200 HDD, 1TB SSD, Oculus Rift.

My sims in order of use: X-Plane 11, P3D v4.4, Aerofly FS 2, DCS World).

 

Share this post


Link to post
Share on other sites

On a windows system, if the monitor is detected as "generic" or "Plug and play", X-Plane will often not let you change its resolution.

You need to install the "driver" for the monitor (an INF file, an ICM file and a CAT file).

This is nothing to do with the Graphics Card driver and it usually does not have an EXE run-able install file.

Also, please note, this can only happen if full-screen mode checkbox is ticked under "rendering Options". 


Greetings

Dave Britzius

(Cockpit Designer and Flight Simulator Hardware Supplier)

Cape Town

http://davebritzius.com

Share this post


Link to post
Share on other sites

Thanks for the info Dave. Actually, on both of my Windows systems, both monitors are generic and are detected as generic, and it works on one and not on the other. Also, I've noticed DirectX games don't have this problem, e.g. FSX/P3D will resize without problems, but X-Plane won't. Maybe it's OpenGL (Driver) related as well?


Hardware: i7-6700HQ, 32GB DDR4,NVIDIA GTX 1070, 1TB 7200 HDD, 1TB SSD, Oculus Rift.

My sims in order of use: X-Plane 11, P3D v4.4, Aerofly FS 2, DCS World).

 

Share this post


Link to post
Share on other sites

FIgured it out..after all this time.

 

Since I run a Nvidia, went to NV control Panel.

 

Display-

------------Adjust desktop size and position

                         Apply the following settings: Full Screen

                          "Check mark" Override the scaling mode set by games and programs

 

 

Now Xplane scales full screen to whatever resolution I choose. The first time i did it and exited it didn't change my desktop resolution back to its native, but onlu happened that one time as I believe XPX crashed.

Share this post


Link to post
Share on other sites

Ah thank you. Yes, that's the major difference between my two laptops, one was ATI (and it worked), and other is Nvidia. This is good to know, great find.


Hardware: i7-6700HQ, 32GB DDR4,NVIDIA GTX 1070, 1TB 7200 HDD, 1TB SSD, Oculus Rift.

My sims in order of use: X-Plane 11, P3D v4.4, Aerofly FS 2, DCS World).

 

Share this post


Link to post
Share on other sites

Ah thank you. Yes, that's the major difference between my two laptops, one was ATI (and it worked), and other is Nvidia. This is good to know, great find.

 

Seems to be not worth it. I scaled all the way down to 1024 and my FPS stayed the same no matter what resolution I choose. Also I couldn't alt-tab out of X-plane as it would go into a display flicker loop.

Share this post


Link to post
Share on other sites

×
×
  • Create New...