Sign in to follow this  
ryanbatcund

Trim too broad

Recommended Posts

By that I mean if I just press my trim button once the planes pitches up or down fairly rapidly....

 

I swear I had this setup in FSX but  after my hdd format I noticed I did not - both FSX and P3D behave like this...

 

Can anyone help me?  Here's my current setup

 

trimsesntive.jpg

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Set P3DV2 control realism setting to easy, medium, or difficult before calibrating controller. Mine was like yours until I adjusted those settings.

Share this post


Link to post

Move the sensitivity sliders to the middle, the sliders you see in the screen shot you posted.

Share this post


Link to post

If you have the paid FSUIPC, you can use it to calibrate/assign all of your controls. (axis and buttons)

 

regards, jazz

Share this post


Link to post

If you have the paid FSUIPC, you can use it to calibrate/assign all of your controls. (axis and buttons)

 

regards, jazz

 

+1 I adjusted the amount of trim using the FSUIPC trim settings found in the FSUIPC user guide.

Share this post


Link to post

I don't have FSUIPC or fs trim - ill try the above thoigh

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this