Sign in to follow this  
dental12

fsx atc not listening

Recommended Posts

HI

I have the delete key set to talk to atc but after the initial request, atc does not hear me when the del key is pressed. I also tried assigning the delete key in the fsx controls menu but no luck. What should I do

thx Lee

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Might try changing the frequency from what you are tuned into for ATC...then change it back.

An FSX wierdism..lol

Share this post


Link to post
Share on other sites

Have tried that. Basically the delete button is not working with atc. Also the other joystick button isnt either. Did I miss some setting? Quite frustrating.

Comms with Fo and others work great. Just not ATC

Share this post


Link to post
Share on other sites

Not sure on that one then. I am sure someone who has experienced this will chime in.

Sorry I could not help. I feel your pain on the frustration tho.

Share this post


Link to post
Share on other sites

HI

I have the delete key set to talk to atc but after the initial request, atc does not hear me when the del key is pressed. I also tried assigning the delete key in the fsx controls menu but no luck. What should I do

thx Lee

Hello Lee,

 

I did have this issue a while ago.

 

1.  Make sure DEL key is not assigned to anything else in FSX

2. When you install MCE you will get a box asking you which key you want to assign the Push To Talk and here I always push my chosen joystick button.

3. I used to have the DEL key mapped to my joystick button as well (Saitek Map) but don't do that anymore. Its all in the initial set up of MCE. MCE has got to know the joystick, (or in your case) keyboard key you want to use for PTT.

4. Do you have the PTT transmission "Hum" switched on from the MCE GUI? If not turn it on (select from GUI menu) and set it at max volume. Then listen for it when you have the PTT button pressed.

5. Try assigning a different key

6. Try assigning a joystick button when you run MCE.

7. Try reset to factory defaults.

8. Re install MCE and run the PTT select joystick button routine.

9. Use the latest version of MCE having previously deleted the last one.

 

Hope this helps. Its just what I would do. I am sure one of the team will be along soon if this does not help.

 

Best Regards

David.

Share this post


Link to post
Share on other sites

 

 


7. Try reset to factory defaults.

 

As David pointed out, whenever you experience strange things going on, a restore to factory settings is the most effective way.

 

It will replace your "mce.ini" config file with a fresh one in synch with the latest package you installed, and provide you with default settings that work for almost everyone.

 

This in turn will force you to go through the wizard, which will ensure everything is setup as expected, be it on the MCE side or the speech engine setup side.

 

Important: No need for speech training every time you have to go through the wizard.

The speech profile you trained is managed by Windows, not MCE.

It would only be lost when you format your hard drive clean or delete your user account from your machine.

Share this post


Link to post
Share on other sites

Hi

I restored factory settings and I was not forced to go through wizard.

The del key seems to be the only option to be either checked or unchecked

do I uncheck it and go to the fsx keyboard control settings and use them?

By PTT transmission "hum", do you mean one of the sliders in the GUI(cpu usage,speech rate etc) or some place else

Where is the Ptt routine. Is it under the tools option?

I have the latest version

Also, when I press the joystick button ,the gui nseems to recognize the button # but thats it

      Sorry for all the questions but Im trying to be thorough and provide you with as much info as possible.

 

thx Lee

Share this post


Link to post
Share on other sites

I restored factory settings and I was not forced to go through wizard.

 

This isn't normal

 

When you restore to factory settings...

 

MCE makes a backup of old "mce.ini" config file

Deletes "mce.ini"

Copies "mce.bkp" from MCE installation folder to C:\Users\your_user_name\AppData\Roaming\Multi Crew Experience\ folder

 

as "mce.ini"

 

We have seen on some occasions, WIndows preventing one of those file operations, be it file saving or file creation. Maybe MCE isn't saving any of the settings, including selected joystick settings.

 

Did you by any chance sometime in the past, manually modify access rights to the C:\Users\ folder or one of its subfolders?

 

You could always manually set things in "mce.ini", however it's not what we expect users to do.

 

Could you post the content of your "mce.ini" in

 

C:\Users\your_user_name\AppData\Roaming\Multi Crew Experience\ (make sure your system is set to show hidden files and folders before you can find it)

 

Thanks

Share this post


Link to post
Share on other sites

having trouble posting ini file. how do you post stuff like this. copy and paste does not work

thx Lee

Share this post


Link to post
Share on other sites

I would be happy to add stuff manually to the ini file. I just want this to work.

so close yet so far

Share this post


Link to post
Share on other sites

I would be happy to add stuff manually to the ini file. I just want this to work.

so close yet so far

 

Check "mce.ini" file properties (right-click on the file). See if the file isn't actually locked in "read-only" mode, in which case nothing will be saved to it.

 

Suggest the following.

 

Manually delete the file "mce.ini"

 

Go to \Multi Crew Experience\ installation folder and cpy file "mce.bkp"

 

Go back to \AppData\Roaming\Multi Crew Experience\ folder and paste "mce.bkp" there.

 

Rename "mce.bkp" to "mce.ini"

 

That would be like running the reset to factory settings.

 

Should definitely have the wizard pop-in.

 

Once you are done with the wizard, including assigning a button for Push To Talk (PTT), check the following section in "mce.ini"

 

[GAMEPAD]

JoyManID=

JoyProdID=

JoyButton=

 

Do you have any info related to your joystick there?

Share this post


Link to post
Share on other sites

Hi

Did what you said and the game pad button and device is registering in ,ini but still no luck. what next? the delete button is not doing it either. Something else must be interfering.

Lee


could there be some fsx atc setting thats the problem. the atc works but not via voice. whenI press the joystick button, I see th atc window border change so there must be some communication.

Share this post


Link to post
Share on other sites

Hello

would you recommend trying a program like PFE instead of default atc. Could the problem be with the default atc or would i be wasting my time.

Your guidance is much appreciated

Thx Lee

Share this post


Link to post
Share on other sites

Hello

would you recommend trying a program like PFE instead of default atc. Could the problem be with the default atc or would i be wasting my time.

Your guidance is much appreciated

Thx Lee

 

It could be simply because you aren't familiar with ATC jargon.

 

Even real world pilots have to go through a learning curve.

 

Suggest using the "Speech training" tool we supplied, and go through the specific <ATC phraseology> topic.

 

Click Start->All Programs->Multi Crew Experience-Tools->Speech training.

 

You must speak the entire sentence swiftly between the times you hold PTT down and release it.

 

Any hesitation longer than a couple of seconds and the speech engine assumes you have finished speaking. At that point there might be no match to any existing ATC speech rules.

 

For VFR flying, Native ATC is the best out there.

 

When you become more proficient, and want to switch to IFR flying, you may want to consider RC4 and PFE, both supported by MCE.

 

Just don't make the investment until you have a good working speech interaction with Native ATC.

Share this post


Link to post
Share on other sites

Unfortunately this not the problem. The native atc tends to hear my first transmission but nothing after that. Even when try something short like the "say again" command,

It does not register.

I will be going back to voxatc. That works very well. I will now be able to put more time into learning MCE and all it has to offer. Thank you for you help!

Lee

Share this post


Link to post
Share on other sites

dental12

You are not alone in the frustrating struggle to get what you expected out of MCE.

Have been trying for 3 years to get successful simple VFR flight in the single engine Default FSX Cessna with no copilot.

All I wanted was to broadcast blind at non-towered strips and the usual communications at towered strips.

MCE comes up with all kinds of weird ATC happenings that make no sense at all.

 

Best I ever had was a long time ago when forum member Dick B came up with his No Copilot Wanted fix.

 

The FS++ Crew has had all kinds of suggestions but no luck so far.

 

Hate to give up but I'd rather be flying than chasing down mysterious problems.

 

Edwin Brown Keremeos BC Canada.

Share this post


Link to post
Share on other sites

I have exactly the same problem with ATC.  I get the 'hum' but no response at all from atc.   tried all the 'fixes',  re-installing, replacing mce.ini et cetera but atc gives no response.

 

Can ANYONE help?

Share this post


Link to post
Share on other sites

I have exactly the same problem with ATC.  I get the 'hum' but no response at all from atc.   tried all the 'fixes',  re-installing, replacing mce.ini et cetera but atc gives no response.

 

Can ANYONE help?

 

Sure.

 

Your entire transmission must happen swiftly between the time you hold PTT down, and the time you release it.

 

What call-sign are you using?

 

Are you using DEL key for transmission or a joystick button?

 

Write down the kind of ATC verbiage you're using, and what ATC window options are displayed at the time.

 

Do you fly GA aircraft or Tubeliners, IFR or VFR?

Share this post


Link to post
Share on other sites

I found the interaction hit and miss with ATC which was the whole point of me getting MCE

 

On top of that was the fairly constant crashing of MCE when addon planes were used which did not have typical .cfg's for MCE to 'read'

 

This is supposedly addressed by sending in the cfg to be fixed but it never really works properly. I gave up on MCE as a bad deal for my personal situation a while ago.

 

I know its not the same and doesn't contain ATC interaction, but the voice recognition of FS2Crew is far superior. Not sure how they managed to get it working so well. Im guessing because FS2Crew is very 'scripted' compared to MCE.......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this