Sign in to follow this  
DJJose

ENB Mod tips needed

Recommended Posts

I find myself having to go back to DX9. I have too many airports that have lighting issues, even with the DX10 fixer. I do miss the bloom effect so I decided to try the 24h EMB Mod. WOW! Awesome!

 

I do have some CTDs, even when running FSX in WinXP SP3 compatability mode.

 

Has anyone successfully been able to run the EMB Mod without CTDs? If yes, can you share your driver version and or settings? Anyone with any knowledge, please share advice.

 

Thanks.

Jose

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi, Jose. Just out of interest, is the WinXP compatibility mode really needed for FSX?

 

I ran ENB for a long time and always had the normal (Win7) mode on. I kept the drivers current so it must have been up to the 330.x generation. Also, what is the Windows event log showing when the CTDs take place? Any specific modules to look out for?

 

The only time when ENB became unstable was when toggling between fullscreen and windowed mode. Since I always had a maximised window for FSX, this wasn't a problem though.

 

I was a big fan of the REX Natural ENBPlus setup offered by Tim over at the REX forums. I left all settings unchanged except for the enbpalette.bmp file where I was using a less dark one tweaked by another user.

Share this post


Link to post
Share on other sites

Hi, Jose. Just out of interest, is the WinXP compatibility mode really needed for FSX?

 

I ran ENB for a long time and always had the normal (Win7) mode on. I kept the drivers current so it must have been up to the 330.x generation. Also, what is the Windows event log showing when the CTDs take place? Any specific modules to look out for?

 

The only time when ENB became unstable was when toggling between fullscreen and windowed mode. Since I always had a maximised window for FSX, this wasn't a problem though.

 

I was a big fan of the REX Natural ENBPlus setup offered by Tim over at the REX forums. I left all settings unchanged except for the enbpalette.bmp file where I was using a less dark one tweaked by another user.

It's the ENB mod. I tried every tip including removing himmemfix, fsx in xp3 mode, and global effects off, and still got ctds.

 

I removed the enb mod and no more ctds. It's sad because I love the way the sim looks with it enabled.

 

Jose

Share this post


Link to post
Share on other sites
found the solution

Hey, don't make that mistake to forget actually describing it. :P A common Internet phenomenon.

Share this post


Link to post
Share on other sites

 

 


Hey, don't make that mistake to forget actually describing it. :P A common Internet phenomenon.

 

Seriously...there are at least a few people who have had CTDs with ENB and may want the fix.  Please let us know what you found.

Share this post


Link to post
Share on other sites

You guys know me better than that.

 

I'm still testing. I have to check with the F1 Mustang and NGX at some airports.

 

Thx.

Share this post


Link to post
Share on other sites

Understood. Good luck testing and some fun flying those nice planes. :smile:

Share this post


Link to post
Share on other sites

I'd like to begin by stating that I tried ENB Mod when it was first introduced, but I hated the way it made FSX look. Removed it and forgot all about it. Steve's DX10 Fixer was released, tried it, and loved the atmosphere that bloom created. Unfortunately, I have way too many add-on airports that have some issues with dx10 lighting. Some devs don't want to fix these issues so I find myself going back to dx9, but I miss the atmosphere that bloom created when using dx10.

 

This lead me to try the ENB Mod. After trying the 24h ENB mod found in the REX forum, I was floored by the transformation. I also tried JVs Purple Haze mod and I love it. The only issue I was having was CTDs. After using Google, I came across a tip from NIckN, "remove HIGHMEMFIX=1." That line causes problems with the ENB Mod.

 

I put FSX back to default compatibility, removed HIGHMEMFIX=1 from the cfg, and even added UIAutomationCore.dll (I did not have in my FSX folder.) I don't think that it has anything to do with UIAutomationCore because I did not have it installed and never had ctds. I tried using UIAutomationCore.dll with HIGHMEMFIX=1 in my cfg and it crashed.

 

Removed HIGHMEMFIX=1 and now I don't have any ctds or scenery or plane corruption. I don't know if it's my EVGA 660ti OC 3gig card, but the removal HIGHMEMFIX=1 enables ENB to work with no corruption. Here are some pics with 24h ENB Enabled:

 

vP4y0.jpg

voSFg.jpg

1CwqJ.jpg

o8Ga.jpg

Axl2e.jpg

BJUQh.jpg

UpFDs.jpg

Tipxu.jpg

c3JrT.jpg

U8hrd.jpg

 

To recap:

 

1) Put FSX in default compatibility mode. Nothing ticked.

2) Remove HIGHMEMFIX=1 from the cfg (Thank you NickN)

3) Try 24h ENB Mod & JV's Mods (Thank you AmericanFlyer & JV of FTX)

 

I hope that this helps.

Jose

Share this post


Link to post
Share on other sites

Thanks for the details, Jose. The skeptic in me would envision other issues arising from not using the highmemfix line, but as long as the data points to a flawless operation, those concerns are meaningless.

 

Since you are now testing the new setup, perhaps keep an eye on the VAS usage to check if the loss of the highmemfix has any impact on that end. Would be interesting to know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this