Sign in to follow this  
kriggelb

HD vc shadows moving (merged thread)

Recommended Posts

Hello everybody,

first of all: Thanks a lot, Steve, for your ongoing work with the fixer!

I´ve got a small question, though:

I already went through the manual of the actual version (2.5) and I didn´t find an answer. With shadows enabled (new fsx.cfg line in the display section) and with "hd shadows", "ezdok compatibility" and "force vc walls" ticked I notice a strange issue: When moving my head using trackir the vc shadows move within the cockpit even if the aircraft itself is not moving. This is not really realistic, as shadows are drawn by the light source that shines on an object and not by moving your head inside the cockpit in a non-moving environment. Is there a way to solve this? I already tried unchecking the boxes mentioned above, but that didn't help. It seems as if I turn into the light source myself when using trackir and my head movements have a direct effect on the shadows drawn within the cockpit. That isn`t normal, is it?

Any help is greatly appreciated:-)

Kind regards,

Chris

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi there was a problem in 2.4 with ezdok but I am not aware of any issues. Doesthe problem occur if you uninstall the libraries and run in basic DX10 - is it true externally is it true for all aircraft or just one.

Share this post


Link to post
Share on other sites

When using the legacy shadows, it seems like the use of TrackIR/EZCA leads to that viewpoint dependency (moving the head alters the shadows, a lot).

 

Now, for non legacy shadows, this (EZCA problem?) was solved in 2.4 and especially 2.5, but how can one receive "static" shadows in legacy aircraft?

Share this post


Link to post
Share on other sites

I don't have EZCA/EZDOK to test with. You could try setting Shadow version in the debug dialog to 4 but I cannot see any difference in the handling.

Share this post


Link to post
Share on other sites

Will try that and report back, thanks Steve.

 

Edited. No change.  :mellow:  Here are my settings, just in case. I used the Maddog as testbed.

 

ZNunW6A.jpg

 

ZvweiO0.jpg

Share this post


Link to post
Share on other sites

Ok, not looking good then, does the same thing apply externally, does it apply to all legacy aircraft, does it work without exca? Does it apply without hd shadows?

Share this post


Link to post
Share on other sites

Hi, Steve. Have to test those things. Will post an update then.

 

Update.

1) does the same thing apply externally

2) does it apply to all legacy aircraft

3) does it work without exca?

4) Does it apply without hd shadows?

 

Answers.

1) No.

2) Only have two, the Maddog (jet) and the small DO-27. The latter does not receive any shadows at all, so I can not tell.

3) No (which surprised me).

4) With HD shadows off, the viewpoint dependency is gone and I can use EZCA just fine.

 

Edited. Posting my #4 shadow settings, just in case.

6XaSBDi.jpg

Share this post


Link to post
Share on other sites

Ok go into debug and deselect Adaptive HD Zoom - I suspect that this isnt EZDOK at all.

 

If the Zoom level is too high when HD shadows are selected then you can get strange effect which shadows that move with your eyepoint.

 

Changing that debug option may improve matters.

Share this post


Link to post
Share on other sites

Hello Steve,

thanks for the answer!

After some trying I found out that the issue occurs when HD shadows are enabled. So it's possible to get VC shadows that don't move when moving only my head, but then it is not HD and this doesn't look great, unfortunately.

Is there a way to get HD shadows working even when using EZCA and trackir?

Share this post


Link to post
Share on other sites

try disabling Adaptive HD ZOOM in debug dialog and report back - note this is identical to the thread below I may try and merge them

Share this post


Link to post
Share on other sites

Reporting back re: disabling HD zoom. Unfortunately, this did not fix the viewpoint dependency issue.

Share this post


Link to post
Share on other sites

thats a shame - ok set the shadowversion to 3 in debug and report back, do all shadows move or just some of them? can you see a defined shadow of for example a window frame or a yoke - are you seeing shadows orrandom light and dark

Share this post


Link to post
Share on other sites

If I leave the HD shadows enabled and just alter the settings to shadowversion 3, the view dependency remains.

 

Note. This is just for legacy aircraft, in case the thread merging suppressed that detail. The normal FSX aircraft and your nice HD shadows work just fine. :smile:

Share this post


Link to post
Share on other sites

But is it just the maddog - I have no problems with any legacy aircraft and HD shadows and multiple people have reported issues with that particular aircraft.

Share this post


Link to post
Share on other sites
But is it just the maddog

This could well be the case, yes. I could only test one other legacy aircraft (which didn't seem like a good test at all) but maybe you have freeware recommendation.

 

The Milton Shupe Dash 7 is mentioned in the manual. Should I pick the FS9 version (there also is a FSX one out) and check? Just point me to a download site and I can test.

Share this post


Link to post
Share on other sites

Hello again,

I just wanted to say that I'm talking about PMDG T7. Without HD everything is fine except for blurry shadow borders. Still have to try unchecking the zoom box in the debug window - I'm not near my computer at the moment:-)

Kind regards,

Chris

Share this post


Link to post
Share on other sites

Then we could be talking about two different issues.  :mellow:  Regarding yours, can you post your settings (maybe just attach the settings file) since the 777 works fine here. In fact, every native FSX aircraft so far does in regard to the viewpoint dependency.

 

So maybe there's something in the settings or the update process didn't run through correctly. Just guessing.

Share this post


Link to post
Share on other sites

Yes sorry in this case merging the threads was a mistake. The Dash 7 doesn't have a VC.

 

This thread lists a whole bunch of freeware with VCs

 

I have Rick Piper's Chipmunk V3 , a IL-18 Sikorsky S-40 and S-42

 

http://forum.avsim.net/topic/424509-fs9-portovers-in-fsxdx10-with-steve-fixer/?fromsearch=1

oh and Milton Shupe's AC520

 

This is Milton Shupe's download page

 

http://www.gjsmith.net/Milton_Shupe/

Share this post


Link to post
Share on other sites

Thanks, Steve. As soon as I've installed and tried one of those planes I shall report back to you.

Share this post


Link to post
Share on other sites

Hello CoolP,

as you are saying that the 777 works fine on your system, could you share your settings for this aircraft, please?

Within "shadow options" I only ticked "reduce fade in poor visibility" (ticked by default) and "Force VC Walls", "HD Shadows" and "EZDOK Compatibility". Furthermore "HD Airliners only" and "Shadow Bias 0.5" is selected. I use Shadow Version 6 (Debug window) and added the new DX10 line in the fsx.cfg referred to in the DX Scenery Fixer 2.5 manual. Of course, I didn't forget to tick the box "aircraft throws shadows on itself" within FSX:-)

It would be great to know, which settings you do actually use in order to get HD shadows within the t7 VC without eye movement dependancy...

Kind regards,

Chris

Share this post


Link to post
Share on other sites

Chris - do you have this problem with other aircraft and does it occur if you don't use TrackIR and does it occur with TrackIR if you disable HD shadows

Share this post


Link to post
Share on other sites

I'm not at my sim system so I couldn't test much (re: legacy aircraft) or make screenshots of my settings (re: 777 shadows) but I will as soon as I am back.

Share this post


Link to post
Share on other sites

Hello Steve,

indeed I only have this problem with PMDG aircraft as far as I tested (FSX SP2; 737 NGX and 777 all updated): The only way to avoid eye movement dependancy of the shadow is to turn off the HD shadow option for me. Then shadows work great in the T7, although as posted before the shadow lines are a bit blurry (due to non-HD, of course), but they don't work at all in the NGX - even when choosing shadow version 5 or turning the zoom option off in the debug window...

It´s a pitty, because when choosing the native 737 the HD shadows really look incredible - what an immersion improvement, Steve!! Still, who wants to fly the native model once you got used to PMDG standards, if you know what I mean...

Maybe it´s one of those issues, your fixer isn`t intended to fix, so I don't want to demand something, I really don't have to - thanks a lot for all your work, Steve!

Share this post


Link to post
Share on other sites

Shadows do not work in the 737NGX see post above - except that the exclusion sphere can cut off some of the square box so you get fleeting shadows. I am really puzzled about the T7 since people are reporting different things - are you both using the latest versions of the 777?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this