Sign in to follow this  
homer

Traffic Causing FS Crash at Dawn/Dusk

Recommended Posts

Hello,

 

I hope this question isn't to vague or needlessly complicated.  I usually have my traffic slider set at 80%.  No problems anywhere in the world, but if I try to load a flight from airports in Southern California - KLAX, KBUR, KLGB, KONT, KPSP and at KPHX at Dawn or Dusk.... the status bar gets to Loading Traffic 92% then it stalls and after a few seconds I get the "encountered a problem must close" popup.

 

If I select the same flight (aircraft/airport) at Day or if I move my Traffic slider to 50% or less, the flight/airport loads fine.   As this only occurs in a certain region and only at Dawn or Dusk, I'm guessing the the problem may be a funky flight plan, AFCAD or a faulty AI Aircraft... but, I'm not sure what to look at if anything. I do have add on airports at those locations.  

 

As I can work around this problem it's not a big deal, but I'm just curious what might be causing the crashes - if you have any ideas.

 

Thanks for reading my question!

Steve

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I would have thought that a faulty AI texture would not be the cause of the sim failing to load. My experience is that they will crash the sim when the texture is called on to be displayed. I could be proved wrong however.

 

The 80% to 50% change in slider is also strange. The FS9 AI slider works by looking at the flightplans where a density % is written in the plan. Most AI plans use a % number below 50% and therefore I would not expect your AI to be any different whether your slider is set to 50% or 80%. The slider is not a "sliding scale", even though it looks like it is.

 

I think it more likely to be a sky or cloud texture causing it. Are you using any addon that replaces the default textures ?

 

Are you loading the defaul cessna at the airport and then selecting a saved flight ?  Maybe the saved flight is the problem. Try deleting it and load the aircraft directly.

Share this post


Link to post
Share on other sites

Thank you for taking the time to reply.....even after all these years - still a learning process for some of us.

 

Peter, you are right about the clouds possibly causing problems.  I had a HD could texture set installed - that I've since replaced - as it was causing crashes for me everywhere. I don't think it is related to sky or clouds in this case as I'm only having this problem in the S. California/Arizona area.

 

Maybe it is a bad AI texture related to one or more aircraft that are scheduled to appear at one of those airports at that time of day.  If I'm creating/starting a flight at dawn at KONT for example and the bad aircraft texture or flight plan is at KPSP or another nearby airport, would it still cause a crash - or only if the faulty plane was at the airport I'm loading?   Not sure how far reaching the errors might be or what that might effect in the general area.

 

I'll play around with this and if I'm able to pinpoint the problem, I'll post the solution.. might help someone else.

Thanks again for your input.  Much appreciated.

Steve

Share this post


Link to post
Share on other sites

I seem to remember having a similar issue with crashes at dawn/dusk. It was not location specific like yours, and I think I solved it by using Flight Environment to load a different set of clouds, and disabling the set I had been using. However mine always occured after I had loaded a plane or in flight. I never experienced the sim failing to load an aircraft.

 

Looks like you may have a "rare" problem. Good luck with solving it. The key, as I am sure you are aware, is to be able to replicate a day/time/location when you will always get the problem. Only then can you really start troubleshooting.

Share this post


Link to post
Share on other sites

 

 


I do have add on airports at those locations.

 

Do you have FS9 updated to FS9.1?

 

Aside from all the good help from Peter. The one additional thought I have is that you might want to look at the night textures involved in your added airports. With that, I also have a question; does this also happen at full night or just dawn / dusk? You might also try changing to a different season and see if the problem still occurs. That might help narrow done the possible causes.

 

Regards,

Share this post


Link to post
Share on other sites

Thanks for your comments, Mel.  I do have FS9.1.  Didn't think about night textures at one of my add-on airports in the area.  Lots of variables here so I'll either just fly SoCal in the daytime or... might try deactivating airports one by one to see if that helps.   Thanks to all for your replies.  You've all helped me.  In the 'grand scheme' it's not a big deal....but you're helping me learn a bit about how it all ties together.  Still amazed by FS9 after all this time.

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this