Sign in to follow this  
freded

FSX AI under Win 7-64 bit

Recommended Posts

I have just installed FSX on a partition running Windows 7-64 bit. I transferred all the Traffic_xxx.bgl files from the FSX installation on my Win 7-32 bit disk to FSX\Scenery\World\Scenery on the 64-bit FSX installation, but no AI aircraft show up.

 

Can anyone please explain what I am doing wrong?

 

Mark

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Help us understand a bit more. 32-bit vs. 64-bit is an OS issue not a disk issue. The system is either 32-bit or 64-bit. How could you move from one to the other?

 

Doug

Share this post


Link to post
Share on other sites

I think he just means he has a backup of the disk when the o/s was 32bit.

Depending on the way the planes were stored, there may also be something in the old fsx.cfg along the lines of:

[Main]
SimObjectPaths.7=C:\MyAIPlanes

 

Share this post


Link to post
Share on other sites

Thanks for your replies.

 

Doug: I have a dual booting setup (using the BIOS to choose which physical disk/OS is active). One disk has Win7-32 bit (my original setup); the other has Win7-64 bit (added later for FSX/P3D only).

 

Devin: Yes. All of them.

 

Steve: Here are the lines in the [Main] section of both the old 32 bit and new 64 bit FSG.cfg (they are identical):-

 

[Main]
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\AI Aircraft
SimObjectPaths.7=SimObjects\CG AI Aircraft
SimObjectPaths.8=SimObjects\CY AI Aircraft
SimObjectPaths.9=SimObjects\GH AI Aircraft
SimObjectPaths.10=SimObjects\HTAI Aircraft
SimObjectPaths.11=SimObjects\MAIW Aircraft
SimObjectPaths.12=SimObjects\PAI Aircraft
SimObjectPaths.13=SimObjects\UGA AI Aircraft
SimObjectPaths.14=SimObjects\WOAI Aircraft
SimObjectPaths.15=SimObjects\###### Aircraft
SimObjectPaths.16=SimObjects\ZZZ AI Aircraft
Location=444,136,1476,904,\\.\DISPLAY1
HideMenuNormal=0
HideMenuFullscreen=1
ProcSpeed=3713
PerfBucket=7
Maximized=2
FIBER_FRAME_TIME_FRACTION=0.33

 

-should they be?

 

Mark


Correction!

 

"SimObjectPaths.15=SimObjects\###### Aircraft" should be "SimObjectPaths.15=SimObjects\###### Aircraft"...

 

Don't know how it got changed betwwen Ctrl-C and Ctrl-V !!

 

Mark


Whoa! The forum changed '######' to '######' again !!

 

Why?

 

Mark


Why won't the forum accept 'W O P' (spaces added )?

 

Mark

Share this post


Link to post
Share on other sites

w o p is a derogatory term that is filtered out by the forum...  You didn't do it on purpose, but that's why it's being filtered.

Share this post


Link to post
Share on other sites

My apologies to any Italians I may have inadvertently offended! :rolleyes:

 

Mark

Share this post


Link to post
Share on other sites

Did you rename trafficaircraft.bgl to trafficaircraft.OFF in your w7 64 install ?

Share this post


Link to post
Share on other sites

Hi JUlian,

 

No. All traffic_xxx.YYY files have .bgl as their extension.

 

There is no file named 'trafficaircraft.bgl'  or 'trafficAircraft.OFF' in FSX\scenery\world\scenery, but a search showed up 'trafficAircraft.bgl.BGD' !

I'll rename this to 'trafficAircraft.bgl' and see if that solves the problem.

 

Watch this space! :smile2:

 

Mark


'Fraid not... Still no AI traffic with the sliders set well up.

 

Any other ideas?

 

Mark

Share this post


Link to post
Share on other sites

-should they be?

yes, and you should have the exact same folders and files in SimObjects.

Share this post


Link to post
Share on other sites

All folders/files in SimObjects are the same - apart from some new additions to 'Airplanes'.

 

Mark

Share this post


Link to post
Share on other sites

I've re-run TTools.exe on all my AI traffic files - but still no AI in FSX on my Win 7-64 bit disk.

 

Are 'Traffic_xxx.bgl' files compatible with Win 7-64 bit?

 

Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this