Sign in to follow this  
marcus300zx

Issue with Caranedo Phenom and ILS

Recommended Posts

I have recently purchased a nice shiney new phenom, but I am finding this aircraft very frustrating.

 

I never had any issues with ILS landing on any default aircraft or even a freeware citation.

 

My problem is that half the time the plane does not pick up the Glidescope and I cannot see any reason for this.

 

I have the NAV1 Tuned into the correct ILS Frequency

I have the Course Set to the correct one

I have the display set to VOR1, which then changes to ILS1 when I get close to the airport

I have the morse code Peeps going.

NAV1 DME MKR switched are all on

APR is turned on when I start to see the glide slope purple dot move, yet the plane will just stay at the current height and fly straight over or past the airport.

 

I use IFR so have been guided down by the ATC.

 

The only thing that might have cause an issue is the fact that the Yellow Traffic was going off due to other traffic being a little close.

 

Failing that is there and easier plane to fly/land that's 6 seater, plush interior and 1000nm range I should get instead

 

I have FS-SE on Win 8.1

 

regards

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have now retried the same approach (Hannover) 7 times an not a single time does it pick up the ILS and start descending.

 

will try another plane and see if the game has become bugged or to dump the phenom and look at something else.

Share this post


Link to post
Share on other sites

I was unable to replicate the issue executing the ILS 32 @ KSTS - Sonoma County transitioned via the Sausalito VOR(SAU)

 

NAV1 to ILS

NAV2 to Santa Rosa VOR

 

AP, FD, SP and ALT HLD

 

Tracked the localizer to GS intercept altitude @1900ft  to MONES (Outer Marker) - I wait until at least 1 dot prior to intercept to hit APR.

 

The plane descended followed the glideslope to about about 350FT where I turned off the AP and hand flew to land.

Share this post


Link to post
Share on other sites

Interesting breakdown, and thanks for the confirmation. I'm just trying to get to grips with ILS and specifically in the Phenom, so nice to know it worked for you.

Share this post


Link to post
Share on other sites

I did find with my Phenom that's putting the ILS frequency on both NAV1 and NAV 2 and flying in at 150kts seemed to work.

 

The problem I was having with hannover was my course was set way out LOL

Share this post


Link to post
Share on other sites

I did find with my Phenom that's putting the ILS frequency on both NAV1 and NAV 2 and flying in at 150kts seemed to work.

 

The problem I was having with hannover was my course was set way out LOL

 

 

You only need to use NAV1 to capture the ILS and make sure you click APR and make sure your in the right mode (LOC, ILS). I have done that a few times myself.

 

Try a little slower possibly ~120kts and flaps 2 or ~115kts flaps 3 if you need the extra bit of flaps to keep the descent coming nicely.

 

glad it worked out for you...this is the fun of part..the learning of a new plane and its little intricacies.

Share this post


Link to post
Share on other sites

I have recently purchased a nice shiney new phenom, but I am finding this aircraft very frustrating.

 

I never had any issues with ILS landing on any default aircraft or even a freeware citation.

 

My problem is that half the time the plane does not pick up the Glidescope and I cannot see any reason for this.

 

I have the NAV1 Tuned into the correct ILS Frequency

I have the Course Set to the correct one

I have the display set to VOR1, which then changes to ILS1 when I get close to the airport

I have the morse code Peeps going.

NAV1 DME MKR switched are all on

APR is turned on when I start to see the glide slope purple dot move, yet the plane will just stay at the current height and fly straight over or past the airport.

 

I use IFR so have been guided down by the ATC.

 

The only thing that might have cause an issue is the fact that the Yellow Traffic was going off due to other traffic being a little close.

 

Failing that is there and easier plane to fly/land that's 6 seater, plush interior and 1000nm range I should get instead

 

I have FS-SE on Win 8.1

 

regards

If you're using FSX, why not consider the Flight1 Citation Mustang.  IMO still the best small jet out there, even after all these years.

Share this post


Link to post
Share on other sites

I have found that flying to fast has a lot to do with it not working properly - been so long since used cant remember what the speed should be - what it should be in real world I would slow it down a bit more from there

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this