Sign in to follow this  
captain420

Odd behaviors w/ Simconnect+EZDOK 1.18.5 in Prepar3d 2.5

Recommended Posts

I am noticing strange things happening sometimes with simconnect and ezdok when using p3d 2.5. At certain times the simconnect popup window will show up and say something about not being able to connect. I don't recall the exact message but it was something along the lines of simconnect can't connect 10 seconds or something. and then EZCA won't show up under the Add-on Menu once P3D loads up. So I have to exit and load up the sim until EZCA finally shows up and is active.

 

I have a lot of add-ons and sometime the sim takes a very long time to load, especially when it loads the terrain, it usually pauses at 6% loading screen for maybe 5 minutes. At this point EZDOK won't be able to connect to Simconnect because its such a long load time. Is there any way to make it so that simconnect can "listen" longer so that it can let EZDOK load up properly?

 

Another issue is sometimes when I'm flying. I will completely lose keyboard shortcut control to switch views. ie (Shift+1, Shift+2, etc). These won't work no more, but I'm able to hit Shift+D to bring up EZDOK's control panel and switch my manually clicking on the different views. If anyone else notice these same issues then it could be related to the 1.18.5 version being a beta.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

The dev needs to increase the link time with simconnect - there are various situations where it might takes more than 10 seconds.

 

 

Vic

Share this post


Link to post

I've had both these thing happen and I do believe they are related to the Beta.  Whether or not they will be fixed if Ver 2 ever comes out is anyone's guess.  I got around the issue by putting a shortcut to EZCA.exe along side my Prepar3d icon.  You can start it after P3D and it will connect with no problem.  Same thing if it locks up.  I press the windows key to see EZCA in the task bar, Right-click it and close it out.  Then click on my EZCA icon it restart it and it generally seems to work after that.  It's a little easier for me, as I have 2 monitors and only run P3d on one of them.  I can then use the other to check charts, open and close programs as needed (EZCA included) and run Avlasoft EFB.

 

It's not a perfect solution, but I hope this helps you out a little,

 

John

Share this post


Link to post

This is perfect timing because I developed this probelm last night.  I installed model matching sets for vPilot which takes ages to load in the sim, and was constantly getting the more than 10 seconds failure to load message.  I'm glad I know what this is about now and Ole thanks for notifying about the 1.18.6 version.

Share this post


Link to post

I've been using the 1.18.6 version and the problem still persists. I have created a shortcut on the desktop and run it after P3d has started. Not ideal but a workaround. 

 

Pete

Share this post


Link to post

If you have FSUIPC, you can add the following lines in your FSUIPC4.ini file in the Modules folder:

 

[Programs]

Run1=READY,"C:\Program Files (x86)\EZCA\EZCA.exe"

 

If you already have other programs starting in this manner, use the next available number (Run2, Run3, etc...). Also, you might have EZCA installed some other place, so make sure that it points to the right location.

 

Then either disable or remove the EZCA entry in exe.xml.

 

Now FSUIPC will start EZCA after the simulator has loaded.

Share this post


Link to post

If you have FSUIPC, you can add the following lines in your FSUIPC4.ini file in the Modules folder:

 

[Programs]

Run1=READY,"C:\Program Files (x86)\EZCA\EZCA.exe"

 

If you already have other programs starting in this manner, use the next available number (Run2, Run3, etc...). Also, you might have EZCA installed some other place, so make sure that it points to the right location.

 

Then either disable or remove the EZCA entry in exe.xml.

 

Now FSUIPC will start EZCA after the simulator has loaded.

 

How does this work if you are using TIR?  Under the 1.18 EZDOK installation you need to start TIR before P3D and that triggers EZDOK to load.     

Share this post


Link to post

I've been using the 1.18.6 version and the problem still persists. I have created a shortcut on the desktop and run it after P3d has started. Not ideal but a workaround. 

 

Pete

 

Pete - I have seen numerous references to v1.18.6 but only see v1.18.5 on the Ezdok beta thread.  Where are you getting v1.18.6 from?

 

Share this post


Link to post

Pete - I have seen numerous references to v1.18.6 but only see v1.18.5 on the Ezdok beta thread.  Where are you getting v1.18.6 from?

 

 

I can't find it either

Share this post


Link to post

 

 


How does this work if you are using TIR?  Under the 1.18 EZDOK installation you need to start TIR before P3D and that triggers EZDOK to load.

 

It works just the same as before. Just start TrackIR first, then start Prepar3D. After Prepar3D is loaded and you're sitting in the cockpit, FSUIPC will start EZCA, which will then connect with TrackIR as usual.

 

The only difference between this method and starting EZCA via exe.xml, is that EZCA is not started until the simulator is finished loading.

Share this post


Link to post

It works just the same as before. Just start TrackIR first, then start Prepar3D. After Prepar3D is loaded and you're sitting in the cockpit, FSUIPC will start EZCA, which will then connect with TrackIR as usual.

 

The only difference between this method and starting EZCA via exe.xml, is that EZCA is not started until the simulator is finished loading.

 

 

Great, I will try this tonight.

Share this post


Link to post

If you have FSUIPC, you can add the following lines in your FSUIPC4.ini file in the Modules folder:

 

[Programs]

Run1=READY,"C:\Program Files (x86)\EZCA\EZCA.exe"

 

If you already have other programs starting in this manner, use the next available number (Run2, Run3, etc...). Also, you might have EZCA installed some other place, so make sure that it points to the right location.

 

Then either disable or remove the EZCA entry in exe.xml.

 

 

Now FSUIPC will start EZCA after the simulator has loaded.

as the saying goes " it did exactly what it said on the tin" great, much better this way, I had some issue with double entries on the task bar, now ok

many thanks

bob

 

Share this post


Link to post

If you have FSUIPC, you can add the following lines in your FSUIPC4.ini file in the Modules folder:

 

[Programs]

Run1=READY,"C:\Program Files (x86)\EZCA\EZCA.exe"

 

If you already have other programs starting in this manner, use the next available number (Run2, Run3, etc...). Also, you might have EZCA installed some other place, so make sure that it points to the right location.

 

Then either disable or remove the EZCA entry in exe.xml.

 

Now FSUIPC will start EZCA after the simulator has loaded.

 

This worked.  thanks

Share this post


Link to post

I also control my EzDok manually with a desktop shortcut. Gets around this issue... losing keyboard commands seems to be linked at least for me to using the ATC panel in P3D. I've stopped using that and now I never have that issue.

 

I actually prefer to run all my addons manually, UT2 is another I just start when I'm ready. If it loads in exe.xml you can load it manually yourself generally.

Share this post


Link to post

I can't find it either

 

Thought I posted a link directly to the post with the download link? 

Oh well, you probably have by now :)

 

Looks like the problem is still there with 1.18.6, though..

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this