Sign in to follow this  
xandirules

Saitek X45 - Not been able to adjust controls

Recommended Posts

I really need help...

 

I'm a total beginner and having a hard time trying to configure Prepard...

 

Installed Version 2.5.12945.0 and latest Saitek drivers.
At first no problem at all.

I was able to assign some functions  to my extras buttons on X45. Everything was OK…

Them I reduced sensitivity for elevator.
Everything normal for a couple of days and all of sudden P3D stopped fully recognizing X45.
I say fully because I still I have all the assignments working OK except for the sensitivity on yoke.
When I tried to re-trim sensitivity I realized that P3D control/settings was not seeing my X45 anymore: only mouse yoke options were available…

Tried to disable and re-intall Saitek drivers.

 

NO effect…

 

Did a clean install.

This time installed FSUIPC4 and assigned the same functions.

Installed OrbxFTXGlobalBASE130.

MigrationTool_2.5.1.728.

A scenery to Sao Paulo (Brazil), SBSP, SBGR

 

In every step a tried to configure Saitek X45 and everything was OK.

But, out of the blue, without any new install of addons or similar, between a test fly and another, when I tried to fine tune some assignments... KABOOM!! 

P3D control/settings was only seem mouse yoke agian.

 

Although all my previous assignments were functioning well, there is no way to access configurations to my joystick.

 

Any help is very welcome.

Thanks in advance,

 

JC

 

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I had related problems with my X52 and only mouse joke settting beeing available through P3D menu. It has sometthing to do with scenery load - Don't ask me why.

 

Solution: Open/Create a flight in a less demanding scenery (default airport, default scenery) and use a default aircraft. When I am doing this, my X52 is back again in P3D menu and I can change the settings.

Share this post


Link to post

JC I have used both the X45 and X55 in all versions of P3Dv2 without issue.

Share this post


Link to post

Thanks a lot NEMO!!!

Your tip worked!!

 

First I got out my installed airport, chosen default Bonanza and set La Guardia  as the airport: no result, same problem...

 

Then I went to a very tiny air strip in the middle a Canadian forest: IT WORKED!!!

Now I have set it as my RESET FLIGHT to my old X45!!   ^_^

 

Thanks alot

Share this post


Link to post

Good that it worked for you too.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this