Sign in to follow this  
DAL1850

Ground Scenery Shadows vs Building Flicker

Recommended Posts

Does DX10 Fixer currently offer a solution for the violent flickering of ground scenery shadows that are cast onto other building surfaces? Everything I've seen so far in the forums has been with respect to aircraft/VC shadows. I am curious to know if the ground scenery shadows benefit from some tweak or adjustment in either the driver (nvidia) or DX10 Fixer?

 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I experimented once but it don't seem to work for anyone else other than me. I will check for you if it's still in the code.

Share this post


Link to post
Share on other sites

Ok well you could try setting GroundShadows=1 to the [General] section of your DX10.ini file in AppData\Local\DX10SceneryFixer

but no guarantees of success.

Share this post


Link to post
Share on other sites

Made the change you suggested. When I restarted DX10Fixer it prompted me to update my effects folder. I re-enabled ground shadows in fsx.cfg and I am happy to report I don't have any flickering! Now you have TWO success stories. This should be a featured part of the tool!

 

The only downside at the moment is that ground shadows do not seem to inherit the shadow boost or contrast adjustment that aircraft shadows receive; the building shadows are very faint at times - most notably at low sun angles - while their aircraft counterparts are rather dark by comparison creating an odd effect.

 

Any chance of resurrecting this code officially and promoting it to full glory?

 

J

Share this post


Link to post
Share on other sites

Are you telling me now that those nasty spikes reaching up into the indefinite heights of FSX world are now gone using the DX10 Fixer? This would be great news, as I only turned off ground shadows so far due to this little bug and I never tried to turn them on again...

Share this post


Link to post
Share on other sites

I didn't have any "spikes" to speak of. I did experience some issues with ground shadows at one of my third-party (Orbx) airports however that was causing some terrain unpleasantness, but the default airports seem OK.

Share this post


Link to post
Share on other sites

Hi,

I am not quite get the expected behavior but still the ground shadow is flickering. Which settings should I have in the Shadow Options in the DX10 Controller v2.8 tool (I also have enabled this setting 'GroundShadows=1' in the DX10.ini file)?

 

Thanks for you help!

Share this post


Link to post
Share on other sites

If you are looking at default scenery it may work in some cases but with any payware scenery you will still see flickering.

 

There is a reason it isn't documented which is that I decided that it didn't work very well.

 

I would advise turning the option off.

 

I will see if it can be improved for a future release.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this