Sign in to follow this  
Martin Connor

RTO and Taxi Problems on FSX

Recommended Posts

I've always noticed that once pushed back, the initial power required to get the aircraft moving is minimal, but as soon as any braking.or thrust reduction is needed, getting the a/c moving again needs a lot more power.  

 

I discovered by accident that switching from RTO to Off reset the braking effect, and we were back to low thrust inputs again. I originally thought that it was RTO itself causing the problem, but then I realised the problem occurred even with RTO off, but could still be cured by cycling RTO.

 

Anyone have a clue if this is a local problem, or is fixable?

 

Martin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


Anyone have a clue if this is a local problem, or is fixable?

 

Do you have hardware brakes, or a brake axis assigned?

Share this post


Link to post
Share on other sites

I have Saitek rudder pedals Kyle

 

Those have caused issues in the past. Unplug them and see if the issue is resolved.

 

Additionally, if you have them set up through FSUIPC, put the FSUIPC.ini file on the desktop to force it to rebuild a new one in the FSX folder. If it fixes it, then it was a corrupted .ini. If not, put the old .ini back in the FSX folder and overwrite the one it just rebuilt.

 

There's also this:

http://forum.avsim.net/topic/405764-ngx-saitek-rudder-pedals-issue/

Share this post


Link to post
Share on other sites

Thanks again Kyle, I'll try experimenting with the pedals when I get home.  I don't use FSUIPC Paid version, so basically FSX and Vista standard.

Share this post


Link to post
Share on other sites

I have no problem running the Saitek pedals directly into the sim (FSX or P3D), in fact I only now use FSUIPC for the VAS remaining logger because I added the Warthog this year and use it to map buttons and various controls.  I have a very small dead zone for brakes just to be conservative and never tested it at different values.

Share this post


Link to post
Share on other sites

Hi Martin,

 

I have had the same problem in the past - albeit with a different brand of pedals

 

I apply brakes and after releasing them, even though the 'brakes' caption disappears it is still as if the brakes are applied.

 

I resolved it (from memory) by moving the brake axis sensitivity to full and null zone sliders to zero.

 

I have heard of using the FSUIPC method although I have not tried it.

 

If you do come across another fix I'd be interested to hear of it. Good luck!

Share this post


Link to post
Share on other sites

Proved that the problem relates to the rudder pedal usage, but using FSUIPC (Free addition). I can see no evidence of the pedals sending spurious signals.  I'll try Scott's solution tomorrow and hope that cures it.

 

Thanks to all for your responses.

Share this post


Link to post
Share on other sites

I've tried all the options suggested, and no deal I'm afraid, though I did find a new and exciting way of Blue Screening by setting the Rudder Pedals (Saitek) to Bands - 0-100%.  Checked Saitek site for new drivers - download site down -.  Guess I'll just continue trying to taxi without using the brakes.  

Share this post


Link to post
Share on other sites

 

 


Guess I'll just continue trying to taxi without using the brakes.

 

What about bumping the null zone up off of the bottom end? Set it above 0% so that any noise is covered.

 

Are you using the MS default calibration screens, or are you using Saitek software?

Share this post


Link to post
Share on other sites

I've tried using both methods.  What I find interesting is that FSUIPC Logging shows no activity from the rudder pedals when brakes are off, so I am rather discounting noise. I assume that when using the toe brakes, variable amounts of braking should be available.  Since the default B key is either on or off, did this variable braking get included as normal behaviour?  I am guessing that most people find it works ok, but then I lived with it until I realised the effect of toggling the Autobrake switch on the PMDG.  I'm also wondering if my take-off rolls have been excessive due to this drag, which doesn't heat up the brakes as it should.

 

Going to see if the PMDG 747-400 also does this.

Share this post


Link to post
Share on other sites

No sign of this behaviour from 747-400.  I think I remember reading that PMDG added some modifications to improve ground friction modelling.  Could something derail this with the Saitek Rudder?

Share this post


Link to post
Share on other sites

No sign of this behaviour from 747-400.  I think I remember reading that PMDG added some modifications to improve ground friction modelling.  Could something derail this with the Saitek Rudder?

Again, the Saitek rudder works just fine with the PMDG products.  I have a flight in progress and peeked at my calibration settings (not using FSUIPC or the Saitek SST interface) and my sensitivity is max and null zone is 1 in the simulator.  Only trick was the sense reversal but that is pretty obvious.

Share this post


Link to post
Share on other sites

I had this problem for ages. Fixed with some info from the DCS forums.

 

HKEY_CURRENT_USER\System\CurrentControlSet\Control \MediaProperties\PrivateProperties\DirectInput\VID _06A3&PID_0763

 

Just unplug the pedals before deleting that key, then plug them back in after your done.

Mash the toe brakes to their full extent a few times, same with the rudder.

 

Last number in the reg-key may be different. For most the last number is either a 3 or 4.

 

Also look up DXTTweak on google.

Share this post


Link to post
Share on other sites

Many thanks Patrick,

 

Deleting the registry entry worked.  Unplugging deleting and replugging didn't quite hit the mark, had to quit out of Profiler and restart it, and also reset the controls in fsx, but in the end the result was a fix.

 

Regards Martin

Share this post


Link to post
Share on other sites

Martin,

 

Glad you got it sorted in the end. That same problem drove me mad for a long time!

 

And thanks Patrick for the extra info :-)

Share this post


Link to post
Share on other sites

Again, thanks to all who contributed their thoughts.  I'm old enough to remember being totally on one's own when trying to resolve these kind of problems, and when drivers came in the mail, or if one was blessed, by CompuServe.

 

Not so happy days :)

 

Regards

Martin

Share this post


Link to post
Share on other sites

Whilst the previously described registry fix worked when applied to my Vista 32 based system, my new Windows 7 64bit seemed reluctant to bend to my will.  I then discovered a conversation in which the user changed the rudder peddle sensitivity to max, i.e. sliders to the far right.  I tried this, and discovered that it worked just fine, when prior to that, I had the brakes coming on and staying on when applied.

 

I wonder if removing the registry key somehow resulted in the sensitivity setting being deleted, and the firmware setting itself to max.  Anyway, I thought I'd add this addendum to the solution.

 

Share this post


Link to post
Share on other sites

 

 


or if one was blessed, by CompuServe.

 

And later, for a while, Prodigy!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this