Sign in to follow this  
stonelance

Flight Toolkit 1.1.13

Recommended Posts

http://www.flighttoolkit.com/Downloads/FlightToolkit_1_1_13.zip

 

Changes:

- Fixed problem where sometimes pending aerocaches would not show up

- Added conversion of generic buildings to procedural buildings

- Changed LC mapping conversion to properly take into account the TerrainCoverage data from FSX

- Change ContentConverter to handle disabling addons that depend on FSX World and re-enable them after new conversion is finished

- Changed how ObjectBrowser works so it should be much faster

- Add loading graphics in some places in the UI (just ObjectBrowser right now)

 

A lot of these changes are old and I haven't run them in a while, so if you notice a breaking change, please let me know.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Steve. 

BTW:  I have more "pending" aerocaches I would like to add, but the last few times I was in the editor, it would not accept them.  I believe it would not connect to the database.

Share this post


Link to post
Share on other sites

Well when I went into the Avsim Flight forum today, I saw that Toolkit 1.1.13 became available  from stonelance. I downloaded it, installed it, and ran the ContentConverter. (It took between 35 and 40 mins. to run) It seems to have a problem: Here is how it ended, and a copy of the ContentErrors.

 

MyuVhj7.jpg

 

ALZTx0n.jpg

 

Hope this is helpful Steve?

 

I would like to add that a short time back I had a problem with my Norton 360, and had to re-download it. Before, I had to temporarily turn off Norton to install/uninstall the toolkit, however now it no longer has that problem.

Share this post


Link to post
Share on other sites

Thanks, the pending aerocaches show up correctly now. There are definitely more airport buildings around and the terrain coverage seems to be improved; the trees in the desert and the tiles full of trees I reported last time are gone now.

 

On the other hand, I feel that texture remapping is worse than before; the airport backgrounds in Western Europe don't seem to be correct anymore and even in hard winter there are too many green spots around. Is this a result of your ongoing attempts to improve texture remapping?

 

As a side note, I think the addons depending on FSX World were disabled correctly, but one of the old FSX World files was still in use by another process which resulted in the conversion failing the first time. After manually uninstalling FSX World, the conversion worked fine.

Share this post


Link to post
Share on other sites

Can you post examples that are broken along with lat\lon?  I don't think I made any changes to the texture mapping, although it could be a side effect of the autogen changes.

Share this post


Link to post
Share on other sites

 

Well when I went into the Avsim Flight forum today, I saw that Toolkit 1.1.13 became available  from stonelance. I downloaded it, installed it, and ran the ContentConverter. (It took between 35 and 40 mins. to run) It seems to have a problem: Here is how it ended, and a copy of the ContentErrors.

Exact same error here.

BTW, I don't use Norton if you were suggesting it could be interfering.

 

Edit: Just back to note. The first conversion attempt failed to complete, however after rebooting and runing again, it did complete and the game appears to work.  I still saw some of the same logged errors on the second run.

Share this post


Link to post
Share on other sites

You can ignore that error.  It happens at the end while trying to re-enable the addon.  You can just manually go to Addon Manager and enable it yourself.  I'll have it fixed for the next version.

Share this post


Link to post
Share on other sites

@ winjimon   “BTW, I don't use Norton if you were suggesting it could be interfering”

 

No, in toolkit 1.1.12 and early versions I had to turn off my Norton 360 to install/uninstall the toolkit because it was detecting a false bug. Shortly after toolkit 1.1.12 came out, I had to re-download my Norton 360 and what I downloaded was what they are replacing 360 with. My wife’s computer has the latest version of “Norton Security” and when you open it, that its name. My Norton is the same as hers, but mine is still named Norton 360. :o

 

I will try running it again and will let you know happens. :smile:

Share this post


Link to post
Share on other sites

Thanks Steve. 

BTW:  I have more "pending" aerocaches I would like to add, but the last few times I was in the editor, it would not accept them.  I believe it would not connect to the database.

 

Yes, that's true, I just tried to add an aerocache, but it failed with an error 530.

 

 

Can you post examples that are broken along with lat\lon?  I don't think I made any changes to the texture mapping, although it could be a side effect of the autogen changes.

 

A wrong airport background at 48.690225, 9.215655, I think it was correct in the last version:

 

stuttgart_zpsb6yu9vtm.jpg

 

 

I think the green spots around 48.377119, 9.242404 are using the wrong texture in hard winter (February):

 

alb_zpsh3kajr8c.jpg

 

 

There are also some problems in winter (July) in the southern hemisphere (-21.799647, -43.386609) where there shouldn't be any snow around:

 

brazil_zps5uhlk1mn.jpg

Share this post


Link to post
Share on other sites

I re-ran the ContentConverter but had to leave just about the time it was going to complete, so I did not get see that. My computer crashed after it had completed, and no, it did not cause it to crash. This time there was no ContentErrors and I fired it up and all is well. B)

 

I really need to rebuild this old computer! :lol:

Share this post


Link to post
Share on other sites

The problem with creating new pending aerocaches is related to the FTP host I am using, and the fact that they seem to be pretty useless.  I told them about the problem months ago, but apparently they haven't fixed it.  I'll have to get on the phone with them again, but that probably won't happen for another month or two.

Share this post


Link to post
Share on other sites

This is what I found with Sacramento, Ca. and the brown spots are associated with parks.

 

 

 

ibYlM39.jpg

 

DRsc1kP.jpg

 

i6QvYBv.jpg

 

:o

Share this post


Link to post
Share on other sites

Is anyone able to install an older version of the toolkit and delete their FSX conversion and reconvert it there to see if it is different? I just tried looking at the LC mappings for 1.1.12 and comparing to 1.1.13 and I didn't see any obvious differences that are related to the parks in Sacramento.

Edit: Ok I think I have found the problem. Apparently the texture set ids of the higher priority lclookups can override\replace the texture sets of the fallbacks, even if the matching LCMap is found in the fallback. This seems really weird to me, but should be easy to fix. I just need to make sure all the texture set ids in the FSX conversion don't overlap with ones from Flight content.

 

Edit: I have a bunch of it fixed now, but there are still some issues with a couple LCs and the south hemisphere winter textures.  I'll take a look at them when I get a chance.

Share this post


Link to post
Share on other sites

Ok, so I think I managed to solve all of the LC issues that I know of.  At least all my test cases seem to be working.  There is still the autogen issue with snowy trees showing up in the southern hemisphere in winter.  I also noticed an issue in the southern hemisphere with water classes, so I'm going to look into that.  Hopefully once I have the water issue sorted out I will have a new version.  The autogen issue will have to wait a while though...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this