Sign in to follow this  
Noah101

Anti-Aliasing issues

Recommended Posts

I used to have really good anti-aliasing but for some reason after an Nvidia update I think the anti-aliasing quality has gone down a lot and jagged edges are very noticeable. I have tried using the same settings I previously used and other profiles and I can't get it to the quality that it used to be. I'm currently running p3d v2.5 and I would GREATLY appreciate any help that you guys can give me!!! 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I was going to create a new topic but I think this will fit in here nicely. I agree with the OP that the AA needs help.
 

So far I read through the forums that the best is to Setup P3D with AA to 8 samples, FXAA OFF, Mip Maps depend on your tastes, AF 16X and use Nvidia inspector to clear things up.

 

In NVI I set "Enhance Application" and the only other change is Transparency to 4X Sparse Grid Super Sampling. Now that is all people seem to be talking about. But with that set it still seems 8/10 clarity wise. Is that all we can get with P3D?

 

Or are there more options to set, because I agree even with 4X SGSS it still needs help. 

Share this post


Link to post

Angelo - the MSAA setting in P3D must be the same as the NVidia SGSS setting.8 is too high. Set MSAA to 4 and in NI set SGSS to 4 and AA to enhance application. Should be better. Some people report better results with override application setting - try both

 

Vic

Share this post


Link to post

Angelo - the MSAA setting in P3D must be the same as the NVidia SGSS setting.8 is too high. Set MSAA to 4 and in NI set SGSS to 4 and AA to enhance application. Should be better. Some people report better results with override application setting - try both

 

Vic

Quote from Neogaf.com :

 

"Please keep in mind that whenever you use SGSSAA you should always match the number of MSAA samples used to the number of SGSSAA samples used. 8xMSAA + 4xSGSSAA will usually have lower quality than 4xMSAA + 4xSGSSAA.

This is because SGSSAA gets it's sample coordinates from the MSAA samples. So if you have more MSAA samples than SGSSAA samples the SGSSAA samples will not be placed in the ideal locations.

 

Also you cannot have more SGSSAA samples than MSAA samples for the same reason as I'm sure you've guessed.

Even though it uses MSAA sample coordinates using additional coverage samples will reduce the effectiveness of SGSSAA by changing the grid pattern so that the MSAA samples are placed closer to the center of the pixel (which is a less ideal location).

This is why I advised 4xMSAA + 4xSGSSAA not 16xAA (4xMSAA + 12xCSAA) + 4xSGSSAA."

 

So if 4x MSAA + 4x SGSS is to much for your system, do not set SGSS to 2x, but do not use it and set MSAA to a higher value...

 

I did it also the wrong way so I now only use MSAA set to 8x as I have 4 cloudlayers at max density enabled...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this