Sign in to follow this  
cat

PIC 737 Evolution

Recommended Posts

I've just installed a new copy of Pic 737 Evolution on my new

computer. It runs well, but I can't enter the radio frequency of 109.5

for arrival airport Heathrow 27L. I used to click on the radio

frequency button, but nothing moves, when I do this with

the new PIC 737. Any ideas?

Peter Sydney Australia

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

can you eneter other frequencies, have you tried the mouse scroll wheel. Havnt flown it in awhile cant remember hiw it is done.

Share this post


Link to post
Share on other sites

No, can't enter any frequencies, by any clicking or scrolling!

Thx!

Any other ideas? Any links?


Thx for that Mjr!   The scrolling works, but I want to set to 109.5

The decimals number will set, but the whole number will only go down to 118!

Any other ideas!

Share this post


Link to post
Share on other sites

The nav radios default to AUTO mode for INS updating - select the AUTO button to manual and you should be fine.

 

Andy

Share this post


Link to post
Share on other sites

No Andy. It makes not difference. It still won't go down to 109!

Any other ideas? Thx

Share this post


Link to post
Share on other sites

That's great Tj! I've now successfully set NAV1 (manual) to 109.5. Is that all I have

to do in order to do an autoland, pressing VOR LOC & then APP, on final into Heathrow?

Share this post


Link to post
Share on other sites

Both NAV radios set to the ILS freq, both course read outs set to the inbound ILS heading per the FMS approach page, APP set on the AFDS and both A and B autopilots selected.

 

Andy

Share this post


Link to post
Share on other sites

Thx Andy. I can only set the right hand NAV radio to 109.5. When I cross to the left

little NAV on Auto side. There seems to be only 2 numbers available on the whole

number side. I get to the Heathrow left turn to incept the VOR, everything seems in

place, but it just sails past with no interception. Any ideas?

Thx for your help!

Share this post


Link to post
Share on other sites

Great Andy! Captured the LOC. Pressed APP, but it wouldn't start the descent. It had to land from there manually? Any ideas?

Share this post


Link to post
Share on other sites

Were you under the GS? Usual procedure for any ILS interception is to capture the LOC first while you're well under the GS and only select APP once the LOC is captured. Check the manual for AFDS operation and the following is helpful.

 

http://www.smartcockpit.com/download.php?path=docs/&file=B737-Automatic_Flight_Systems_Summary.pdf

 

What are the Flight Mode Annunciators on the ADI reading when you're intercepting the ILS?

 

Without more info or a screenshot, it's hard to know what you're doing wrong.

 

Andy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this