Sign in to follow this  
Hark1

FSX not recognizing joysticks

Recommended Posts

Hi,

I have looked in other threads but none of the fixes have worked. All my power management options are off.

When I minimize fsx, (e.g. to activate a pro atc x flight) the joystick will not work. Sometimes it is recognized in fsx controls, but doesn't work. But normally, it isn't recognized in fsx controls, nor does it work.

I am using Windows 8.1 and the Mad Catz V.1 stick.

Any ideas? Thanks

Harry Karmel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have had this issue for as long as I can remember. I have never thought that it was a problem.

 

If in windowed mode and you go and do something outside the window, the aircraft keeps flying but the joystick doesn't work. As soon as you go back and click the window with the mouse everything works again. I should say that is not the same as the pause on task switch option which freezes the whole thing. 

 

Anyway, why would you want to use the joystick when the window is minimized and you can't see what the aircraft is doing?

Share this post


Link to post
Share on other sites

I have to minimize fsx to start pro atc x for good atc but when I "unminimize" fsx the joystick won't work.

Share this post


Link to post
Share on other sites

I have just tried to replicate the problem but can't, mine works perfectly now even when i open another application.( I use 2 monitors.)

 

From your first post you appear to have tried the suggestions in the massive thread on this in windows 8. Joystick drop out was always a problem with windows 8 but for me it happened after I had been flying for some time. I solved it by getting the registered version of FSUIPC. Otherwise I haven't a clue

 

Rather than have to do this why don't you consider updating to windows 10? It won't cost anything and people have reported that they no longer have a problem.

I have one last thought and it is so simple that I think you must have tried it unless you are new to FSX. Does the sim pause altogether when you reopen the window?.In which case the pause on task switch option has been checked.

Share this post


Link to post
Share on other sites

Apparently FSX doesn't run well with Windows 10, and with my system, I am not taking that chance!! FSX does pause when I change window and clicking on the fsx window again and again still does not fix the problem

Share this post


Link to post
Share on other sites

Hit P when starting again to unpause it .Also there is an option to pause on task switch in FSX under General in the Settings just untick it and it won't pause.

Share this post


Link to post
Share on other sites

Apparently FSX doesn't run well with Windows 10, and with my system, I am not taking that chance!! FSX does pause when I change window and clicking on the fsx window again and again still does not fix the problem

You may well be onto something there. I have Windows 10 Pro, but I've lost count of the number of times, the USB-connected MS Sidewinder Force Feedback 2 joystick all of a sudden just drops connection,and I have to re-boot or re-connect at the USB port. Never ever happened in the 5-7 years I ran FSX on a Windows 7 Pro machine. Is it any wonder that folks are so critical and so sceptical that Microsoft has just rushed this platform out and hopes to reach a publicity coup 1 billion landmark?  Professionals I have spoken too reckon it is still buggy.more than 7 months down the roadmap since it was touted to the world.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this