Sign in to follow this  
masterofdoh

Blurred Scenery

Recommended Posts

So, I know that this was discussed many times, but I've tried nearly every fix for this and there is no change. Sometimes the textures are excellent ( http://imgur.com/O6412iY ) and sometines they are horrible ( http://imgur.com/99c4cDV ) The crazy thing is, that both pictures are taken in the same flight. I've tried Low-End, Mirgrange and High end settings in P3D, made any tweak to my p3d.cfg that i was able to find, but nothing worked. Also, independent to the settings and twaks i do, the performance is horrible. In an Aerosoft Airbus A318 at FL 380 over Italy I have at maximum 10 FPS. Tweaks and seting changes don't made a difference. Even a reinstall hasn't fixed it.

My Hardware:

AMD FX-8350 with 8 Cores @ 4GHz , a GTX 680 with 4GB RAM, 16GB DDR3 RAM, Win 10 Pro. 

My addons are: 

 

EZDok, ORBX Global/Vector/Open LC, Rex 4 + Soft Clouds, Active Sky Next, Approaching Innsbruck X (Via the Migration Tool) and the AS Airbus. My P3D.cfg is :

[AContain]
LabelColor=FFFF0000
LabelDelay=1000
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelAirspeed=0
ShowLabelAltitude=1
ShowLabelContainerId=0
ShowLabelDistance=1
ShowLabelFlightPlan=0
ShowLabelHeading=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabels=1
ShowLabelTailNumber=0
ShowUserLabel=0

[ATC]
AutoOpenAirTrafficWindow=1
PilotVoice=0
UsePilotVoice=1

[ATTACHMENTS]
AutoWeaponSwitching=False
HighlightDuration=1.000000
IgnoreAttachmentForces=True
IgnoreAttachmentWeight=True
UnlimitedCountermeasures=False
UnlimitedWeapons=False
WeaponHighlight=False

[BUFFERPOOLS]
PoolSize=250000
UsePools=1

[CONTROLS]
Controls_Current=Standard
Controls_Default=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64

[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
ChangeTime=4.000000
FullScreen=False
FullScreenAutoFill=True
FullScreenExclusive=False
FXAA=0
InfoBrakesEnable=True
InfoCountermeasureEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
InfoWeaponSystemEnable=True
MSAA=4
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
SSAA=0
TEXTURE_BANDWIDTH_MULT=110
TEXTURE_FILTERING=2
TransitionTime=4.000000
TRIPLE_BUFFER=0
UPPER_FRAMERATE_LIMIT=0
VSYNC=0
WideViewAspect=False

[DISPLAY.Device.NVIDIA GeForce GTX 680.0.0]
Mode=1920x1080x32

[DynamicHeadMovement]
HeadMoveTimeConstant=1.000000
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
RollAccelOnHeadLat=0.010000
RollAccelOnHeadRoll=0.100000
YawAccelOnHeadLat=-0.100000

[FACILITIES]
CITY=
COUNTRY=
GTL_BUTTON=4096
STATE=

[FlightPlanMap]
LineWidth=2

[GRAPHICS]
AIRCRAFT_REFLECTIONS=1
ALLOW_SHADER_30=1
BLOOM_LEVEL=2
BUILDING_SHADOWS_CAST=0
BUILDING_SHADOWS_RECEIVE=0
CLOUD_SHADOW_CAST_DISTANCE=1
CLOUD_SHADOW_TEXTURE_SIZE=512
CLOUD_SHADOWS_CAST=1
COCKPIT_HIGH_LOD=1
CONTENT_NO_SHADOW=0
DAWN_DUSK_SMOOTHING=1
EFFECTS_DISTANCE=0
EFFECTS_QUALITY=0
EXTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_RECEIVE=0
GROUND_SHADOW_TEXTURE_SIZE=2048
HDR=1
HIGHMEMFIX=1
IMAGE_QUALITY=0
INTERIOR_SHADOWS_CAST=1
INTERIOR_SHADOWS_RECEIVE=1
LANDING_LIGHTS=0
LENSFLARE=0
MIPMAP_VC_PANELS=1
NUM_LIGHTS=4
OBJECT_SHADOW_CAST_DISTANCE=1
See_Self=1
SHADER_CACHE_VERSION=1
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_ULTRA=12
SHADOW_QUALITY=1
SIMOBJECT_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_RECEIVE=1
STALE_BUFFER_THRESHOLD=1024
TERRAIN_SHADOW_CAST_DISTANCE=1
TERRAIN_SHADOWS_CAST=1
TERRAIN_SHADOWS_RECEIVE=1
TESSELLATION=1
Text_Scroll=1
TEXTURE_MAX_LOAD=512
TEXTURE_QUALITY=3
VEGETATION_SHADOWS_CAST=0
VEGETATION_SHADOWS_RECEIVE=0

[INTERNATIONAL]
ASLAT=2
ASLON=0
MEASURE=0

[JOBSCHEDULER]
AFFINITYMASK=254

[Main]
DisablePreload=1
FIBER_FRAME_TIME_FRACTION=0.01
HideMenuFullscreen=1
HideMenuNormal=0
LabelsSupported=Airplane, Helicopter
Location=440,129,1480,908,\\.\DISPLAY1
Maximized=2
SimObjectPaths.0=C:\Program Files (x86)\Flightport\FlightPort Dynamic Library - P3DV2x\
SimObjectPaths.1=SimObjects\Airplanes
SimObjectPaths.10=SimObjects\Countermeasures
SimObjectPaths.2=Aerosoft\Split X\simobjects
SimObjectPaths.3=SimObjects\Rotorcraft
SimObjectPaths.4=SimObjects\GroundVehicles
SimObjectPaths.5=SimObjects\Boats
SimObjectPaths.6=SimObjects\Animals
SimObjectPaths.7=SimObjects\Misc
SimObjectPaths.8=SimObjects\Submersible
SimObjectPaths.9=SimObjects\Weapons
SimObjectPathsRemarks=These entries were automatically added from SimObjects.cfg by Migration Tool. Set RepairConfig=0 in MigrationTool.cfg to disable.
User Objects=Airplane, Helicopter, Submersible, ExternalSim

[Misc]
Com_Rate=7


[PANELS]
IMAGE_QUALITY=1
PANEL_MASKING=1
PANEL_OPACITY=100
PANEL_STRETCHING=1
QUICKTIPS=1
SAVE_AND_LOAD_PANEL_STATE=0
UNITS_OF_MEASURE=0

[PointOfInterestSystem]
CycleSetting=0

[REALISM]
AllowEngineDamage=True
AutoCoord=False
AutoTrim=False
CrashDetection=False
CrashTolerance=1.000000
CrashWithDyn=True
GEffect=False
General=1.000000
GyroDrift=False
GyroEffect=1.000000
ManualLights=True
OnCrashAction=0
PFactor=1.000000
RealMixture=True
StressDamage=True
Torque=1.000000
TrueAirspeed=False
UnlimitedFuel=False

[RECORDER]
RecordAirportVehicles=True
RecordAITraffic=True
RecordLeisureBoats=True

[SCENERY]
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=2
MAX_ASYNC_BATCHING_JOBS=2
POP_FREE_AUTOGEN=1

[SIM]
OPTIMIZE_PARTS=1
SYSCLOCK=0

[SlewTextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2

[SlewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2

[SlewTextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2

[SOUND]
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_LOD=0
SOUND_QUALITY=2
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}

[STARTUP]
DEMO=0
LOAD_SIMDIRECTOR=1
LoadWindow=1
STARTUP_DEMO=

[TERRAIN]
AUTOGEN_BUILDING_DENSITY=2
AUTOGEN_VEGETATION_DENSITY=2
DETAIL_TEXTURE=0
ENABLE_BATHYMETRY=0
LOD_RADIUS=4.500000
MESH_RESOLUTION=21
SWAP_WAIT_TIMEOUT=2
TESSELLATION_FACTOR=85
TEXTURE_RESOLUTION=26
UseGlobalTerrainView=True
WATER_CLARITY=30
WATER_DETAIL=2
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_CLOUDS=1
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFRACT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_USERAIRCRAFT=0

[TextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
WindDirectionAndSpeed=1,6

[TextInfo.2]
FrameRate=1,1
FuelPercentage=1,4
GForce=1,3
LockedFrameRate=1,2

[TextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
FuelPercentage=2,4
GForce=2,3
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
WindDirectionAndSpeed=1,6

[TrafficManager]
AirlineDensity=0
AIRPORT_SCENERY_DENSITY=0
FreewayDensity=0
GADensity=0
IFROnly=0
LeisureBoatsDensity=0
ShipsAndFerriesDensity=0

[USERINTERFACE]
Map_Orientation=2
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
RestoreTimeOnMove=0
SHOW_MISSION_CAPTIONS=0
SHOW_SCENARIO_WINDOW=1
SITUATION=C:\Users\David\AppData\Local\Lockheed Martin\Prepar3D v2\Prepar3D_Default

[VirtualCopilot]
VirtualCopilotActive=0

[Weather]
AdjustForMagVarInDialog=1
CLOUD_COVERAGE_DENSITY=6
CLOUD_DRAW_DISTANCE=5
DETAILED_CLOUDS=1
DisableTurbulence=0
DownloadWindsAloft=0
DynamicWeather=0
MaxGustRampSpeed=200
MaxGustTime=500
MaxVarRampSpeed=75
MaxVarTime=50
MinGustRampSpeed=1
MinGustTime=10
MinVarRampSpeed=10
MinVarTime=5
OPTIMIZE_DENSE_CLOUDS=0
THERMAL_VISUALS=0
TurbulenceScale=1.000000
VolumetricFog=1
WeatherGraphDataInDialog=0
WindshieldPrecipitationEffects=1

[MULTIPLAYER]
condAccoutPassword=0

 

 

Thanks in advance,

masterofdoh

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Make sure you don't have affinity mask in your P3D cfg. If you have any FSDT products the add on manager may have entered that into your cfg file. Delete it and see if that fixes your problem. 

Share this post


Link to post

There is no slider, just a checkbox...

No, there is a checkbox and a "factor" slider for tesselation

Share this post


Link to post

Did you try deleting your P3D.cfg so it will roll back to default settings?

Share this post


Link to post

So, I've found the slider ( I've must hev been blind) but I tied it on full/med/low already but nothing changed... I'll delete the Aff. Mask from the .cfg and will leave the tesselation on medium and give it a try...

Thanks for all your answers... I'll post the result later...

Thank you

masterofdoh

Share this post


Link to post

On my (not so up to date) system, setting the slider on the lowest setting resolved my blurries issue. I guess your mileage will vary. I would suggest testing with a light-on-resources aircraft in an area which you find is prone to blurries, while keeping all other variables (other than the tessellation slider) equal. I would also suggest setting it at the lowest setting first to see if there is any appreciable change.

Share this post


Link to post

Ok, now it is getting crazy.... I've started a flight with the suggested settings and got this : http://imgur.com/aI2VHPl

Any Ideas?

Masterofdoh

 

I believe if you just deleted your affinity mask setting and nothing else, your blurries would have disappeared. I'm also guessing it was affinitymask=14.  

Share this post


Link to post
 
 

I have similar system and addons as yours (i5-2500K and GTX 970), but use the PMDG aircraft and also UT2 with 100% full schedule.  I'm running P3D3.1 at 4K and get decent frame rates (18-25 in cockpit) even with ORBX SoCal/NorCal and payware SFO and LAX airports.  Without UT2, those go up 3-5 fps.

 

I have noticed the textures are a bit more blurry and sometimes when changing from one view to another, it looks like your screenshot, but usually improves after a few seconds.  I've also noticed some long frames where the scenery will pause for a half second even though frame rate is high.  I've also noticed a lot more tearing that previous versions of P3D/FSX.  However, these issues are really only a problem on exterior views.  If I just stay in cockpit, not a problem.

 

I've tried all the CFG tweaks posted online one at a time and none of them do anything.  I would recommend starting with default settings and default P3D.cfg, dial everything back to minimum using the in game settings and then start turning things on/up one at a time, but don't do ANY manual editing of the CFG file.  This includes the tweaks that FSDT manager will add if you let it.

 

I have frame rate set to unlimited and V Sync disabled.  These seem to be the two that have greatest impact on frame rates so start there.

Share this post


Link to post

I have severe blurries as well in P3D v3.1. I've turned down or off every slider in the display settings (except Lod Radius which is maxxed out) and fly with fps unlimited, getting 150-250, so it shouldn't be something else in the sim slowing texture loading down. I fly the default King Air 350 which is a very light addon. 

 

What I've tried so far with no success:

- Various FTFF settings

- Affinitymask=14 on and off (I've got 4 cores and HT turned off)

- Tried 5-6 different NVidia drivers (Clean install and only drivers (no NVidia bloatware installed)

- Various affinity settings in the Windows Task Manager

- Tessellation enabled and disabled

- Various levels of Tessellation (Low, medium etc.)

 

Still, ground textures, coastlines, roads etc. remains blurred and loads very slowly (you can see the textures load (pop up) in mountains as you get closer). 

Share this post


Link to post

Still, ground textures, coastlines, roads etc. remains blurred and loads very slowly (you can see the textures load (pop up) in mountains as you get closer).

 

Maybe you are giving too much resource to frame rates and not enough to texture loading.

What happens when you frame rate limit to 60 or 30?

 

gb

Share this post


Link to post

GBOZ,

 

Thanks for your reply. I've tride with fps locked at 20 and 30. Made no difference in texture loading. Even tried flying in som areas with low resolution mesh, and the same happens. Textures load very slowly and pops up on the mountain side as I fly by. Very distracting.

Share this post


Link to post

GBOZ,

 

Thanks for your reply. I've tride with fps locked at 20 and 30. Made no difference in texture loading. Even tried flying in som areas with low resolution mesh, and the same happens. Textures load very slowly and pops up on the mountain side as I fly by. Very distracting.

 

I think that is simply how it is. I never experienced anything else. Unfortunately. Some people just don't see this or aren't annoyed by this. We all have a different threshold when it comes to annoying things: some call something smooth while others would call it choppy. Some call late loading textures blurries and others don't know what you are talking about. This has always been one of the biggest problems when it comes to talking about performance on a forum. We all have different expectations, needs, hopes, etc.

 

BTW Things like this usually pop up when a new version has been released because with a new version almost everyone pays a lot more attention to detail. It's the same when you buy a new computer: a lot of people report things running worse than on their old computer: usually this simply is because they now pay attention to things they had gotten used to on the old PC. I myself have problems with fps right now which are a lot lower with 3.1 than they were with 3.0... at least... that's what I think. Probably it's just the same.  :wink:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this