Sign in to follow this  
MindYerBeak

alt-enter 3 times in a row and CTD

Recommended Posts

I installed p3d v3.2  and noticed if i alt-enter   3 times in a row the sim crashes (ctd). It happens every time.

 

 

Any of you experiencing the same thing ? any workaround ?

 

Thanks

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What was the scenario (i.e., aircraft, scenery, weather?, time of day)?  If the scenario was different from the default, then it could be an addon that doesn't like what you are doing.  Was there an error created?  This way we can try to recreate to see if it happens to us too.

 

I just tried to create the CTD using the default scenario.  I tried 20 times with alt+enter and no crash.

 

Best regards,

Share this post


Link to post

What was the scenario (i.e., aircraft, scenery, weather?, time of day)?  If the scenario was different from the default, then it could be an addon that doesn't like what you are doing.  Was there an error created?  This way we can try to recreate to see if it happens to us too.

 

I just tried to create the CTD using the default scenario.  I tried 20 times with alt+enter and no crash.

 

Best regards,

 

No.It was default flight and default plane. I tried again and  it took me  over 10  times  alt-entering before the  screen went black but it sure did. No error created.

Share this post


Link to post

 If I hit ALT-ENTER to go full-screen P3D crashes every time. This is repeatable 100% of the time.

 

Anyone  has a fix for this ? I tried many different drivers.No go.

Share this post


Link to post

I am also getting this problem. If i go from full screen to windowed mode I get a black screen but I can hear p3d running in the background.

 

I thought it was with fspassengers but it doesnt seem to be exclusively when that is running. Has anyone found a solution?

Share this post


Link to post

 

 


Has anyone found a solution?

 

You all appear to be the first to report this "bug".  Certainly you have reported this to Lockheed Martin but I would also recommend you bring P3D back to the Default Configuration.  You must be able to prove you are not using tweaks in your p3d.cfg or have anything loaded via the dll.xml or exe.xml or have add-ons loading in your scenery.cfg.  Here's how:

 

Return to your default configuration

  • Move your simulator’s config to a temporary folder or delete the configuration.
  • Move your scenery.cfg to a temporary folder.
  • Move your dll.xml and exe.xml to a temporary folder (they are found in the same folder as the folder where your simulator’s config is located as these files are not installed by default)
  • Restart your simulator.  The p3d config and scenery.cfg will be rebuilt.  You are now basically in the default configuration of your simulator.

Try to replicate the black screen using alt+enter repeatedly.

  • If simulator is now working and no black screen, move the dll.xml and exe.xml, if applicable, in the temporary folder back to the proper folder.  Restart your simulator and try to replicate the black screen using alt+enter.
  • If simulator is still working w/o a black screen, move the scenery.cfg from the temporary folder and return it to the scenery.cfg folder and overwrite the default scenery.cfg. Restart your simulator and make sure there are no black screens.

If the screen continues to go black after hitting alt+enter repeatedly, then the problem is most likely your video card drivers.  Uninstall and reinstall the drivers.

 

If this still does not fix the problem, then make sure you are running P3D in Administrative Mode:

 

Run in Administrative Mode –Right click on the P3D icon on your desktop and select ‘Properties’. Click on the Compatibility Tab, then look all the way down at the Privilege Level and make sure “Run this program as an administrator” is checked.  Also, click on "Change settings for all users" and make sure the box in the Privilege Level is checked.  This will make sure it is compatible with all users.

 

If you installed any product using the Estonia Migration Tool (EMT), uninstall or disable the product you installed with this tool.

 

Use the System File Checker to look for corrupt/missing files (AKA - SFC \scannow) - If you are unfamiliar with the procedures to scan your system, please go to the following link for procedures depending on your Windows version.  Basically, you will use the Windows Search and search for ‘Run’, look up in the menu and open up your ‘Run’ command in elevated mode (right click and open with Administrator Rights).  You then enter SFC \scannow and the press the enter key.  This program will then scan your system for corrupted or missing files and replace them if any are found.

 

Hope this helps track down the issue so that you can fix it.

Share this post


Link to post

This has happened with FSX also. It is a driver/graphics issue. Much like continually hitting the S key to keep switching views, eventually you will overload the graphics and have an issue. If it were a pure P3D issue, we all would have been having the issue all along.

 

If it happens EACH time you try to alt enter - you might consider a reinstall because it is not normal for P3D.

 

Vic

Share this post


Link to post

I am also getting this problem. If i go from full screen to windowed mode I get a black screen but I can hear p3d running in the background.

 

I thought it was with fspassengers but it doesnt seem to be exclusively when that is running. Has anyone found a solution?

 

Yes . For me the solution was to lower msaa to 4 samples.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this