Sign in to follow this  
Dragonmount

Concorde X recent update question

Recommended Posts

So I went back and read the Facebook release and it said "all" forms of FSX, which should include SE, so I ask the obvious question does it? Because I keep getting a .dll error and it refuses to load no matter how many which ways I try installing it. My question is, am I probably doing something wrong with the install if it is working now in SE?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

So I went back and read the Facebook release and it said "all" forms of FSX, which should include SE, so I ask the obvious question does it? Because I keep getting a .dll error and it refuses to load no matter how many which ways I try installing it. My question is, am I probably doing something wrong with the install if it is working now in SE?

 

I think you need to install the three legacy simconnects.  Have you done that?  Check the installation manual.

 

Mike

Also, SE only works with the latest version, which can be downloaded from FSLabs.

Share this post


Link to post
Share on other sites

Do u use SweetFX ? - if so then switch it off ( had similar problems and SFX was the reason )

Share this post


Link to post
Share on other sites

I haven't read any reviews of the new version . Hoping for someone from here to make one. How do you like it Mike777?

Share this post


Link to post
Share on other sites

I think you need to install the three legacy simconnects.  Have you done that?  Check the installation manual.

 

Mike

Also, SE only works with the latest version, which can be downloaded from FSLabs.

I actually don't know, I'll attempt to install them and see what happens thanks for that advice!

Share this post


Link to post
Share on other sites

I actually don't know, I'll attempt to install them and see what happens thanks for that advice!

 

Hi, Dragonmount,

 

I took a look at the manual and actually I don't see anywhere that you need to install the three legacy simconnects.  AFAIK it doesn't do any harm to install all of them. 

 

You do need a recent version of the installer file downloaded from FSLabs.  You should be able to download from them even if you have a boxed version.  In fact they released an update a few days ago, which I have been unable to download so far.

 

Mike

Share this post


Link to post
Share on other sites

Where do I get the updater?

It's a bit complicated.  If you purchased from FSLabs,  you should probably start by logging into the account where you bought it and see what is showing there.  It looks like if you bought it more than 365 days ago you need to pay for a $4.99 download service.  I think if you bought it from Aerosoft or anyone selling the boxed version, as I did, you have to pay that fee. 

 

Take a look at this thread, scroll down a little. 

 

http://forums.flightsimlabs.com/index.php?/topic/6397-fsx-customers-in-the-past-365-days-please-note/

 

If you have problems e-mail them -- they responded to my difficulty downloading very quickly and resolved the issue.

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this