Jump to content

Sign in to follow this  
mikealpha

MCE/PF3 voice recognition trouble

Recommended Posts

I`m struggling to get the MCE/PF3 voice recognition to work in P3D.

 

First of all a general remark : I could not get any readback to work before changing the PF3 Hotkey 10 key assignment to something more common than the default CTRL-SHIFT-\. It worked after changing it e.g. to SHIFT-c. Maybe has to do with my German keyboard and special characters.

 

1. All works well until the taxi clearance. No readback recognized. It is not quite clear what exactly has to be readback. E.g. PF3 now includes the taxiway names. Do they have to be readback ?

 

2. There are documents for native FS ATC and RC4 handling, but not for PF3. A clear document or transcript for PF3 would be very useful.

 

3. I have huge problems to get some words recognized, e.g. the word “decimal“.

I did the initial voice training, the ATC voice training using trainer.exe, added decimal as custom word.

If I open MS speech training, I get “decimal“ recognized 10 out of 10 times. But not in MCE. Whatever I say, or even using my Smartphone speakers to send “decimal“ from a native english source, MCE recognizes really absurd stuff.

So getting e.g. a readback like “121.8, Callsign“ recognized is impossible.

Might be my “German english“, but speech recognition e.g in FS2Crew works without problems.

I don`t really know what to do, are

there any hints what else I could do ?

 

Would love to get it to work and get MCE plus the PF3 plugin also for XPlane.

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

I`m struggling to get the MCE/PF3 voice recognition to work in P3D.

 

First of all a general remark : I could not get any readback to work before changing the PF3 Hotkey 10 key assignment to something more common than the default CTRL-SHIFT-\. It worked after changing it e.g. to SHIFT-c. Maybe has to do with my German keyboard and special characters.

 

1. All works well until the taxi clearance. No readback recognized. It is not quite clear what exactly has to be readback. E.g. PF3 now includes the taxiway names. Do they have to be readback ?

 

2. There are documents for native FS ATC and RC4 handling, but not for PF3. A clear document or transcript for PF3 would be very useful.

 

3. I have huge problems to get some words recognized, e.g. the word “decimal“.

I did the initial voice training, the ATC voice training using trainer.exe, added decimal as custom word.

If I open MS speech training, I get “decimal“ recognized 10 out of 10 times. But not in MCE. Whatever I say, or even using my Smartphone speakers to send “decimal“ from a native english source, MCE recognizes really absurd stuff.

So getting e.g. a readback like “121.8, Callsign“ recognized is impossible.

Might be my “German english“, but speech recognition e.g in FS2Crew works without problems.

I don`t really know what to do, are

there any hints what else I could do ?

 

Would love to get it to work and get MCE plus the PF3 plugin also for XPlane.

 

Mike

Not sure what MCE version you have. I assume it's the latest which works quite well with PF3.

 

There is actually a document. Click Start->All Programs->Multi Crew Experience->Interfacing PF3/PFE ATC (a pdf document).

 

I doubt the issue is with speech recognition.

 

One has to be aware, it's very important for MCE to work out the current call-sign as well as the type of flight. I mean airliner with "airline_name + flight_number" or general aviation traffic with call-signs such as Beech November Sierra Five Tango Mike".

 

There's 2 speech grammars. One tuned for airliners, and another for GA.

 

If for some reason MCE can't read PF3 settings and it ends up with wrong type of flight or call-sign, it might end-up loading the wrong speech grammar.

 

The result, you'll see a lot of garbage recognised as the speech engine tries to match your speech to the grammar structure.

 

We try to make the grammar files as flexible as possible. It's not fun being told to speak only a specific sentence. A real world pilot should be able to use it without the need to look up the kind of messages to transmit.

 

What call-sign are you using?

 

Is PF3 installed on same machine as MCE or on a networked machine?

Share this post


Link to post
Share on other sites

Yes, I have the latest version, downloaded a few days ago. I have seen the pdf summary of the phraeseology possibilities. But I meant something like IFR RC4 FS9&FSX ATC.pdf , actually a summary or transcript of an entire flight. Just to have some sort of minimum phrases to be safe to get a flight through and avoid guesswork.

 

What I`m not sure about, what is the minimum MCE wants me to readback to avoid getting stuck?

 

I use the Easyjet or Ryanair callsign, e.g. Easy 472.

Clearance, Push and Start, all goes well until the instruction to contact Tower at <frequency>. All gets stuck there.

What exactly am I supposed to readback ? If I speak e.g. “Tower on 121 decimal 8 , Callsign“ or just “121 decimal 8, Callsign“, MCE detects just rubbish.

If I change to Tower frequency and try to contact, nothing happens.

 

So, it seems MCE doesn`t recognize anything to send Hotkey 6 to PF3.

Would be great if there would be a logfile, at least to get an idea why it gets stuck.

 

MCE is on the same PC than P3D.

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

Tried three more times, now six in total. No success.

 

Once again clearance request, clearance readback, change to ground, request push and start, “ready for taxi“, all works well and gets recognised.

 

After the taxi instruction, “taxi to holding point runway xx via taxiways x,y,z“ it`s stuck again. No matter what I readback, it does not continue. Noticeable because the PF3 taxi monitor is silent.

 

If I start taxi anyway, I get the instruction to contact Tower anyway, shortly before reaching the holding point.

 

But then silence again. Readback or not ?

 

If I change to Tower frequency and try to check in, nothing. I tried roughly 10 phrases, e.g. something like “Tower, good morning, Callsign, ready for departure, or at holding runway xx“. No chance.

If I press the PFE Hotkey 6 manually at that stage, I get takeoff clearance.

 

Frustrating, need help.

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

What exactly am I supposed to readback ? If I speak e.g. “Tower on 121 decimal 8 , Callsign“ or just “121 decimal 8, Callsign“, MCE detects just rubbish.

 

Both these variations should be supported. It doesn't matter whether you spell the word "decimal", "point" or not, as long as you utter 3 digits minimum.

 

I think you have a point.

 

Looking at the current speech grammar for PFE, it appears, when you acknowledge handoff, you are expected to start with any of these (it should be optional)

 

roger copy next frequency
      roger copy next controller
      roger copy next contact
      roger copy contact
      roger copy call
      roger next frequency
      roger next controller
      roger next contact
      roger next control
      roger continue with
      roger transferring to
      copy roger next frequency
      copy roger next controller
      copy roger next contact
      copy roger contact
      copy next frequency
      copy next controller
      copy next contact
      copy next control
      copy continue with
      copy transferring to
      roger transfer to
      roger going to
      roger over to
      copy over to
      roger changing to
      roger change to
      copy changing to
      copy change to
      switching over to
      changing over to
      switch over to
      copy going to
      copy transfer to
      roger copy
      copy roger
      roger contact
      copy contact
      continue with
      roger monitor
      copy monitor
      switching to
      changing to
      change to
      transferring to
      transfer to
      next control
      next frequency
      next contact
      next report
      next center
      next call
      continue
      over to
      monitor
      roger
      copy
      contact
      switch
      transfer
      with
      call
      going
      over

 

Example: "Contact Tower on XXX, callsign (goodbye)"

 

Which isn't flexible enough.

 

Normally, we allow variations that don't start with words above, nor include the word "Tower" or "Ground". Words between parenthesis are optional.

 

Tower on XXXX callsign (goodbye)

One eighteen seven callsign (auf wiedrsehen)

 

 

Will get the PFE specific grammars updated this week.

 

Thanks for reporting this. It was an oversight.

  • Upvote 1

Share this post


Link to post
Share on other sites

OK, thanks for the info.

 

In the meantime I completed a flight with MCE / RC4 without problems, so at least my voice recognition seems to be basically OK.

 

There still seems to be something special with MCE and PF3.

 

What would I have to readback regarding the taxi instruction? Seems PF3 expects a readback to continue with taxi monitoring. However, to continue, does MCE at this stage expect a readback at all ?

 

“taxi to holding point runway xx via taxiways x,y,z“

 

I tried roughly ten different phrases to no avail, e.g. just  "Copy, Callsign, taxi holding point runway XX" , or "Copy, Callsign, taxi holding point runway XX via taxiway X,Y,Z"

 

And just to make sure, for initial Tower contact, does MCE send Hotkey6 instead the normal Hotkey0 ? I am wondering, why none of my initial Tower contact phrases get recognised. Whatever I say, nothing visible in the text window. Usually if MCE "listens", it at least reminds to say the correct callsign in the text window ??

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

 

 


If I change to Tower frequency and try to check in, nothing. I tried roughly 10 phrases, e.g. something like “Tower, good morning, Callsign, ready for departure, or at holding runway xx“. No chance.
If I press the PFE Hotkey 6 manually at that stage, I get takeoff clearance.

 

This could be an indication MCE isn't reading simulator state as expected.

 

With PF3, before accepting takeoff request (even when recognized and displayed on-screen), MCE will ensure aircraft is on ground before sending hotkey 6.

 

Go to <Sim> tab in MCE user interface and check the green font is reporting aircraft on ground and engines ON or OFF as they are (may take up to 10 seconds to update).

 

If not, be aware when Windows UAC is enabled, and there is no requirement to disable it, you MUST

 

1 - Install MCE to default C:\Program FIles (x86)\ folder

2 - Set "fsx.exe", "Prepar3D.exe" and/or "fs9.exe" to run as adminisrator.

 

This will ensure data flows seamlessly between MCE and the simulator.

Share this post


Link to post
Share on other sites

I confirm 'on ground' and 'engines ON' at the <Sim> tab. UAC is completely disabled, MCE and P3D are installed on the same disk, both set to 'run as admininstrator'

Not sure if that's really the problem though. MCE/RC4 connection works without problems.

 

However, if there's anything you want me to test or try any beta, let me know ! Would love to get it to work, and buy the same for XPlane.

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

I confirm 'on ground' and 'engines ON' at the <Sim> tab. UAC is completely disabled, MCE and P3D are installed on the same disk, both set to 'run as admininstrator'

Not sure if that's really the problem though. MCE/RC4 connection works without problems.

 

However, if there's anything you want me to test or try any beta, let me know ! Would love to get it to work, and buy the same for XPlane.

 

Mike

 

There will be a patch in 2 to 3 days.

Share this post


Link to post
Share on other sites

 

 


There will be a patch in 2 to 3 days.

 

Ok, excellent, thanks for info.

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

Thanks for the patch, Gerald. Definitely one step further. But not quite there yet.

 

Clearance request, clearance readback, handoff readback, chekin with next frequency, everything working. But ...

 

I get taxi instruction e.g. at EGBB : “taxi to holding point runway 3, taxiways W-D-E-S. I taxi to the holding point accompanied by the PF3 taxi monitor. Shortly before reaching I get the handoff to Tower. Readback ok, checking in with Tower Ok, using “Tower good morning, callsign, ready for departure“. Ok, gets recognized in text window. Answered with “stand by“. I reach the holding point, confirmed by taxi monitor.

But then I get another taxi instruction (tower frequency active) to the holding via taxiway S ?!

 

Does MCE really send Hotkey #6 at this stage, instead of Hotkey #0 ? Because if I press Hotkey #6, I get the correct takeoff clearance.

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

 

 


Does MCE really send Hotkey #6 at this stage, instead of Hotkey #0 ? Because if I press Hotkey #6, I get the correct takeoff clearance.

 

Yes, it does.

 

However, it only sends it after checking aircraft is on ground and engines are running.

 

I believe your issue is related to the specific use of MCE+GSX and ATC features exclusively.

 

In order not to impact on performance, MCE doesn't make the same amount of requests to the sim when the main features are disabled.

 

Will have to either remove that check or eventually query the state of engines at that specific time.

 

With the "Real Crew Coordination" feature enabled for instance, there are about 50 bits of information that change often (speed, heading, altitude, etc....), MCE gets about once every 2 seconds. Not so when feature is disabled because it's deemed unnecessary.

 

You could try enabling all MCE features, which is the most tested scenario, and see if it fails to send Hotkey 6.

 

In any case, it's something that can be sorted, one way or another. No mystery there.

Share this post


Link to post
Share on other sites

Will have to either remove that check or eventually query the state of engines at that specific time.

 

With the "Real Crew Coordination" feature enabled for instance, there are about 50 bits of information that change often (speed, heading, altitude, etc....), MCE gets about once every 2 seconds. Not so when feature is disabled because it's deemed unnecessary.

 

You could try enabling all MCE features, which is the most tested scenario, and see if it fails to send Hotkey 6.

 

I tried enabling all MCE features, but have more difficulties regarding the voice recognition then. I could not even get "ground, Callsign, ready to taxi" correctly recognized anymore. Also understanding my callsign clearly is way more reliable with only ATC (and GSX) recognition active.

 

I assume, this is because of the much bigger word recognition pool when everything is active in MCE ? Also occasionally the FO picks up GSX ground communication and understands unintended commands (like IRS off or other weird stuff).

 

Anyway, the other solution you mentioned above, would be much appreciated for the time being. I'm OK to test anytime.

 

I think I'm almost there :-)

 

Mike


ugcx_banner.png

1. A320 home cockpit (Skalarki, VierImPott).  Main PC : I7-8700K@4.7 GHz, NVidia GTX1080Ti. Second PC for Displays : I5-8400, GTX 1060Ti.

2. P3D V4, FSLabs A320. Asus ROG Laptop I7-4720HQ, GTX 980M

Share this post


Link to post
Share on other sites

 

 


I assume, this is because of the much bigger word recognition pool when everything is active in MCE ? Also occasionally the FO picks up GSX ground communication and understands unintended commands (like IRS off or other weird stuff).

 

Correct. When you hold PTT switch down, MCE would typically suspend all other speech contexts (crew coordination, checklist, UI voice control), then enable the ATC commands. A process that may be instant, but could also take up to half a second or so. The opposite happens when you release PTT. One shouldn't start transmitting ATC stuff until MCE has switched to ATC mode (the continuous humming background noise). And never release PTT switch before the complete message was transmitted.

 

As for the weird stuff, you don't have to worry, as every critical action is safe-guarded against accidental trigger. FO will never turn IRS, or engines OFF unless you confirm following his prompt. Keeping silent means, ignore whatever command was recognized accidentally. 

 

Try to trick him to retract the gear on ground, or extend the flaps beyond flaps extension speed and you'll see what I mean.

 

With regards PF3 interfacing, will get the check for engine status removed in next update. 

 

Will have a new "mce.exe" beginning of next week to address that (Monday or Tuesday at the latest).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...