Sign in to follow this  
Slayer

Milviz P-38 Redbull edition FREE

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

I don't have any classic warbirds in my hangar, more of a jet fan. But hey when a respected software house gives away one of these classics for free, of course I'll try it! THANK YOU!

Share this post


Link to post
Share on other sites

I have been considering a twin engine warbird for a while, now I can try this beautiful bird for free!  Thanks, MilViz!!!!!!!

Share this post


Link to post
Share on other sites

Yes a very nice gift from Milviz. Thank you Milviz. Just one issue I have found. It works perfectly with starting up the two engines and following the guide in FSX. Not so in P3D v3.3. Doing the partially automatic mode with the Ctrl E, starts only the left engine. And using the full manual mode just does not start the engines.The mixture levers flutter, the prop levers do not want to move forward, and the one prop lever flutters up and down when Ctrl E is used as start. And I cannot get any of the magneto switches on, except for the left engines left magneto, which only switches on with Ctrl E mode.

I have followed all advice on the Milviz forum, and by setting the mixture with the Ctrl-Shift-F4 for full rich option. I have no issues with the default P3D Lockheed P-38's nor the payware addon Lockheed P-38's from FlightSim Developers. So it must be with this model. I know with this becoming a freeware giveaway, there is no support, but hopefully Milviz patch it, if enough of us ask them to fix it for the newest versions of P3D.

 

Regards

Andrew Brown

Share this post


Link to post
Share on other sites

Auto start works but you have to manually click off the mixture lock then it will work just fine.

Share this post


Link to post
Share on other sites

Auto start works but you have to manually click off the mixture lock then it will work just fine.

Hi Slayer

 

Thanks for advice. I think I tried this, but maybe not. I'll follow your advice and see how I go. I'll report back if I succeeed or don't. Have you tried this in P3D v3.3.

 

Regards

 

Edit - 12 July 2016 SAST 16H00

 

Ok, tested and it works in P3D v3.3. Once one has clicked the mixture lock buttons everything settles down and one can even perform the full manual start, or the semi-auto Ctrl E start. It seems P3D is a lot more finicky or should I say fastidious, in the startup process. Thanks for the tip Slayer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this