Sign in to follow this  
Skybus2000

Not so SweetFX

Recommended Posts

Evenning,

 

I foolishly installed SweetFX, I then tried to uninstall it deleting the files, each time now when I start FSX I get no actual sim display, please see screenshot, however the engines sounds everything can be heard running just no display.

 

I tired deleting FSX.CFg and let it built another one but no luck.

 

Thanks

 

Jake

 

 

 

   Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.160408-2045)
           Language: English (Regional Setting: English)
System Manufacturer: To Be Filled By O.E.M.
       System Model: To Be Filled By O.E.M.
               BIOS: BIOS Date: 05/10/12 11:37:19 Ver: 04.06.05
          Processor: Intel® Core i5-3450 CPU @ 3.10GHz (4 CPUs), ~3.1GHz
             Memory: 8192MB RAM
Available OS Memory: 8088MB RAM
          Page File: 3311MB used, 12860MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: Using System DPI
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 32bit Unicode

 

 

   Card name: AMD Radeon HD 6800 Series
       Manufacturer: Advanced Micro Devices, Inc.
          Chip type: AMD Radeon Graphics Processor (0x6738)
           DAC type: Internal DAC(400MHz)
         Device Key: Enum\PCI\VEN_1002&DEV_6738&SUBSYS_03C61043&REV_00
     Display Memory: 4095 MB
   Dedicated Memory: 1008 MB
      Shared Memory: 3087 MB
       Current Mode: 1280 x 1024 (32 bit) (60Hz)
       Monitor Name: Generic Non-PnP Monitor

 

 

Post%20Sweet_zpsiayohrek.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The AVSIM CTD Guide (see link in my signature) provides information on what files to remove.  Look at page 30 for the d3d9.dll.  You have to remove all of those files.

 

Best regards,

Share this post


Link to post
Share on other sites

Thanks Jim,

 

I did follow the instructions but still have the same problem.

 

With kind regards

 

Jake


Sorry just to clarify are those files located within FSX maon folder ?  or in the whole Win7

Share this post


Link to post
Share on other sites

Thanks Jim,

 

I did follow the instructions but still have the same problem.

 

With kind regards

 

Jake

Sorry just to clarify are those files located within FSX maon folder ?  or in the whole Win7

 

You removed the files from the main fsx folder and you still have the issue?

Share this post


Link to post
Share on other sites

 

 

That's correct the only file I found was d3d9.dll and I obviously deleted the whole Reshades and FXSweet folder. These were all located within the main FSX directory.

The file was d3d9 both dll and text

Share this post


Link to post
Share on other sites

That's correct the only file I found was d3d9.dll and I obviously deleted the whole Reshades and FXSweet folder. These were all located within the main FSX directory.

The file was d3d9 both dll and text

Make sure d3d9.dll is removed.  It is a DirectX hack and does not belong in the main FSX folder.  When FSX is started, all "dll's" in the main fsx directory are loaded.  When SweetFX is installed, all of the files are placed into the main fsx folder and not a separate SweetFX folder unless someone wrote an .ini file and placed it in the main FSX folder directing FSX to look into a SweetFX folder.

 

Best regards,

Share this post


Link to post
Share on other sites

 

 

It's removed from FSX main folder the only remaining ones are in the main Windows systems, I have placed the FSX disc and tried a 'repair" but still the same problem

Share this post


Link to post
Share on other sites

It's removed from FSX main folder the only remaining ones are in the main Windows systems, I have placed the FSX disc and tried a 'repair" but still the same problem

Make sure DX10 Preview is enabled under Graphics tab.

 

This topic might be of interest too - http://www.avsim.com/topic/480970-all-dark-when-loading-aircraft-in-fsx/

Edited by Jim Young
Added link to a topic

Share this post


Link to post
Share on other sites

 

 

I install FSX Accler pack and the problem goes away, however when I install SP2 it will not allow me, can I leave SP2 out, but most Addons ask for SP2

Share this post


Link to post
Share on other sites

I install FSX Accler pack and the problem goes away, however when I install SP2 it will not allow me, can I leave SP2 out, but most Addons ask for SP2

Why are you installing SP2 on top of Acceleration???   Not needed, in fact will probably mess up the install.

Share this post


Link to post
Share on other sites

I believe I always has SP2 installed but for some reason I also thought I had FSX Accel too for the SDK, but I just installed FSX Accel and it asked me to remove SP2.  Its all working well now but the problem is FSX Accel takes some space within FSX where as SP2 didnt.

 

I just tried and removed FSX Accel and back to square one with the black home screen, I installed SP2 and it installed and then I ran FSX and still the black home screen as mentioned previously, but when I remove SP2 and install FS Accel all ok.

 

Really strange, welcome any thoughts however I thank Jim and anybody else who have trie to help

Share this post


Link to post
Share on other sites

FSX Acceleration is the payware version of SP2.  FSX Acceleration was released first to get as much money as possible before releasing the freeware version, SP2.  SP2 does not have the aircraft and scenery and scenarios offered in Acceleration.  You cannot install both or your sim will not work properly.

Share this post


Link to post
Share on other sites

 

 

Thanks Jim, in respect of FSX Acceleration is there a way to remove unwanted aircrafts such as the military jets and some scenery that comes with FSX Accel?

 

When I remove FSX Accel I still get the original issue despite installing both SP1 and 2, I then remove both SP 1 and 2 installing FSX Accel and the problem goes but end up with more space being taken.

 

I guess you cannot have everything but curious as to why FSX Accel corrects the problem but SP2 doesn't

Share this post


Link to post
Share on other sites

 

 


Thanks Jim, in respect of FSX Acceleration is there a way to remove unwanted aircrafts such as the military jets and some scenery that comes with FSX Accel?

 

Just go into fsx/simobjects/airplanes/FA-18 and P51Racer and fsx/simobjects/rotorcraft/EH101 and delete them and that should eliminate the aircraft.  SP2 is specially coded so as making it impossible to use these payware aircraft.  The scenery should be the same except it is updated textures that are optimized for better performance.  Not sure what else was installed with Acceleration.  There are new missions too but they don't take up space.  You just won't be able to use them as some will require the P51 or the EH101 or FA18. 

 

I believe some add-ons require Acceleration but most require SP2 or Acceleration.  If you uninstall Acceleration, you will have to download and install SP2.

 

Best regards,

Share this post


Link to post
Share on other sites

 

 

Many thanks Jim for your valuable advice, I believe some files within FSX may have been corrupted so I bit the bullet and did a complete fresh removal and install of FSX, all seems to be working fine with both SP1 and 2 without the need of installing FS Accelerate.

 

Amazing how many addons there are, its taken a long time to re install most add ons, hopefully won't have to do that again.

Share this post


Link to post
Share on other sites

 

 


Amazing how many addons there are, its taken a long time to re install most add ons, hopefully won't have to do that again.

 

Sometimes the best option is to bite the bullet and reinstall.  I've had to do it several times too.  Just take it slow reinstalling the addons.  Make sure you run fsx (at least, just start up and then close) after each install.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this